0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 1078 Просмотров
*

Lepiloff

  • Захожу иногда
  • 202
  • 1 / 0
При обновлении примерно на 87% появляется сообщение Fatal error: Cannot redeclare class JControllerLegacy in /var/www/u0051229/public_html/site.ru/libraries/legacy/controller/legacy.php on line 0 . После этого только бэкап помогает, сталкивался ктонить?
« Последнее редактирование: 10.12.2015, 14:10:07 от Lepiloff »
*

Gosha5767

  • Захожу иногда
  • 446
  • 22 / 0
Re: Ошибка при обновлении с J 2.5.8 до J 3.4
« Ответ #1 : 10.12.2015, 13:16:16 »
Нужно проводить миграцию по этапно.
Первый этап: обновить Joomla 2.5.8 до 2.5.28
Второй: Удалить все сторонние расширения
Третий: Joomla 2.5.28 до Joomla 3.4.5
Четвертый: Загрузка расширений совместимых с Joomla 3.х
Примечание: Некоторые расширения можно не удалять, если существует возможность их обновления и они не будут мешать процессу миграции.
Чистка сайта от дублей в Яндекс и Google.
Удаление ссылок (битых и внешних) на сайте.
Миграция Joomla 1.5 до Joomla 3.хх
*

Lepiloff

  • Захожу иногда
  • 202
  • 1 / 0
Re: Ошибка при обновлении с J 2.5.8 до J 3.4
« Ответ #2 : 10.12.2015, 14:09:30 »
да понятно это, все сделано, но что то ругается, вот на что конкретно вопрос?
*

zeus07

  • Давно я тут
  • 634
  • 8 / 0
Re: Ошибка при обновлении с J 2.5.28 до J 3.4
« Ответ #3 : 05.02.2016, 02:55:17 »
Аналогичная ошибка при обновлении с 2.5.28 до 3.4.8

Код
Fatal error: Cannot redeclare class JControllerLegacy in /home/***/***/***/libraries/legacy/controller/legacy.php on line 1120

В чём может быть проблема? Подскажите пожалуйста кто сталкивался.
*

zeus07

  • Давно я тут
  • 634
  • 8 / 0
Re: Ошибка при обновлении с J 2.5.28 до J 3.4
« Ответ #4 : 05.02.2016, 04:18:47 »
При обновлении примерно на 87% появляется сообщение Fatal error: Cannot redeclare class JControllerLegacy in /var/www/u0051229/public_html/site.ru/libraries/legacy/controller/legacy.php on line 0 . После этого только бэкап помогает, сталкивался ктонить?

Чтобы избавиться от этой ошибки, необходимо удалить папку по адресу: libraries/cms/controller и проблема исчезает. Папка controller принадлежит Joomla 2.5.28 и при обновлении до версии 3.4 эта папка остаётся, её необходимо просто удалить.
*

kernel

  • Захожу иногда
  • 108
  • 19 / 1
  • Search Engine Optimization
Re: Ошибка при обновлении с J 2.5.28 до J 3.4
« Ответ #5 : 10.12.2017, 15:44:03 »
Чтобы избавиться от этой ошибки, необходимо удалить папку по адресу: libraries/cms/controller и проблема исчезает. Папка controller принадлежит Joomla 2.5.28 и при обновлении до версии 3.4 эта папка остаётся, её необходимо просто удалить.

! - не вижу смысла создавать новую тему, т.к. эта самая актуальная оказалась для меня.

Полное описание с решением ошибок обновления с Joomla 2.5.* до 3.*

Суть в следующем (Joomla 2.5.8 обновление):
  • Выключил нужные расширения;
  • Удалил не нужные расширения;
  • Исправил БД;
  • Отключил шаблон свой и поставил по умолчанию штатный Atomic;
  • .htaccess переименовал на всякий случай .txt по стандарту;

Обновляю до 3.5.1, что предложила система и комплит - ошибка 500. Хрен снимаю, думаю, иду на главную админки и все кривое. стили что ли не подгружаны? короче, иду исправлять бд - ошибка 500.
ошибка после обновления "#__postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `#__postinstall_messages`"

Благодаря Вашему, зевс, совету, удалил контроллер папку и ошибка исчезла. исправилась бд и остались ошибки. еще раз исправить и ошибки пропали, но вот стили шаблона и тем более главная вообще все блоки посъезжали. куда копать - хз.
При этом пробовал hathor шаблон поставить - слетевшая какашка.

Для тех, кто так и не решил вопрос (так как форум русскоязычной поддержки лучше всех), пишу сюда решение. т.к. я искал долго.
В общем, скачал с оффсайта Joomla архив 3.5.1 версии. удалил все папки, кроме images, т.к. у меня в ней находятся изображения товаров VM. Распаковал и шаблон нормализовался. но появилась ошибка "The template for this display is not available."
*

zeus07

  • Давно я тут
  • 634
  • 8 / 0
Re: Ошибка при обновлении с J 2.5.28 до J 3.4
« Ответ #6 : 10.12.2017, 15:50:40 »
! - не вижу смысла создавать новую тему, т.к. эта самая актуальная оказалась для меня.

Полное описание с решением ошибок обновления с Joomla 2.5.* до 3.*

Суть в следующем (Joomla 2.5.8 обновление):
  • Выключил нужные расширения;
  • Удалил не нужные расширения;
  • Исправил БД;
  • Отключил шаблон свой и поставил по умолчанию штатный Atomic;
  • .htaccess переименовал на всякий случай .txt по стандарту;

Обновляю до 3.5.1, что предложила система и комплит - ошибка 500. Хрен снимаю, думаю, иду на главную админки и все кривое. стили что ли не подгружаны? короче, иду исправлять бд - ошибка 500.
ошибка после обновления "#__postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `#__postinstall_messages`"

Благодаря Вашему, зевс, совету, удалил контроллер папку и ошибка исчезла. исправилась бд и остались ошибки. еще раз исправить и ошибки пропали, но вот стили шаблона и тем более главная вообще все блоки посъезжали. куда копать - хз.
При этом пробовал hathor шаблон поставить - слетевшая какашка.

Для тех, кто так и не решил вопрос (так как форум русскоязычной поддержки лучше всех), пишу сюда решение. т.к. я искал долго.
В общем, скачал с оффсайта Joomla архив 3.5.1 версии. удалил все папки, кроме images, т.к. у меня в ней находятся изображения товаров VM. Распаковал и шаблон нормализовался. но появилась ошибка "The template for this display is not available."

Я бы на вашем месте сделал бы немного иначе. Сейчас расскажу, как я обновляю.

После того, как вы обновили Joomla штатным способом, я просто вытягиваб из этой БД нужные таблицы с нужной информацией, например:
- пункты меню
- статьи
- категории статей

В вашем случае ещё:
- товары
- категории товаров
- и т.д. все таблицы от VM

И все эти твблицы уже потом грузите на ЧИСТУЮ Joomla - и будет вам счастье! Как по мне, это лучший способ!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Joomla 3.5 ошибка Using $this when not in object context

Автор klara7

Ответов: 4
Просмотров: 2358
Последний ответ 18.09.2018, 13:32:26
от Nobillis
Уведомление об обновлении плагинов остается еще некоторое время после обновления

Автор Matysh

Ответов: 0
Просмотров: 82
Последний ответ 31.08.2018, 09:45:16
от Matysh
Ошибка IIS 7.5 0x80070002

Автор shur44

Ответов: 1
Просмотров: 74
Последний ответ 22.08.2018, 11:00:29
от shur44
Обнаружена ошибка при входе в админку

Автор Xavibeat

Ответов: 1
Просмотров: 509
Последний ответ 30.06.2018, 11:43:18
от al707
Бэкап Joomla Ошибка This extension requires FOF 3.0

Автор manm7667

Ответов: 1
Просмотров: 303
Последний ответ 26.06.2018, 23:07:04
от manm7667