Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 20 Ответов
  • 4047 Просмотров
*

bob888

  • Новичок
  • 1
  • 0 / 0
Здравствуйте! эта ошибка отображается в панели управления Joomla 3.5.0 , как быть? Joomla к локалке.



Такая ошибка как исправит?
*

b2z

  • Глобальный модератор
  • 7288
  • 778 / 0
  • Разраблю понемногу
*

ShamilHan

  • Захожу иногда
  • 196
  • 5 / 0
Re: Ошибка в панели управления
« Ответ #2 : 22.03.2016, 23:44:58 »
Аналогичная ситуация. нигде не нашел причины появления данного сообщения об ошибке. И база данных в актуальном состоянии. А сайт, кроме отображения главной страницы больше ничего не работает.
Попробовал установить чистую Joomla 3.5 с офф сайта и вуаля, та же самая ошибка))
« Последнее редактирование: 23.03.2016, 00:05:29 от ShamilHan »
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
Re: Ошибка в панели управления
« Ответ #3 : 23.03.2016, 00:39:25 »
Хостер поддерживает utfmb4 кодировка для мускуля?
*

ShamilHan

  • Захожу иногда
  • 196
  • 5 / 0
Re: Ошибка в панели управления
« Ответ #4 : 23.03.2016, 00:41:48 »
сайт на локалке
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
Re: Ошибка в панели управления
« Ответ #5 : 23.03.2016, 00:42:47 »
Ну значит мускуль на локалке поддерживает?
*

ShamilHan

  • Захожу иногда
  • 196
  • 5 / 0
Re: Ошибка в панели управления
« Ответ #6 : 23.03.2016, 00:46:02 »
Ну значит мускуль на локалке поддерживает?
к сожалению я не знаю даже о чем вы спрашиваете... я не столько глубоко понимаю тонкостей всех
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
*

Wertos

  • Захожу иногда
  • 489
  • 22 / 0
Re: Ошибка в панели управления
« Ответ #8 : 23.03.2016, 01:01:29 »
В 5.5.3 поддержку добавили.
*

molodejnoe

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
Re: Ошибка в панели управления
« Ответ #9 : 23.03.2016, 01:22:53 »
Та же самая проблема. Сайт на локалке, на Денвере последней версии. Полагаю что MySQL utfmb4 кодировку поддерживает. Как поправить все это дело?
*

Wertos

  • Захожу иногда
  • 489
  • 22 / 0
Re: Ошибка в панели управления
« Ответ #10 : 23.03.2016, 01:31:04 »
Та же самая проблема. Сайт на локалке, на Денвере последней версии. Полагаю что MySQL utfmb4 кодировку поддерживает. Как поправить все это дело?
Для начала посмотреть версию мускула. Ну можно ещё тут читануть http://invisionweb.ru/docs/general/hosting/perehod-s-utf8-na-utf8mb4-v-mysql-r43/
*

molodejnoe

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
Re: Ошибка в панели управления
« Ответ #11 : 23.03.2016, 01:36:32 »
Для начала посмотреть версию мускула. Ну можно ещё тут читануть http://invisionweb.ru/docs/general/hosting/perehod-s-utf8-na-utf8mb4-v-mysql-r43/
Программа: MySQL
Версия программы: 5.5.25 - MySQL Community Server (GPL)

А если внимания не обращать на эту ошибку? У нее никаких последствий не должно быть в виде сбоев?
*

Wertos

  • Захожу иногда
  • 489
  • 22 / 0
Re: Ошибка в панели управления
« Ответ #12 : 23.03.2016, 01:42:48 »
Код
mysql> SHOW VARIABLES WHERE Variable_name LIKE 'character\_set\_%' OR Variable_name LIKE 'collation%';
+--------------------------+--------------------+
| Variable_name            | Value              |
+--------------------------+--------------------+
| character_set_client     | utf8mb4            |
| character_set_connection | utf8mb4            |
| character_set_database   | utf8mb4            |
| character_set_filesystem | binary             |
| character_set_results    | utf8mb4            |
| character_set_server     | utf8mb4            |
| character_set_system     | utf8               |
| collation_connection     | utf8mb4_unicode_ci |
| collation_database       | utf8mb4_unicode_ci |
| collation_server         | utf8mb4_unicode_ci |
+--------------------------+--------------------+
10 rows in set (0.00 sec)
Тут что показывает ?

Код
[client]
default-character-set = utf8mb4

[mysql]
default-character-set = utf8mb4

[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci
Настройки вписаны в my.ini
*

molodejnoe

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
Re: Ошибка в панели управления
« Ответ #13 : 23.03.2016, 01:52:39 »
Код
mysql> SHOW VARIABLES WHERE Variable_name LIKE 'character\_set\_%' OR Variable_name LIKE 'collation%';
+--------------------------+--------------------+
| Variable_name            | Value              |
+--------------------------+--------------------+
| character_set_client     | utf8mb4            |
| character_set_connection | utf8mb4            |
| character_set_database   | utf8mb4            |
| character_set_filesystem | binary             |
| character_set_results    | utf8mb4            |
| character_set_server     | utf8mb4            |
| character_set_system     | utf8               |
| collation_connection     | utf8mb4_unicode_ci |
| collation_database       | utf8mb4_unicode_ci |
| collation_server         | utf8mb4_unicode_ci |
+--------------------------+--------------------+
10 rows in set (0.00 sec)
Тут что показывает ?

Код
[client]
default-character-set = utf8mb4

[mysql]
default-character-set = utf8mb4

[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci
Настройки вписаны в my.ini
# Кодировка консоли MySQL.exe по умолчанию.
default-character-set = cp1251
# Внутренняя кодировка таблиц на сервере.
character-set-server = utf8
*

Wertos

  • Захожу иногда
  • 489
  • 22 / 0
Re: Ошибка в панели управления
« Ответ #14 : 23.03.2016, 02:10:01 »
Попробуй прописать как в документации написано...
*

b2z

  • Глобальный модератор
  • 7288
  • 778 / 0
  • Разраблю понемногу
Re: Ошибка в панели управления
« Ответ #15 : 23.03.2016, 10:44:40 »
Из соседней темы

У кого ошибка при переходе в управление модулями, нужно увеличить sort buffer size до 256к
PS. Проверяйте у кого красная надпись в админке об ошибке.
Ещё можно попробовать увеличить innodb_sort_buffer_size
*

molodejnoe

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
Re: Ошибка в панели управления
« Ответ #16 : 23.03.2016, 11:55:57 »
Из соседней темы
Ещё можно попробовать увеличить innodb_sort_buffer_size
Благодарю! Заработало)
P.S.: Править в my.ini
*

ShamilHan

  • Захожу иногда
  • 196
  • 5 / 0
Re: Ошибка в панели управления
« Ответ #17 : 23.03.2016, 12:18:11 »
Можете поэтапно описать решение проблемы?
*

x1

  • Давно я тут
  • 639
  • 15 / 0
  • Linux — это Windows для бытовой техники
Re: Ошибка в панели управления
« Ответ #18 : 23.03.2016, 12:40:43 »
Можете поэтапно описать решение проблемы?
Лично я в файле  usr\local\mysql-5.5\my.ini  строка 33 изменил sort_buffer_size = 64K  на 256K
Сработало на Denwer 5.3.13 на сайте с Kunena и на чистой Joomla: исчезло красное предупреждение и ошибка входа в управлением модулями.
« Последнее редактирование: 23.03.2016, 12:44:53 от x1 »
*

molodejnoe

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
Re: Ошибка в панели управления
« Ответ #19 : 23.03.2016, 12:42:23 »
Можете поэтапно описать решение проблемы?
Уже проще некуда все расписано. Найди конфиг MySQL, который называется my.ini и в sort buffer size напиши 256K.
Если у тебя сайт на Денвере, то тебе сюда: Z:(или какой у тебя там диск на денвер)\usr\local\mysql-5.5\my.ini
*

Wertos

  • Захожу иногда
  • 489
  • 22 / 0
Re: Ошибка в панели управления
« Ответ #20 : 23.03.2016, 12:45:17 »
зашёл на сайт Денвера, глянул... Он же устарел жутко. Может попробовать XAMPP например...
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Помогите с БАГом в панели администратора Joomla 3

Автор akteon25

Ответов: 2
Просмотров: 5814
Последний ответ 26.02.2025, 16:41:56
от akteon25
Прошу помощи. Ошибка при обновлении на Joomla 4

Автор wmsonic

Ответов: 1
Просмотров: 3629
Последний ответ 29.10.2023, 22:07:23
от Kukush
Выходит ошибка в админской панели

Автор daymarus

Ответов: 0
Просмотров: 3143
Последний ответ 10.08.2023, 12:43:43
от daymarus
При обновлении ошибка 403 Forbidden Request forbidden by administrative rules

Автор THeCMeX

Ответов: 18
Просмотров: 10525
Последний ответ 14.07.2023, 17:13:19
от art22
Панель управления Joomla 3 права доступа

Автор sergei8

Ответов: 11
Просмотров: 2365
Последний ответ 16.02.2023, 22:55:13
от sergei8