ошибки при переходе на PHP5.4 и выше

  • 10 Ответов
  • 833 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Evg

  • Осваиваюсь на форуме
  • ***
  • 41
  • 0
Добрый день.
Сайт работает на PHP5.3, уже давно пытался перейти на более новую, но лезут ошибки...
Забил на время, а сейчас все чаще пишут что многие расширения не будут работать на старой 5.3 ( таже akeeba)
При включении 5.4 и выше появляются ошибки
Спойлер
[свернуть]

Отключить то вывод этих ошибок я могу, чтоб не мазолило глаза, но хотелось бы узнать как их исправить!
Ведь если есть ошибки, то значит что то будет работать неправильно...
Подскажите, знающие, как правильнее перейти на PHP5.4 и выше

*

Wertos

  • Завсегдатай
  • *****
  • 505
  • 21
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #1 : 23.03.2016, 17:07:36 »
Код
&
в 118 строке быть не должно !
Глянул... там ппц менять много где нужно...
Код: php
$menu = JFactory::getApplication()->getMenu();
« Последнее редактирование: 23.03.2016, 17:13:28 от Wertos »

*

b2z

  • Support Team
  • *****
  • 7450
  • 741
  • Разраблю понемногу
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #2 : 23.03.2016, 17:16:02 »
mod_icemegamenu на свалку :)
А если серьёзно - проход по коду и внесение изменений спасут от показа ошибок. Правьте потихоньку и следите за тем, чтобы больше не вылазили.

*

Evg

  • Осваиваюсь на форуме
  • ***
  • 41
  • 0
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #3 : 23.03.2016, 17:34:33 »
Не совсем понял что нужно менять.
Так его что надо просто удалить или на что то поменять?
И почему mod_icemegamenu на свалку - вроде красивое и удобное. Кстати может его как то обновить можно? Как я понимаю оно просто очень старенькое...
А на что влияют эти ошибки, вроде как все работает в этом меню
А может тогда подскажете аналогичное и бесплатное меню, чтоб работало без ошибок
« Последнее редактирование: 23.03.2016, 17:44:27 от Evg »

*

Wertos

  • Завсегдатай
  • *****
  • 505
  • 21
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #4 : 23.03.2016, 17:41:00 »
И почему mod_icemegamenu на свалку - вроде красивое и удобное. Кстати может его как то обновить можно?
Оно древнее как навоз мамонта ! Я помниться правил его уже...
Найти
Код: php
$menu = JSite::getMenu();
Заменить на
Код: php
$menu = JFactory::getApplication()->getMenu();
там несколько таких строк.

*

Evg

  • Осваиваюсь на форуме
  • ***
  • 41
  • 0
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #5 : 23.03.2016, 18:31:22 »
нашел вот такую строчку

$menu   = &JSite::getMenu();
отличается значком &
это она или нет

*

SeBun

  • Практически профи
  • *******
  • 3076
  • 186
  • @SeBun48
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #6 : 23.03.2016, 18:36:46 »
Не совсем понял что нужно менять.
Движок вам нужно менять, а не ошибки править.

Поясню. Что бы корректировать ошибки, вызванные несовместимостью кода с версией PHP, нужно уметь их находить и знать, что именно в этом коде менять. Параллельно нужно следить за багтрекером и самостоятельно устранять уязвимости, периодически проверять на предмет взлома и т.д., ведь официально эта версия давно не поддерживается, а значит никто ее не обновляет. Есть, конечно, энтузиасты, которые до сих пор юзают такие движки. Но насколько это оправдано? Это все равно, что пытаться чинить старый ржавый автомобиль, в то время, как есть возможность ездить на новом.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование | Разработка
Ник занят

*

Wertos

  • Завсегдатай
  • *****
  • 505
  • 21
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #7 : 23.03.2016, 18:38:30 »
нашел вот такую строчку

$menu   = &JSite::getMenu();
отличается значком &
это она или нет
Это оно

*

Evg

  • Осваиваюсь на форуме
  • ***
  • 41
  • 0
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #8 : 23.03.2016, 18:50:36 »
Движок вам нужно менять, а не ошибки править.

Запутался, что вы имеете ввиду  под  движком. Если о Joomla, то она у меня последняя стоит...
Поясните пожалуйста...

Кстати, строчку эту заменил, но ничего не поменялось.
Там кстати такие же ошибки еще и по корзине с AJAX полезли. Незнаю чего делать,  сидеть до последнего что ли на PHP5.3
« Последнее редактирование: 23.03.2016, 19:02:36 от Evg »

*

SeBun

  • Практически профи
  • *******
  • 3076
  • 186
  • @SeBun48
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #9 : 23.03.2016, 19:06:17 »
Запутался, что вы имеете ввиду  под  движком. Если о Joomla, то она у меня последняя стоит...
Поясните пожалуйста...
Последняя 3.5?

Я думал у вас 1.7, почему я так думал показал на скрине в аттаче.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование | Разработка
Ник занят

*

Evg

  • Осваиваюсь на форуме
  • ***
  • 41
  • 0
Re: ошибки при переходе на PHP5.4 и выше
« Ответ #10 : 23.03.2016, 19:24:30 »
странно откуда этот значок берется, вначале был действительно 1.7 а в последних постах 3.х

А стоит пока Joomla 3.4.8  , не решаюсь пока обновлять, а то опять чего нибудь полезет
Так может кто подскажет нормальные замены  для mod_icemegamenu и какую-нибудь нормальную корзину...
« Последнее редактирование: 23.03.2016, 19:28:56 от Evg »