0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 874 Просмотров
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Здравствуйте. Я новичок в работе с Seblog (последняя версия 3.8). Некоторые проблемы не могу решить.

Сделал новую Search form.

https://postimg.org/image/4m8nwqekh/
https://postimg.org/image/fn3t1r6td/

Активировал Seblod Search Module и вывел на сайт.

https://postimg.org/image/f7nxuzvi9/

Но нет кнопки "Поиск" или "Отсортировать". Выделение чекбоксов или города ничего не даёт.

И ещё. Как сделать по аналогии с городами вывод категорий? Через "Select simple" или что-то ещё?

Заранее спасибо.
*

KKAAZZOO

  • Практически профи
  • 2148
  • 102
Re: Фильтры поиска не работают
« Ответ #1 : 17.07.2016, 23:46:41 »
Добавьте поле Button Search в форму, это и есть кнопка поиска. Если хотите искать через выделение чекбоксов или списка, то в форме поиска в столбце Variation (кнопка 1) выберите настройку Form Filter
Категории можно вывести через штатное поле вывода категорий Category, через поле Select Dynamic,  через поле Select Simple.
По аналогии с городами как раз через Select Simple.
« Последнее редактирование: 17.07.2016, 23:50:55 от KKAAZZOO »
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #2 : 18.07.2016, 00:46:11 »
Спасибо за ответ! Кнопку добавил, теперь она срабатывает (если в настройках выставить Input). Нужные пункты на Form Filter поменял. Однако, в результате поиска имею пустую страницу. Вероятно, что-то с выводом. На выводе в Item поставил Aricle Title, Introtext и картинку. В базе с указанными в поиске параметрами есть тестовые статьи.

И ещё на счёт категорий через Simple Select. В пункты будущего списка, как я понимаю, нужно вводить ID категорий? В каком виде? Или я неверно понимаю?
Для городов я вбивал просто названия городов, а тут неясно.

Спасибо.
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #3 : 18.07.2016, 00:54:30 »
Экспериментирую дальше.
Полностью выключил штатный джумловский SEF - поиск стал работать, но выводятся только картинки. Тайтл и описание не выводится. Но это уже прогресс!
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #4 : 18.07.2016, 01:04:21 »
В режиме отладки сделал запрос поиску (отфильтровал) и вылезло вот это -

SELECT t0.id AS pid,t0.pk AS pk,t0.pkb AS pkb,t0.parent_id AS parent,t0.author_id AS author,t0.cck AS cck,t0.storage_location AS loc,tt.id AS type_id,tt.alias AS type_alias
FROM `#__cck_core` AS t0
LEFT JOIN `#__cck_store_form_katalog` AS t1 ON t1.id = t0.pk
LEFT JOIN `#__content` AS t2 ON t2.id = t0.pk
LEFT JOIN `#__cck_core_types` AS tt ON tt.name = t0.cck
WHERE t2.state = 1
  AND t2.access IN (1,1,2,3)
  AND ( t2.publish_up = '0000-00-00 00:00:00' OR t2.publish_up <= '2016-07-17 22:01' )
  AND ( t2.publish_down = '0000-00-00 00:00:00' OR t2.publish_down >= '2016-07-17 22:01' )
  AND t0.cck = 'katalog'
  AND t1.article_city LIKE '%Харків%'
  AND t1.article_styles LIKE '%undefined%'
  AND t2.catid = 18
ORDER BY t2.title ASC
LIMIT 0, 25

Тут я не силён... Понимаю, что решение где-то на поверхности. Буду благодарен за подсказку.
*

KKAAZZOO

  • Практически профи
  • 2148
  • 102
Re: Фильтры поиска не работают
« Ответ #5 : 18.07.2016, 09:35:56 »
Перед тем как пытаться что-либо сделать на Seblod http://old.sebloders.ru/forum/36-obshchie-voprosy/4862-faq
У поля Simple Select есть инструкция в настройках, оранжевый шеврон снизу-справа. Вместо цифр использовать ID категории, настройки storage поля должны совпадать с настройками Storage поля Article Category Id
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #6 : 18.07.2016, 23:07:34 »
Спасибо. Буду вникать. Пока действую по наитию, погугливая, глядя видео. Компонент нелёгкий. Что-то выходит, что-то нет.
Если не разберусь - ещё задам вопросы.
В любом случае - спасибо за наводки.
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #7 : 28.07.2016, 18:35:30 »
Всё сделал, разобрался, порядок.
Осталась одна нерешённая задача.
При выводе результатов заголовок материала (Article Title) некликабельный.
*

composerr

  • Осваиваюсь на форуме
  • 34
  • 0
Re: Фильтры поиска не работают
« Ответ #8 : 28.07.2016, 22:09:20 »
Эврика. В Item, Кнопка 2, "Ссылка", выставил "Содержание"
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

cтандартный модуль поиска Joomla

Автор ivan.sergeev

Ответов: 1
Просмотров: 761
Последний ответ 26.03.2016, 14:07:33
от KKAAZZOO
Проблема с Типом поиска?

Автор andrepon

Ответов: 1
Просмотров: 750
Последний ответ 02.12.2012, 02:56:50
от zeroif
Не выводятся результаты поиска

Автор hawk1

Ответов: 5
Просмотров: 1454
Последний ответ 31.07.2012, 17:48:30
от Posokhoff
Вывод результатов поиска в виде блога в 1 колонку с сортировкой по кол-ву "лайков".

Автор Владимир Гаврилов

Ответов: 1
Просмотров: 1449
Последний ответ 19.07.2012, 13:40:44
от Posokhoff
Модуль поиска Jseblod1.8

Автор andrepon

Ответов: 2
Просмотров: 984
Последний ответ 28.04.2012, 12:44:24
от KKAAZZOO