JCE перемещает тэги

  • 3 Ответов
  • 302 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

iridos

  • Новичок
  • *
  • 8
  • 0
JCE перемещает тэги
« : 15.09.2016, 13:55:28 »
Здравствуйте! у меня Joomla 3.6 JCE 2.4.6

Проблема.

нужно какую-то часть HTML кода обрамить тэгами

<span itemprop="Priem_Kol_Mest">
HTML текст
</span>

При редактировании материала  с отключенным визуальным редактором (редактирую HTML) все хорошо. как только включаю редактор и делаю самое простое действие, например поставлю пробел.
происходит вот что
<p><span itemprop="Priem_Kol_Mest"> </span></p>
HTML текст

Конечно можно писать и без использования визуального редактора - на HTML, но многие вещи проще сделать в визуальном редакторе

Кто поможет!

*

vipiusss

  • Профи
  • ********
  • 5517
  • 318
  • JoomlaNet
Re: JCE перемещает тэги
« Ответ #1 : 15.09.2016, 14:41:35 »
в 3 местах в настройках JCE изменить настройки:

в Общие настройки : Проверять HTML: Да   Нет
в Профили редактора/default/Параметры редактора : Проверять HTML: Да   Нет
в Профили редактора/default/Параметры редактора/Расширенные :
Разрешить Javascript: Да   Нет
Разрешить CSS: Да   Нет
Разрешить PHP: Да   Нет
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями

*

fbr

  • Живу я здесь
  • ******
  • 1274
  • 140
Re: JCE перемещает тэги
« Ответ #2 : 15.09.2016, 14:56:25 »
еще Профили - параметры плагина - буфер обмена - удалять spans - нет

*

iridos

  • Новичок
  • *
  • 8
  • 0
Re: JCE перемещает тэги
« Ответ #3 : 15.09.2016, 15:02:55 »
Вроде сработало.
Я еще вместо span поставил div
<div itemprop="Priem_Kol_Mest">
HTML текст
</div>
завтра буду менять материал на сайте (сегодня занят другими делами) обязательно отпишусь.
СПАСИБО