0 Пользователей и 1 Гость просматривают эту тему.
  • 642 Ответов
  • 244172 Просмотров
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@Sulpher
Да. Скрипт плагина в windows-1251.
*

Sulpher

  • Живу я здесь
  • 2028
  • 392 / 15
  • Шаблоны и расширения Joomla
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
*

Gold Dragon

  • Захожу иногда
  • 289
  • 33 / 2
есть два замечания...
Если в статье поставить {hsimage} и {mosimage} то на выходе получится одна и та же картинка: первая использующая мамбот, вторая обычная (если отключить замену IMG). Если эта ошибка уже обсуждалась то дайте ссылку на решение :)

и ещё.. в теге IMG нет атрибутов align и valign :) Не совсем по спецификации
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@Gold Dragon
Да, обсуждалось. Попробуйте вот эту версию мамбота mosimage.
« Последнее редактирование: 26.01.2011, 23:03:07 от yunoshev »
*

Gold Dragon

  • Захожу иногда
  • 289
  • 33 / 2
большое спасибо.. А почему бы это не встроить в офверсию? или не так уж и хорошо работает?
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
большое спасибо.. А почему бы это не встроить в офверсию? или не так уж и хорошо работает?
Я не могу без ведома пользователей изменять исходные файлы НЕ моего расширения. :)
*

fancyone

  • Новичок
  • 5
  • 0 / 0
Виктор,
Хотел выразить вам огромную благодарность за ваш мамбот. Очень он функциональный получился и достаточно простой в использовании. Не по воли приходится переходить на платформу 1.5 и, перечитав форум, я понял что нативной версии мамбота для этой платформы нет (Мне очень часто приходится пользоваться именно ручной обработкой эскиза, когда в теге прописываешь желаемую ширину и высоту). Пробовал другие варианты и что-то прям совсем они мне не нравятся в тем что надо почти всегда лезть в HTML код и там ручками все делать. Посмотрев, что вы успешно занимаетесь проектом yvCommodity для Joomla 1.5.x стало понятно, что с Joomla 1.5 вы уже познакомились. Так может быть уже можно и мамбот переделать под платформу 1.5?

Если у вас есть такая возможность, то готов финансово посодействовать, ну а потом можно его выложить для публики, чтобы все, наконец-то были счастливы.
Заранее благодарен за ответ
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@fancyone
Спасибо за благодарности, но это все благодаря нашим форумчанам, т.к. именно "местные жители" хотели, чтобы мамбот имел всякие функции.
Что касается портирования мамбота на платформу Joomla! 1.5 -- с разработкой плагинов для этой версии CMS я еще не разбирался, хотя уже пора, т.к. нужен плагин рейтинга товаров для каталога товаров, который к тому же еще не переведен на режим NATIVE.
Т.е. я не говорю "нет" -- я сделаю, но и сроков, к сожалению, пока сказать не могу.
*

fancyone

  • Новичок
  • 5
  • 0 / 0
@yunoshev
Ну тогда спасибо всем форумчанам. Действительно очень здорово, когда в результате совместных усилий рождается что-то простое, полезное и функциональное.
Также спасибо, что обнадежили :) В принципе, у меня есть очень талантливый веб разработчик, который уже хорошо освоился в Joomla 1.5. Если скажете примерно, где "капать" и что надо посмотреть да адаптировать, то могу его попросить, может и получится адаптировать, тогда и поделюсь с общественностью сразу :)
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@fancyone
Да я только за, если кто поможет. Но там довольно емкий и местами запутанный код вышел -- логика разработчика всегда загадка, -- что боюсь, мало кто разберется. :)
*

fancyone

  • Новичок
  • 5
  • 0 / 0
@fancyone
Да я только за, если кто поможет. Но там довольно емкий и местами запутанный код вышел -- логика разработчика всегда загадка, -- что боюсь, мало кто разберется. :)
Да уж, знакомая ситуация.
Ну тогда будем ждать с нетерпением когда у вас дойдут руки и будет время. :)
*

fancyone

  • Новичок
  • 5
  • 0 / 0
Виктор,
А подскажите, можно ли сделать так, чтобы прямо в теге можно было указать путь до картинки а не выбирать ее через меню "картинки". У меня вот на сайте много картинок и других файлов (около 2 гигов уже) и недели три назад я просто не мог открыть ни один материал потому что просто вылетала ошибка. Опытным путем выяснили, что при формировании структуры папок PHP просто уходил в небытие. Закомментировали строчку и все нормально. Но теперь проблема что нельзя выбрать картинки. Бороздил тут просторы интернета и выяснил что у народа есть такая проблема тоже когда папок становится слишком много.
Вот и интересно можно ли указать мамботу путь прямо в теге или нет и если можно то где поискать? Может самому удастся разобраться.
Спасибо за ответ :)
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@fancyone
В режиме ручного указания параметров мамбота такой поддержки нет, но есть для тега <IMG>.
*

fancyone

  • Новичок
  • 5
  • 0 / 0
@fancyone
В режиме ручного указания параметров мамбота такой поддержки нет, но есть для тега <IMG>.
Да но тогда получается что все картинки которые я вставлял через тег <IMG> будут автоматически выводится через мамбот, а это блин не очень удачный вариант потому что очень много моментов когда этого не нужно, например когда на рисунок назначена ссылка да еще много других моментов.
Ладно будем стараться побыстрее перейти на Joomla 1.5 и ждать от вас адаптации на эту версию, ну или хотя-бы работы в режиме легаси :)
*

supercom

  • Захожу иногда
  • 53
  • 1 / 0
хотелось бы узнать как добавить ватермарк на фотографии выводимые на сайт посредством мамбота. спасибо
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@supercom
Мой мамбот такого не умеет.
*

vitmasik

  • Новичок
  • 3
  • 0 / 0
Доброго времени суток, помогите пожалуйста при использовании вашего мамбота вместо эскиза картинки выходит рамка с названием темы.
Вот как это выглядит http://adminssn.valuehost.ru/index.php?option=com_content&task=view&id=466&Itemid=76
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@vitmasik
Проверьте:
  • права на папки в images
  • включен или нет кеш сайта и соответственно этому выставьте режим работы мамбота
Если ничего не помогло и по адресу картинки-эскиза ничего не отображается (к примеру: http://adminssn.valuehost.ru/mambots/content/highslide/timthumb.php?src=http://adminssn.valuehost.ru/images/stories/grafika/ruo.jpg&w=100&h=75&zc=1), то пересмотрите настройки хостинга для сервера APACHE (что-то типа 'allow_url_fopen') или же обратитесь в техподдержку хостинга.
*

supercom

  • Захожу иногда
  • 53
  • 1 / 0
хочу испытать на сайте bot_hstooltip, понятно как вставлять, а как вставить кнопку?? или еще вопрос как поставить bot_hstooltip_btn
выдает при установке бот постоянно ошибку не найден файл install_4cdbca501d163/bot_hstooltip_btn/hstooltip.gif, создал руками папку и подпапку, переместил файл, после следующей установки ошибка таже, только папка уже другая, именно название (код), че делать?
« Последнее редактирование: 11.11.2010, 13:53:58 от supercom »
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@supercom
При всем уважении, вопрос к Вам -- неужели не видно в начале топика надпись "В Joomla 1.5.х не работает"? Или Вы устанавливаете на J!1.0.x?
« Последнее редактирование: 11.11.2010, 14:13:25 от yunoshev »
*

supercom

  • Захожу иногда
  • 53
  • 1 / 0
заработало, спасибо
« Последнее редактирование: 11.11.2010, 15:36:37 от supercom »
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
@supercom
Нет. Только из-за того, что Joostina 1.3. Поменяйте кодировку файлов на UTF8 без BOM и сделайте новый установочный архив. Должно пойти.
*

supercom

  • Захожу иногда
  • 53
  • 1 / 0
joostina 1.3 [

превью не показывает
при нажатии работает, проблема с хостингом?
потому как на других сайтах то работает
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
превью не показывает
при нажатии работает, проблема с хостингом?
потому как на других сайтах то работает
Если по адресу картинки-эскиза ничего не отображается (в Firefox нажмите правую кнопку мыши на эскизе, выберите "Информация об изображении", скопируйте значение "адрес" и вставьте его в новом окне браузера), то пересмотрите настройки хостинга для сервера APACHE (что-то типа 'allow_url_fopen') или же обратитесь в техподдержку хостинга. Отпишитесь, если проблема не решилась, если решилась -- то как. :)
*

supercom

  • Захожу иногда
  • 53
  • 1 / 0
Если по адресу картинки-эскиза ничего не отображается (в Firefox нажмите правую кнопку мыши на эскизе, выберите "Информация об изображении", скопируйте значение "адрес" и вставьте его в новом окне браузера), то пересмотрите настройки хостинга для сервера APACHE (что-то типа 'allow_url_fopen') или же обратитесь в техподдержку хостинга. Отпишитесь, если проблема не решилась, если решилась -- то как. :)
Поправили настройки модуля безопасности mod_security - ошибка ушла, но превью так и не отображается, что еще может быть??
PS:

ХОСТЕР: тут уже с нашей стороны ничего не блокирует, сама картинка почему то генерируется битой.
кстати и еще, скорее наверно не к Вам, но напишу, joostina 1.3. такая проблема при использовании мамбота, в содержимом выбираем картинку, переносим ее в правый селект, только вот в левом отображаются 3-4 картинки из 60, которые есть в указанной папке... что может быть, опять хостинг??
« Последнее редактирование: 02.12.2010, 11:37:20 от supercom »
*

Mikl

  • Захожу иногда
  • 64
  • 0 / 0
При включении компонента EasySEF на НЕКОТОРЫХ статьях перестали показываться превьюшки (щелкаешь - полная картинка показывается).
в ошибках 404 компонента выдаётся такой адрес: номер/раздел/категория/mambots/content/highslide/timthumb.php

что делать? мамбот классный - хочу на нём остаться
« Последнее редактирование: 25.01.2011, 17:12:01 от Mikl »
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
При включении компонента EasySEF на НЕКОТОРЫХ статьях перестали показываться превьюшки (щелкаешь - полная картинка показывается).
в ошибках 404 компонента выдаётся такой адрес: номер/раздел/категория/mambots/content/highslide/timthumb.php

что делать? мамбот классный - хочу на нём остаться
Я использовал на своих сайтах компонент Artio JoomSEF и проблем не замечал в работе с мамботом. Возможно, устранить проблему удасться путем анализа настроек Вашего компонента.

Как вариант, попробуйте открыть файл ваш_сайт/mambots/content/hsimage.php и перейти к строке №588, замените эту строку:
Код: php
				$image_thumb_src = '"mambots/content/highslide/timthumb.php?src='

на:
Код: php
				$image_thumb_src = '"'. $hs_path. '/timthumb.php?src='

Этот вариант я не тестировал.
*

Mikl

  • Захожу иногда
  • 64
  • 0 / 0
Я использовал на своих сайтах компонент Artio JoomSEF и проблем не замечал в работе с мамботом. Возможно, устранить проблему удасться путем анализа настроек Вашего компонента.

Как вариант, попробуйте открыть файл ваш_сайт/mambots/content/hsimage.php и перейти к строке №588, замените эту строку:
Код: php
				$image_thumb_src = '"mambots/content/highslide/timthumb.php?src='

на:
Код: php
				$image_thumb_src = '"'. $hs_path. '/timthumb.php?src='

Этот вариант я не тестировал.
Cпасибо огромное! Заработало :) +1 в карму)) Есть правда 2 НО:
1) в одной статье вылезли ошибки. но это видимо статья такая, т.к. везде всё ок
2) понимаю, к данному мамботу отношение не имеет, но всё же. что сделать с mosimage, чтобы там тоже показывались превьюшки? :)
*

yunoshev

  • Завсегдатай
  • 1254
  • 178 / 1
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Мамбот внутренней навигации (Content Item Navigation) для j! 1.0.хх

Автор beliyadm

Ответов: 60
Просмотров: 33677
Последний ответ 16.10.2012, 11:35:53
от beliyadm