0 Пользователей и 1 Гость просматривают эту тему.
  • 0 Ответов
  • 103 Просмотров
*

phpCoder

  • Новичок
  • 9
  • 0
Написал свой компонент. В нем есть форма для отправки сообщения с сайта. Хочу добавить в эту форму стандартную капчу.

1. Включил плагин.
2. Прописал в нем необходимые ключи с Google.
3. В XML файле с описанием формы добавил

Код
<field name="captcha" type="captcha" validate="captcha"
           label="COM_CONTACT_CAPTCHA_LABEL"
           description="COM_CONTACT_CAPTCHA_DESC" >
</field>

4. В блок head в шаблоне добавил <script src='https://www.google.com/recaptcha/api.js'></script>
5. В общих настройках тоже включил.

Капча появляется и вроде как проходит проверка(по крайней мере после выбора нужных изображений, появляется зеленая галочка). Но после отправки формы в момент ее валидации выкидывает ошибку:
TPL_WHITESQUARE_ERROR
0 No transport driver available.

Подскажите, в чем может быть дело? Что я делаю не так?

Нужно ли писать свой обработчик проверки правильности заполнения CAPTCHA на стороне сервера(в XML файле прописано validate="captcha"), или этот обработчик штатный?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема отображения модулей на шаблоне proto

Автор Artefact

Ответов: 10
Просмотров: 181
Последний ответ 17.08.2017, 18:29:40
от Artefact
[Решено]Изменить внешний вид пагинации

Автор pavel2950

Ответов: 1
Просмотров: 110
Последний ответ 17.08.2017, 15:31:24
от pavel2950
Кто запускал image recycle кроном?

Автор pavelrer

Ответов: 23
Просмотров: 298
Последний ответ 14.08.2017, 17:16:10
от dmitry_stas
Поддомены в папках основного домена

Автор Dmitriy5023

Ответов: 4
Просмотров: 149
Последний ответ 08.08.2017, 01:40:49
от Филипп Сорокин
Как убрать текст на главной?

Автор m03mug08

Ответов: 4
Просмотров: 140
Последний ответ 05.08.2017, 14:59:41
от Missile