JUri() не работает ?

  • 11 Ответов
  • 178 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
JUri() не работает ?
« : 05.03.2017, 13:49:04 »
Доброго времени суток. Нужна ваша помощь. Суть проблемы : перенес сайт на хостинг timeweb . Версия Joomla 3.6 . В компоненте медия менеджер перестала работать функция Juri(). Виесто адреса админки выводит :///

Вот пример строки :////index.php/?option=com_media&task=file.upload&tmpl=component&2166473d5b5dfb5ea4056303263cf80b=89e9412277175eb6e519271df5257a5a&5a8bc4bcdea36f09d7599762ceddaab8=1&format=html&folder=

При этом если написать в форме выозов функции  2 раза подряд то будет в форме  2 раза написан адрес админки. И если просто в макете вывести через echo то так же все ок. Трабла прослеживается именно в компоненте медиа менеджер. Версия php 5.6. Не знаю что делать, сломал голову но баг так и не нашел. Подскажите плз кто сталкивался или может быть у кого то есть предположения

*

robert

  • ********
  • 4002
  • 371
Re: JUri() не работает ?
« Ответ #1 : 05.03.2017, 14:22:34 »
C чего вы взяли, что
перестала работать функция Juri()
?
  • Не будь паразитом, сделай что-нибудь самостоятельно!
  • В личке и по Skype не даю советов.

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
Re: JUri() не работает ?
« Ответ #2 : 05.03.2017, 14:25:34 »
C чего вы взяли, что?
смотрие, если в фрме над тегом form я напишу <?php echo JUri::base(); ?>  то мне выведет адрес админки. site.com/admiistrator  . Но когда это же в самом теге :

Код: php
			<form action="<?php echo JUri::base(); ?>index.php?option=com_media&amp;task=file.upload&amp;tmpl=component&amp;<?php echo $this->session->getName(). '=' . $this->session->getId(); ?>&amp;<?php echo JSession::getFormToken();?>=1&amp;format=html" id="uploadForm" class="form-inline" name="uploadForm" method="post" enctype="multipart/form-data">

то вместо базового URL выводит запись такого типа ://// (двоеточие в начале и слеши). Сама то функция работает но при ее использовании в медиаменеджере в теге формы почему то нет. Я первый раз такое в глаза вижу :((

*

SmokerMan

  • ********
  • 5329
  • 689
Re: JUri() не работает ?
« Ответ #3 : 05.03.2017, 14:52:24 »
смотрие, если в фрме над тегом form я напишу <?php echo JUri::base(); ?>  то мне выведет адрес админки. site.com/admiistrator  . Но когда это же в самом теге :
может скрипт какой-то режит или дополнение для браузера
посмотрите что в исходном коде страницы

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
Re: JUri() не работает ?
« Ответ #4 : 05.03.2017, 14:54:06 »
может скрипт какой-то режит или дополнение для браузера
посмотрите что в исходном коде страницы
скриптов нет. Пробовал в разных браузерах. Суть в чем - на одном хостинге норм а на  timewe вот такая ерунда. Версия php одна и таже. Думаю может хостинг но тогда как ? ну тоесть разве может как то сам хостинг резать тег в форме  ?  и смысл

*

SmokerMan

  • ********
  • 5329
  • 689
Re: JUri() не работает ?
« Ответ #5 : 05.03.2017, 14:55:16 »
посмотрите что в исходном коде страницы

*

voland

  • ********
  • 9349
  • 420
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: JUri() не работает ?
« Ответ #6 : 05.03.2017, 14:56:28 »
скриптов нет. Пробовал в разных браузерах. Суть в чем - на одном хостинге норм а на  timewe вот такая ерунда. Версия php одна и таже. Думаю может хостинг но тогда как ? ну тоесть разве может как то сам хостинг резать тег в форме  ?  и смысл

Спросите у хостинга.
Это вроде он менял принудительно файлы и даже не сознавался в этом

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
Re: JUri() не работает ?
« Ответ #7 : 05.03.2017, 15:05:45 »


Хм, в исходном коде нет :/// ? там URL начинается сразу с index.php . Но компонент медиа менеджера как и шаблон админки я не менял.  Он с коробки как и был, плаины в браузере никакие не установленны (уже с чистого браузера смотрю). В конце страницы есть очень длинный скрипт в одну строку со 100500 символов. Его причитать не реально да и если на одном хостинге работает а тот же сайт один в один на другом хостинге не работает ... странно

*

almika

  • ****
  • 269
  • 22
Re: JUri() не работает ?
« Ответ #8 : 05.03.2017, 18:50:01 »
Посмотрите, есть ли разница в подключенных модулях PHP, модулях Apache, параметрах PHP на обоих хостингах.

*

robert

  • ********
  • 4002
  • 371
Re: JUri() не работает ?
« Ответ #9 : 05.03.2017, 21:18:02 »
Хм, в исходном коде нет :/// ? там URL начинается сразу с index.php .
А где они есть?
  • Не будь паразитом, сделай что-нибудь самостоятельно!
  • В личке и по Skype не даю советов.

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
Re: JUri() не работает ?
« Ответ #10 : 06.03.2017, 00:43:20 »
А где они есть?
когда смотрю через фаирбаг . Открываю исходный код - там этого нет.

*

voron121

  • ****
  • 222
  • 1
  • Метод тыка и мата помогает в кодинге
Re: JUri() не работает ?
« Ответ #11 : 06.03.2017, 00:45:03 »
Решил траблу костылем через jQuery . Однако весьма интересная особенность. Учитывая что стандартный шаблон без каких-либо допов или плагинов, то грешу все же на хостинг (хотя они сказали что нет очобых модов или правил по работе с формами). Буду сравнивать phpinfo() как советовал almika , другого выходя не вижу.