Проблема с вложениями Kunena 5.0.7

  • 3 Ответов
  • 395 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

SeBun

  • *******
  • 3071
  • 185
  • @SeBun48
Не так давно на одном из сайтов, где Kunena была обновлена до 5.0.7, обнаружилась невозможность добавления изображения. При этом правила в настройках форума такие: ширина не более 900 пикселей, высота не более 800 пикселей, размер файла не более 0,9Мб. Но даже изображения заведомо меньшего размера не добавляются. В конфиге PHP post_max_size = 250M. Но есть и еще одна строка:
Код: ini
disable_functions = exec,ini_get,ini_get_all,parse_ini_file,passthru,php_uname,popen,proc_open,putenv,dl,shell_exec,show_source,system,symlink,phpinfo,curl_multi_exec,curl_exec

Хотя ее отключение тоже ни на что не влияет. В чем может быть причина?
« Последнее редактирование: 01.05.2017, 14:25:53 от SeBun »
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

voland

  • ********
  • 9365
  • 420
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: Проблема с вложениями Kunena 5.0.7
« Ответ #1 : 01.05.2017, 14:23:34 »
А расширение JPG разрешено в настройках?

*

SeBun

  • *******
  • 3071
  • 185
  • @SeBun48
Re: Проблема с вложениями Kunena 5.0.7
« Ответ #2 : 01.05.2017, 14:34:19 »
Да. Я ранее написал, что PNG грузится. Но я перед этим удалил строку, отключающую функции. Файл PNG был размером больше, чем задано в конфигурации, как по весу файла, так и по разрешению. Отключил вообще возможность загрузки PNG, удалил разрешенный МIME. Все равно PNG добавляет. Вернул назад свою строку, отключающую функции PHP. Вставил PNG-картинку, хотя она запрещена в конфиге. Странно...
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

SeBun

  • *******
  • 3071
  • 185
  • @SeBun48
Re: Проблема с вложениями Kunena 5.0.7
« Ответ #3 : 01.05.2017, 14:41:55 »
Так, стоп... Забил голову и себе и людям )
Там кеш включен и изменения не сразу видны. Сейчас все работает. Проблема в отключенных мной функциях PHP. Я в JQuery не силен, разве она через cURL картинки загружает?
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую