Установка Joomla 2.5.28

  • 3 Ответов
  • 227 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Alazi

  • Новичок
  • *
  • 1
  • 0
Установка Joomla 2.5.28
« : 17.05.2017, 15:39:31 »
Привет! Помогите, при установки Joomla на denwer выдает ошибку Parse error: parse error, unexpected '=', expecting '(' in z:\home\localhost\www\joomla\includes\framework.php on line 42
Я как понимаю, это 42 строчка, посмотрите, что не так? Красным выделил 42 строчку. Что с этим символом нужно сделать?
<?php
/**
 * @package      Joomla.Site
 * @subpackage   Application
 * @copyright   Copyright (C) 2005 - 2014 Open Source Matters, Inc. All rights reserved.
 * @license      GNU General Public License version 2 or later; see LICENSE.txt
 */

// No direct access.
defined('_JEXEC') or die;

//
// Joomla system checks.
//

@ini_set('magic_quotes_runtime', 0);
@ini_set('zend.ze1_compatibility_mode', '0');

//
// Installation check, and check on removal of the install directory.
//

if (!file_exists(JPATH_CONFIGURATION.'/configuration.php') || (filesize(JPATH_CONFIGURATION.'/configuration.php') < 10) || file_exists(JPATH_INSTALLATION.'/index.php')) {

   if (file_exists(JPATH_INSTALLATION.'/index.php')) {
      header('Location: '.substr($_SERVER['REQUEST_URI'], 0, strpos($_SERVER['REQUEST_URI'], 'index.php')).'installation/index.php');
      exit();
   } else {
      echo 'No configuration file found and no installation code available. Exiting...';
      exit();
   }
}

//
// Joomla system startup.
//

// System includes.
require_once JPATH_LIBRARIES.'/import.php';

// Force library to be in JError legacy mode
JError::$legacy = true;
JError::setErrorHandling(E_NOTICE, 'message');
JError::setErrorHandling(E_WARNING, 'message');
JError::setErrorHandling(E_ERROR, 'callback', array('JError', 'customErrorPage'));

// Botstrap the CMS libraries.
require_once JPATH_LIBRARIES.'/cms.php';

// Pre-Load configuration.
ob_start();
require_once JPATH_CONFIGURATION.'/configuration.php';
ob_end_clean();

// System configuration.
$config = new JConfig();

// Set the error_reporting
switch ($config->error_reporting)
{
   case 'default':
   case '-1':
      break;

   case 'none':
   case '0':
      error_reporting(0);
      break;

   case 'simple':
      error_reporting(E_ERROR | E_WARNING | E_PARSE);
      ini_set('display_errors', 1);
      break;

   case 'maximum':
      error_reporting(E_ALL);
      ini_set('display_errors', 1);
      break;

   case 'development':
      error_reporting(-1);
      ini_set('display_errors', 1);
      break;

   default:
      error_reporting($config->error_reporting);
      ini_set('display_errors', 1);
      break;
}

define('JDEBUG', $config->debug);

unset($config);

//
// Joomla framework loading.
//

// System profiler.
if (JDEBUG) {
   jimport('joomla.error.profiler');
   $_PROFILER = JProfiler::getInstance('Application');
}

//
// Joomla library imports.
//

jimport('joomla.application.menu');
jimport('joomla.environment.uri');
jimport('joomla.utilities.utility');
jimport('joomla.event.dispatcher');
jimport('joomla.utilities.arrayhelper');

*

KKAAZZOO

  • Практически профи
  • *******
  • 2138
  • 102
Re: Установка Joomla 2.5.28
« Ответ #1 : 17.05.2017, 16:06:15 »
Актуальная версия Joomla 3.7.0. Сегодня выйдет 3.7.1. Выкиньте Денвер на свалку истории.

*

voland

  • Профи
  • ********
  • 9376
  • 421
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: Установка Joomla 2.5.28
« Ответ #2 : 17.05.2017, 16:07:36 »
Может он с Вояджера пишет? Просто пинг в 5 лет

*

SeBun

  • Практически профи
  • *******
  • 3078
  • 186
  • @SeBun48
Re: Установка Joomla 2.5.28
« Ответ #3 : 17.05.2017, 16:10:22 »
denwer выдает ошибку
Для Windows сейчас используют OpenServer в основном, используйте его. И учитесь на всем новом - Joomla 3.7.x.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование | Разработка
Ник занят