0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 311 Просмотров
*

RTEagle

  • Захожу иногда
  • 125
  • 5 / 0
Вот код, который отвечает за вывод изображения в материале из com_content/article/default.php
Код
<img
<?php if ($images->image_fulltext_caption):
echo 'class="caption"' . ' title="' . htmlspecialchars($images->image_fulltext_caption). '"';
endif; ?>
src="/<?php echo htmlspecialchars($images->image_fulltext); ?>"
alt="<?php echo htmlspecialchars($images->image_fulltext_alt); ?>" itemprop="image"
/>

После обновления пропала картинка материала
http://joxi.ru/DrlbwxbT40JXJ2
Потому что путь стал какбы относительно категории novosti, а не от корня сайта
http://joxi.ru/12MZLyZc407NwA

Это касается и картинок просто вставленных через редактор JCE. Явно какая-то лабуда с роутером. Смотрю код роутера уже другой в 3.7.2.
Вот страница для примера http://britbob.ru/novosti/britanskaya-klassika-dlya-novichkov-s-viktoriej-imber.html
« Последнее редактирование: 22.06.2017, 14:56:42 от RTEagle »
*

RTEagle

  • Захожу иногда
  • 125
  • 5 / 0
Немного подумав, может оно так и должно быть. Может дело в редакторе, который ставит относительный ссылки без слэша в начале
Это последняя версия JCE core
Если я в ручную указываю путь к картинке начинающийся со слэша, тогда работает, если выбираю картинку мышкой средствами редактора он автоматически прописывает путь без слэша.
Соответственно путь меняется в зависимости от раздела в котором мы находимся

Проблема решилась после включения системного плагина "Система SEF"
« Последнее редактирование: 22.06.2017, 16:11:29 от RTEagle »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

После обновления на 3.9 не могу вставить модуль в материал

Автор polezniy

Ответов: 2
Просмотров: 214
Последний ответ 28.11.2018, 13:12:59
от polezniy
Ошибка в меню - после обновления до 3.8.10

Автор bas700

Ответов: 45
Просмотров: 5431
Последний ответ 20.11.2018, 21:25:58
от a159cm
После обновления на версию 3.9.0 не работают модули при добавлении в материал

Автор help-tend

Ответов: 10
Просмотров: 458
Последний ответ 09.11.2018, 16:13:50
от help-tend
Perfect ajax Popup Contact Form не закрывается после отправки

Автор fireman

Ответов: 2
Просмотров: 221
Последний ответ 07.11.2018, 19:55:38
от EvgenDu
Наверное после обновления до 3.9 возникала проблема

Автор polezniy

Ответов: 0
Просмотров: 198
Последний ответ 05.11.2018, 16:12:08
от polezniy