0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 1211 Просмотров
*

capricorn

  • Завсегдатай
  • 1909
  • 118 / 3
Установил php 7.1.11 (из исходников). Joomla 3.8.1. Получаю ошибки:

Warning: session_start(): Failed to read session data: user (path: /tmp) in /var/www/html/zend-test.techtranslate247/htdocs/libraries/joomla/session/handler/native.php on line 260
Error displaying the error page: Application Instantiation Error: Failed to start the session

http://www.zend-test.techtranslate247.ru/

после обновления страницы пару раз появляется:

Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.

Данные БД в configuration.php правильные. Обработчик сессий БД.

public $dbtype = 'mysqli';
public $session_handler = 'database';

Сессии без Joomla пишутся. http://www.zend-test.techtranslate247.ru/session.php

Код: php
<?php
session_start();
if (!isset($_SESSION['counter'])) $_SESSION['counter'] = 0;
echo "Вы обновили эту страницу " . $_SESSION['counter']++ . " раз. ";
echo "<br><a href=" . $_SERVER['PHP_SELF'] . ">обновить";
?>

Инфо http://www.zend-test.techtranslate247.ru/info.php

php.ini

https://yadi.sk/i/uOa6CgFJ3PMKZC

На этом же сервере этот сайт работал на php 5.6.28. И другие работают.

Нашел https://github.com/joomla/joomla-cms/issues/10855 Особой разницы в конфигурациях php не заметил.

Что может быть?
« Последнее редактирование: 04.11.2017, 05:41:47 от capricorn »
*

capricorn

  • Завсегдатай
  • 1909
  • 118 / 3
Re: Failed to read session data Joomla 3.8.1 php 7.1.11
« Ответ #1 : 02.11.2017, 19:48:15 »
Обе версии php работают в режиме FastCGI - с mod_fastcgi. Каталог сессий /tmp drwxrwxrwxt.

UPD. Пересобрал php. Как-то получилось. Кажется неправильно задал сначала путь к сокету mysql. Точно не могу сказать. В любом случае, научился устанавливать несколько версий php на CentOS.
« Последнее редактирование: 04.11.2017, 06:12:13 от capricorn »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Найти админку у Joomla 3

Автор vovchikku

Ответов: 15
Просмотров: 309
Последний ответ 12.07.2018, 08:58:30
от vovchikku
Не работает админка Joomla 3.

Автор AngryUser

Ответов: 7
Просмотров: 636
Последний ответ 02.07.2018, 08:02:08
от AngryUser
Не обновить &amp;quot;Joomla! Update Component Update&amp;quot;

Автор stardel

Ответов: 0
Просмотров: 137
Последний ответ 28.06.2018, 19:16:38
от stardel
Скрыть <script type="application/json" class="joomla-script-options new">

Автор romagromov

Ответов: 4
Просмотров: 448
Последний ответ 27.06.2018, 22:21:24
от dmitry_stas
Бэкап Joomla Ошибка This extension requires FOF 3.0

Автор manm7667

Ответов: 1
Просмотров: 159
Последний ответ 26.06.2018, 23:07:04
от manm7667