0 Пользователей и 1 Гость просматривают эту тему.
  • 5 Ответов
  • 701 Просмотров
*

Ebelous

  • Захожу иногда
  • 109
  • 0 / 0
  • Учиться,учиться и учиться!
 Обновил сайт до версии 3.8.3, версия РНР 7.2.0, шаблон стандартный beez3. Все работает нормально. Но сунулся отредактировать материал - выскакивает ошибка :
Цитировать
Fatal error: Switch statements may only contain one default clause in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\document.php on line 279
Сам код, на который указывает ошибка таков:
Код
switch ($path) {
                // JCE root folder
                case 'jce':
                    $pre = $base . '';
                    break;
                // JCE libraries resource folder
                default:
                case 'libraries':
                    $pre = $base . 'libraries/' . $type;
                    break;
                case 'jquery':
                    $pre = $base . 'libraries/jquery/' . $type;
                    break;
                case 'mediaelement':
                    $pre = $base . 'libraries/mediaelement/' . $type;
                    break;
                case 'bootstrap':
                    $pre = $base . 'libraries/bootstrap/' . $type;
                    break;
                // TinyMCE folder
                case 'tiny_mce':
                    $pre = $base . 'tiny_mce';
                    break;
                // JCE current plugin folder
                case 'plugins':
                    $pre = $base . 'tiny_mce/plugins/' . $plugin . '/' . $type;
                    break;
                // Extensions folder
                case 'extensions':
                    $pre = $base . 'extensions';
                    break;
                case 'joomla':
                    return JURI::root(true);
                    break;
                case 'media':
                    return JURI::root(true). '/media/system';
                    break;
                case 'component':
                    $pre = JURI::root(true). '/administrator/components/com_jce/media/' . $type;
                    break;
                default:
                    $pre = $base . $path;
                    break;
            }
Данная ошибка и на локалке и на хостинге. Подскажите в чем дело.
*

KKAAZZOO

  • Живу я здесь
  • 2167
  • 111 / 9
Как минимум обновите компонент вызывающий ошибку.
*

Ebelous

  • Захожу иногда
  • 109
  • 0 / 0
  • Учиться,учиться и учиться!
 Обновил редактор JCE до последней предложенной Joomla версии 2.5.1. Окна редактирования материала стали открываться.Но вылезла куча ошибок :[quoteWarning: Illegal string offset 'icon' in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 615

Warning: Cannot assign an empty string to a string offset in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 615

Warning: Illegal string offset 'action' in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 616

Warning: Cannot assign an empty string to a string offset in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 616

Warning: Illegal string offset 'title' in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 617

Warning: array_merge(): Argument #2 is not an array in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 620

Warning: array_key_exists() expects parameter 2 to be array, null given in C:\xampp\htdocs\pitomnik\components\com_jce\editor\libraries\classes\browser.php on line 623][/quote]
Не совсем полное обновление? Или редактор отстает от обновления Joomla?
*

zikkuratvk

  • Глобальный модератор
  • 4328
  • 310 / 2
  • Разрабатываем для Joomla
наверное потому что 2.5.1 вышла еще до появления наверное даже PHP 7)) а последняя 2.6.22
https://www.joomlacontenteditor.net/downloads/editor/core
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

Ebelous

  • Захожу иногда
  • 109
  • 0 / 0
  • Учиться,учиться и учиться!
 Оказывается, пока не обновишь до 2.5.1, предложение обновиться до более поздней версии не будет. Сейчас открыл по новой, уже предлагается версия 2.6.1
Спасибо большое за помощь!  Что то я не нашел механизма как самостоятельно обновить редактор путем загрузки своего пакета?
*

zikkuratvk

  • Глобальный модератор
  • 4328
  • 310 / 2
  • Разрабатываем для Joomla
Качаете пакет с сайта и устанавливаете как новое расширение, все само обновится :-)
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Знатоки нужна помощь...Ошибка после перехода версии php

Автор polezniy

Ответов: 19
Просмотров: 485
Последний ответ 14.11.2018, 13:36:06
от Igor2
После обновление некорректно работает плагин "Поля"

Автор Victor333

Ответов: 3
Просмотров: 109
Последний ответ 12.11.2018, 11:44:51
от NewUsers
После настройки 301 редиректа не пускает в админку

Автор Apollon

Ответов: 16
Просмотров: 1210
Последний ответ 18.10.2018, 19:02:33
от Vasiliy111
После обновления до Joomla 3.7 в админке в меню "Компоненты" пропали пункты

Автор lolitma3

Ответов: 37
Просмотров: 5450
Последний ответ 11.10.2018, 16:28:28
от khan-alex
После перехода на PHP 7.2.9 сайт Joomla работает некорректно

Автор stimyl

Ответов: 18
Просмотров: 504
Последний ответ 27.09.2018, 12:54:30
от stimyl