0 Пользователей и 1 Гость просматривают эту тему.
  • 3 Ответов
  • 630 Просмотров
*

lexrider

  • Осваиваюсь на форуме
  • 39
  • 0 / 0
Всем привет. Есть сайт с "нормально" работающей мультиязычностью (как я думал) http://alp-in.com/ как на удивление мультиязычность стала с первого раза. Был глюк с:
Цитировать
Както раз обновлял до 3.7 и начал залипать язык как описано вот тут копаться не стал откатил и начал работать дальше

Суть проблемы вот в чем: мультиязычность работает как нужно на всем сайте во всех модулях кроме непосредственно материалов по прямой ссылке. Связанные материалы продублированы для каждого языка, связи категорий и материалов выставлены, языки материалов выставлены аналогично - проверено по несколько раз. Основной язык Русский, доп. Украинский статьи на русском отображаются нормально но если переключаться на другой язык получаем An error just happened: Component Not Found. Аналогично если пробовать попасть на украинский вариант статьи по прямой ссылке.

Русский вариант подменю со ссылкой на материал http://alp-in.com/obsluzhivanie-elevatorov работает а украинский ругается.

Не понимаю почему по этой ссылке (подменю с типом пункта "материал")  мультиязычность работает а по прямой ссылке другая статья http://alp-in.com/germetizatsiya-mezhsogovykh-shvov уже не работает мультиязычность хотя связи все выставлены и то и то материал, просто один опубликован как меню а второй нигде не опубликован и доступ через прямую ссылку.

Перекопал уже все несколько раз не пойму как исправить. Помогите >:(
« Последнее редактирование: 15.03.2018, 11:16:54 от lexrider »
*

lexrider

  • Осваиваюсь на форуме
  • 39
  • 0 / 0
Структура меню такова, что каждый конечный пункт подменю является материалом. Так вот замечено, что связи стоят только у меню и подменю, а вот между самими материалами связей не было установлено, странно но все работает, наверное хватает того что меню связаны. Ну а вот с материалами которые нигде не выставлены и доступ к ним подразумевается только по прямой ссылке у меня  все еще проблема.

UPD: Обновился до 3.8.6
« Последнее редактирование: 14.03.2018, 18:54:22 от lexrider »
*

lexrider

  • Осваиваюсь на форуме
  • 39
  • 0 / 0
Насколько понял проблема в том что в некоторых случаях не удаляется префикс языка а в других не добавляется. Соответствующая настройка на удаление включена.

Например при переходе с материала на основном языке (русский) на второй язык (украинский) не добавляется префикс "uk"  хотя в меню все работает и добавляется. В тот же момент на главной странице если перейти на второй язык а потом перейти обратно на основной то уже префикс "uk" не удаляется и сайт остается на украинском языке crazy!

Еще у меня стоит sh404SEF
*

lexrider

  • Осваиваюсь на форуме
  • 39
  • 0 / 0
sh404SEF - проблема всех бед. Удалил все заработало.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Мультиязычность на Joomla 3

Автор AhmadRahmanov

Ответов: 5
Просмотров: 383
Последний ответ 12.03.2018, 19:22:25
от Ilhom666
Не работают связи материалов на многоязычном сайте (J3.8.0, J3.8.1)

Автор Dorfman

Ответов: 3
Просмотров: 2022
Последний ответ 08.10.2017, 15:55:37
от effrit
Сломалась мультиязычность Joomla 3.6

Автор ajustlike

Ответов: 2
Просмотров: 1042
Последний ответ 01.06.2017, 15:00:07
от voland
Стандартная мультиязычность

Автор Dolphin

Ответов: 129
Просмотров: 42009
Последний ответ 18.02.2017, 21:50:02
от all_zer
Мультиязычность перестала работать

Автор ipugach

Ответов: 0
Просмотров: 334
Последний ответ 06.02.2017, 15:29:43
от ipugach