Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 11 Ответов
  • 1788 Просмотров
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Всем здоровья.
После переноса сайта на другой хостинг, появляется ошибка "Невозможно очистить кэш" при нажатии на кнопку "очистить кэш" плагина Cache Cleaner. При этом удаление кэша через админку проходит нормально. Поддержка хостинга говорит, что у них в логах по этому поводу нет инфы. Переустановка плагина не помогла. Сайт на Joomla 3.
Прошу подсказать где и как лечить.
*

beliyadm

  • Легенда
  • 9758
  • 1665 / 66
  • Севастополь, Россия
Проверить значение переменных в конфиге сайта
$log_path и $tmp_path
Если сайт переносился на новый сервер - пути на 100% изменились.
https://domen/administrator/index.php?option=com_admin&view=sysinfo - права доступа на каталоги, все связанное с кешем и темпом должно быть зеленым
Все истины, которые я хочу вам изложить, — бесстыдная ложь. Сделать всё хорошо
TLG: @Beliyadm
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Пути мне выставила техподдержка первым делом.
В информации о системе все зеленое.
А кнопка не работает. Хотя на этом же шаблоне, но у другого хостера работает.
Что еще проверить?
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Я попробовал войти не в плагин, а в модуль Cache Cleaner и у меня выскочила такая ошибка: An error has occurred while fetching the JSON data: HTTP 0 status code. error Подозреваю, что эти ошибки связаны. Подскажите пжл как устранить эту ошибку.
*

SeBun

  • BanMaster
  • 4031
  • 259 / 5
  • @SeBun48
Написал небольшой скрипт, можете залить в корень и повесить задание в планировщик. Будет чистить папку cache по расписанию. А плагин можете удалить.
Оказываю услуги по Joomla | Миграция/Обновление | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Написал небольшой скрипт, можете залить в корень и повесить задание в планировщик. Будет чистить папку cache по расписанию. А плагин можете удалить.
Спасибо. Но удобство плагина в наличии кнопки, которую можно нажать в любой момент. Кстати, ошибка "An error has occurred while fetching the JSON data: HTTP 0 status code. error" вылазит при открытии любого модуля. Ее появление совпало по времени с установкой более новой версии phpMyAdmin. Техподдержка писала, что на этой версии не работает автоматическая авторизация и потребуется вводить логин и пароль пользователя БД вручную. Может ли это быть причиной данной ошибки? или эти вещи не связаны между собой?
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Вернули phpMyAdmin к предыдущей стабильной версии - не помогло. Неужели никто так и не подскажет как лечить ошибку An error has occurred while fetching the JSON data: HTTP 0 status code. error ?
*

beliyadm

  • Легенда
  • 9758
  • 1665 / 66
  • Севастополь, Россия
Все истины, которые я хочу вам изложить, — бесстыдная ложь. Сделать всё хорошо
TLG: @Beliyadm
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Благодарю за советы.
Ошибку гуглил. Признаюсь долго не мог в них разобраться т.к. там на английском. В этих рекомендациях говорят об обновлении плагина Менеджер модулей, но у меня в админке он заблокирован и при попытке его включить вылазит другая ошибка: "Изменение состояния не допускается". Т.е. для меня это решение не осуществимо.
*

beliyadm

  • Легенда
  • 9758
  • 1665 / 66
  • Севастополь, Россия
но у меня в админке он заблокирован и при попытке его включить вылазит другая ошибка: "Изменение состояния не допускается".

Вы в админке один администратор с правом изменения чего-либо? Опция "разблокировать" не срабатывает (система - снять блокировки)?
Тогда только идти в базу данных и руками менять состояние модуля. Но лучше пока проверить штатные методы
Все истины, которые я хочу вам изложить, — бесстыдная ложь. Сделать всё хорошо
TLG: @Beliyadm
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Да я один администратор.
в Система - Снятие блокировок было только 2 таблицы: модулей и расширений. Выделил обе, нажал разблокировать. Таблицы пропали, в остальном ничего не изменилось. Менеджер модулей по прежнему заблокирован.
По сути мне же не надо его включать/выключать. По инструкции мне надо его обновить.
У меня на старом хостинге остался этот сайт. Там ошибки не было. Может перезалить сайт на новый сервер заново?
*

Loh

  • Захожу иногда
  • 124
  • 0 / 0
Вообщем перезалил несколько бэкапов со старого хостинга - не помогает.
Вы в админке один администратор с правом изменения чего-либо? Опция "разблокировать" не срабатывает (система - снять блокировки)?
Тогда только идти в базу данных и руками менять состояние модуля. Но лучше пока проверить штатные методы
Может подскажете поподробнее как эту проблему через базу данных решить?
Видел на других форумах (англоязычных) спрашивали про такую же проблему, но для заблокированного модуля там решений так и не предлагалось :(
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка Missing field in database: Joomla\CMS\Table\Extension   extension_id

Автор Ragivort

Ответов: 1
Просмотров: 6899
Последний ответ 25.12.2025, 21:10:01
от fbr
Стоит ли ставить плагин rel="canonical" на Joomla 3

Автор azm1n

Ответов: 2
Просмотров: 6876
Последний ответ 09.05.2025, 12:39:18
от azm1n
Не работает менеджер материалов, ошибка 500 SSL certificate problem

Автор Екатерина М

Ответов: 5
Просмотров: 7229
Последний ответ 06.04.2025, 09:27:20
от wishlight
Joomla! 3.9.21 Невозможно создать пункт меню

Автор edvalitto

Ответов: 1
Просмотров: 4075
Последний ответ 26.03.2025, 19:26:30
от azm1n
Как установить header Cache-Control только для одной страницы по URL?

Автор Slava77

Ответов: 0
Просмотров: 2320
Последний ответ 23.03.2024, 00:16:36
от Slava77