0 Пользователей и 1 Гость просматривают эту тему.
  • 10 Ответов
  • 705 Просмотров
*

submaster

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
В админке Joomla 3.9.14 настойчиво выдает предупреждение:

Ваша версия PHP, 7.2.23, в настоящее время получает только исправления безопасности от проекта PHP. Это означает, что ваша версия PHP скоро не будет поддерживаться. Мы рекомендуем запланировать обновление до новой версии PHP до конца поддержки 30.11.20. Joomla будет быстрее и более безопасной, если вы обновитесь до новой версии PHP (рекомендуется PHP 7.x).

Неужели PHP 7.2.23 уже так сильно устарела? Какая версия сейчас рекомендуется для Joomla?
*

cntrl

  • Захожу иногда
  • 179
  • 6 / 0
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #1 : 17.09.2020, 18:10:51 »
Неужели PHP 7.2.23 уже так сильно устарела? Какая версия сейчас рекомендуется для Joomla?
ИМХО - нормально, ещё на пятой сидит много, это перфекционизм от разработчиков Joomla. В гос.учереждениях встречаю и более старые, чем 5 версии php. Конечно они уязвимы к целевым атакам, но зато к нецелевым коих 99,9% нет. В случае такого часто используемого  скрипта как Joomla конечно стоит подумать об обновление с 5 на 7.
*

Taatshi

  • Глобальный модератор
  • 5259
  • 481 / 1
  • Верстаем и кодим. Обращайтесь ;)
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #2 : 17.09.2020, 18:33:49 »
Идеал 7.4, но не все расширения поддерживают. Чем выше версия, тем лучше.
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

gorbi_U

  • Захожу иногда
  • 77
  • 0 / 0
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #3 : 04.10.2020, 09:03:10 »
А как минимальной кровью Joomla 1.7 перевести на пхп7?  *ОХ-Х-Х*
*

AlexB

  • Завсегдатай
  • 1973
  • 54 / 2
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #4 : 04.10.2020, 10:14:24 »
А как минимальной кровью Joomla 1.7 перевести на пхп7? 
переезжать на Joomla 3
*

gorbi_U

  • Захожу иногда
  • 77
  • 0 / 0
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #5 : 04.10.2020, 10:31:26 »
И компоненты могут не переехать с другими обвесами?
*

AlexB

  • Завсегдатай
  • 1973
  • 54 / 2
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #6 : 04.10.2020, 10:38:56 »
само собой
тут в первую очередь надо смотреть функционал
во многих случаях проще пересобрать сайт чем мигрировать
*

gorbi_U

  • Захожу иногда
  • 77
  • 0 / 0
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #7 : 04.10.2020, 10:44:52 »
Спасибо. Примитивный набор обвесов даёт надежду на минимальные финансовые потери)
*

AlexB

  • Завсегдатай
  • 1973
  • 54 / 2
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #8 : 04.10.2020, 10:46:40 »
ну если статейник с мелкими плюшками то должно все легко быть
*

gorbi_U

  • Захожу иногда
  • 77
  • 0 / 0
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #9 : 04.10.2020, 10:52:09 »
Жаль, что нет эмулятора в пару кликов. Я бы не переезжал
*

arma

  • Завсегдатай
  • 1729
  • 81 / 2
Re: Версия PHP 7.2.23 уже устарела?
« Ответ #10 : 04.10.2020, 14:33:20 »
Пару кликов? Ну пробуйте http://SP Upgrade, если купите. На одном сайте всё отлично переехало (предварительно отключить все чужие модули, плагины и шаблоны от старого) , на другом затык - пришлось ручками
« Последнее редактирование: 04.10.2020, 15:10:18 от arma »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Установлена последняя версия Joomla, 3.10.6

Автор max.slanskii

Ответов: 3
Просмотров: 424
Последний ответ 27.02.2022, 09:44:19
от arma
После обновления Joomla версия 3.9.26 ошибка компонента com_widgetkit

Автор kate19

Ответов: 2
Просмотров: 504
Последний ответ 14.05.2021, 22:34:26
от sivers
Мобильная версия сайта Joomla

Автор CoffeeWolf

Ответов: 0
Просмотров: 311
Последний ответ 12.04.2021, 12:48:28
от CoffeeWolf
Версия файла стилей

Автор Mick_20

Ответов: 2
Просмотров: 338
Последний ответ 04.04.2021, 10:59:46
от Gosha5767
Внимание! Последняя версия Akeeba 7.4.0 обновляется с ошибкой!

Автор fbr

Ответов: 7
Просмотров: 428
Последний ответ 19.11.2020, 09:56:52
от fbr