0 Пользователей и 1 Гость просматривают эту тему.
  • 10 Ответов
  • 3624 Просмотров
*

Knight1979

  • Осваиваюсь на форуме
  • 26
  • 1 / 0
Доброе утро.

Очень странная и непонятная мне ситуация. Все фотографии загружаемые на хост начиная с размера 1413х1060 (установленно эксперементально) и дальше - не загружаются. 1412х1059 - без проблем, что с фронта, что с админки. (В тестовых фото менял только ширину, высота менялась пропорционально).
При этом:
Цитировать
Поддерживаются только изображения в форматах JPEG, GIF и PNG. Максимальные размеры фото 4000x4000. Размер файла не должен превышать 2000 Кб.
После неудачной загрузки объявление все таки заносится в базу, однако фото к нему не крепится. Пользователю выводится чистая белая страница с сылкой вида http://www.site.ru/index.php и никаких сообщений об ошибках. Рефреш страницы приводит к повтрному занесению объявления в базу и очередному белому листу в браузере.
 
Подскажите, пожалуйста, с чем это может быть связано? Такое ощущение, что где-то еще стоит фильтр на проверку размеров загружаемых изображений...

ЗЫ: Только что выставил в настройках допустимый размер 1412х1059 и добавил объявление с фото большего размера. Фотография не загрузилась, но пользователю выдало сообщение о том, что объявление успешно добавлено и будет опубликовано после одобрения администратором... разве это нормально, не должно быть сообщения о превышении размеров добавляемого изображения?
« Последнее редактирование: 12.06.2008, 07:25:07 от Knight1979 »
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
Вывод предупреждений при превышении размера фото в компонента не предусмотрен.

Информацию о невозможности загруки фото более чем 1412х1059 я проверю. Вы со своей стороны посмотрите не превышает ли размер фото в байтах максмальный разрешенный объем загруки заданный в php.ini вашего хоста.
*

Knight1979

  • Осваиваюсь на форуме
  • 26
  • 1 / 0
Файлы легкие, делаю градиентную заливку в фотошопе, сохраняю в .jpg, не превышают 30-40кб. Сейчас с хостером вместе разбираем логи...
Интересность в том, что на локальной версии подобных проблем не наблюдается.
*

Knight1979

  • Осваиваюсь на форуме
  • 26
  • 1 / 0
Alex Revo, понимаю что с выходом версии 2.0 забот у вас прибавилось, но может быть у вас была возможность просмотреть мою проблему? Спасибо.
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
А вам удалось найти что-нибудь в логах?
*

Knight1979

  • Осваиваюсь на форуме
  • 26
  • 1 / 0
Нет, чистые логи, пара ошибок, но по моему, не относящихся к этой проблеме.
*

Knight1979

  • Осваиваюсь на форуме
  • 26
  • 1 / 0
[12-Jun-2008 12:45:12] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969
[12-Jun-2008 12:46:27] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969
[12-Jun-2008 12:51:30] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969
[12-Jun-2008 12:52:01] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969
[12-Jun-2008 12:56:36] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969
[12-Jun-2008 12:57:13] PHP Notice:  Undefined variable: mosConfig_live_site in www/html/administrator/components/com_autobb/admin.autobb.html.php on line 969   

Вот строки с 969 по 970, 970 уже была закомментирована, 969 закомментировал я сам:
Код
<!--			<input type="button" class="button" value="<?php echo _AUTOBB_EDITFORM_BUTTONS_CHOOSE_CITY;?>" onclick="window.open( '<?php echo $mosConfig_live_site;?>/index2.php?option=com_autobb&task=select_region', 'win1', 'status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=no,width=' + winW + ',height=' + winH + ',left=' + winX + ',top=' + winY + ',directories=no,location=no');" /> -->
<!-- <input type="button" class="button" value="Äðóãèå..." onclick="window.open( '../index2.php?option=com_autobb&amp;task=select_region', 'win1', 'status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=no,width=400,height=100,directories=no,location=no');" />-->
*

A28

  • Новичок
  • 5
  • 0 / 0
Та же проблема, решение найдено?
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
Скорее всего ваш сервер не тянет обработку таких больших фото, например, не хватает памяти.
*

A28

  • Новичок
  • 5
  • 0 / 0
другие файлы грузятся без проблем. В php.ini  memory_limit = 64M
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
загрузка это полдела, проблема обычно возникает на этапе ресайза библиотекой gd
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

И все же, кто нибудь поможет разобраться? mod_autobb_latest = пропадают фото

Автор htmlcss

Ответов: 1
Просмотров: 2431
Последний ответ 30.10.2013, 20:23:38
от digor1
При выводе на главную обьявлений, пропадают фото

Автор htmlcss

Ответов: 4
Просмотров: 3012
Последний ответ 20.06.2013, 15:08:01
от htmlcss
Проблема с добавлением новых категорий ТС

Автор eskander

Ответов: 0
Просмотров: 2117
Последний ответ 07.06.2013, 21:30:18
от eskander
Проблема с хлебными крошками?

Автор digor1

Ответов: 4
Просмотров: 2894
Последний ответ 19.05.2013, 14:33:01
от digor1
Проблема с отображением фото

Автор muhammad23

Ответов: 0
Просмотров: 2252
Последний ответ 16.05.2013, 14:55:16
от muhammad23