Голосование

Какая версия PHP установлена на вашем сайте (сервере хостера)?

PHP 4 (ниже 4.2.0)
2 (1.1%)
PHP 4.2.x
1 (0.5%)
PHP 4.3.x
7 (3.7%)
PHP 4.4.x
16 (8.4%)
PHP 5.x
86 (45.3%)
PHP 5.0.x
1 (0.5%)
PHP 5.1.x
1 (0.5%)
PHP 5.2.x
34 (17.9%)
PHP 5.3.x
32 (16.8%)
PHP 5.4.x
8 (4.2%)
PHP 6.x
2 (1.1%)

Проголосовало пользователей: 153

Какая версия PHP установлена на вашем сайте (сервере хостера)?

  • 79 Ответов
  • 41931 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Вот общались мы сейчас с boston'ом и возник вопрос, как много нынче используется PHP4, и стоит ли поддерживать эту версию в настоящее время, или уже пора переписывать все, на PHP5, что позволит повысить и скорость, и качество кода.

Официальная поддержка PHP 4 закончилась 31 декабря 2007 года, а обновления по безопасности для этой версии будут выпускаться только до 8 августа 2008 года. После этой даты, в принципе, можно говорить, что версия 4 уже ушла в прошлое. Многие хостеры еще прошлой осенью начали миграцию на PHP5, но как показывает практика еще не все перешли.

Посему и опрос... В параметрах опроса, я разрешил оставлять по 5 голосов на пользователя, на тот случай, если у вас несколько площадок, с разными параметрами.

*

Daglus

у меня на одном стоит     5.2.1 а на другом  5.2.6 )  почти везде где есть хостинг уже перевелись на 5-ю линейку

*

Physicist

  • *****
  • 963
  • [+]185 / [-]0
  • Рябов Денис
Во многих случаях установлена как 4.4.x, так и 5.2.x, а выбрать нужную можно либо в панели управления аккаунтом, либо в .htaccess. Я стараюсь использовать PHP5 за исключением ситуаций, когда memory_limit сильно ограничен (до 32Мб, а порой и ниже; это не позволяет, например, сделать парсинг WURFL в PHP5), т.к. PHP5 требует примерно в два раза больше памяти, чем PHP4.

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Ребятки, уделите немного времени - оставьте свой голос, ну интересно же...

*

VETERINAR

  • ******
  • 868
  • [+]165 / [-]14
  • Kiss my shiny metal ass!
Отличная тема. Я сам недавно задавался таким вопросом. Я считаю, что PHP 5 очень вкусный, в главную очередь, за счет улучшения ООП. Когда попробовал, уже не хочется ничего писать для PHP 4 :)

На самом деле давно уже не видел хостера у которого версия PHP меньше 5-й. Думаю, что действительно нужно про неё забыть.

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
PHP 5 очень вкусный, в главную очередь, за счет улучшения ООП
мало того, что вкусный, так еще зараза и быстрый... и конечно, намного более красивый и эффективный код в нем можно писать... поэтому и решил я устроить опрос...

*

Александр Фёдоров

  • ***
  • 151
  • [+]26 / [-]4
  • Жизнь - удивительная штука
У меня все старые проекты крутятся на 4.4..., но хостер говорит, что у него давно стоят сервера с php 5 и он готов в любой момент перевести любого пользователя на пятую версию.
Жизненно важный ингредиент успеха — это не знать, что задуманное вами невозможно выполнить. М.Жванецкий

*

Full_crazy

  • ****
  • 264
  • [+]48 / [-]0
  • Иногда думаю ...
У меня только пара проектов на 4.4, но они на канадском хостинге :). А на VDS у меня 5.2.6
Joomla! = невозможного почти нет!

*

newleax

5.2.6. недавно что-то полезла как раз смотреть из-за Коппермайна.


*

Sedoy

  • *****
  • 910
  • [+]86 / [-]10
  • Интересно,в какой кодировке пишут врачи?
стоят и 4 и 5 у хостера, выбираешь сам на какой ставить
судя по тому что у многих движки еще на 4 ее убирать с хоста не собираются
что же касается всего нового то однозначно нужно все уже делать под 5
Что б правильно задать вопрос - нужно знать на него ответ!
смотри FAQ по Joomla!
Где скачать шаблоны Joomla
Статьи и обзоры
Желаю Вам здоровья в личной жизни - живите долго и часто :)

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
Так же как и у Седого и 4 и 5 стоит у хостеров. Приходится пользоваться чаще 4, так как под ней нет проблем с установкой расширений.

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Приходится пользоваться чаще 4, так как под ней нет проблем с установкой расширений.
т.е. упираемся в криворукость разработчиков, которые не могут правильный, валидный xml к расширению приложить? или какие-то иные ошибки установки?

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
Не, проблема не в криворукости изготовителей, так как и сам могу подправить XML. Пробема с путями, а именно с двумя слешами (ошибка в Php 5)/ На форуме уже обсуждалось

*

chemerzaev

  • *****
  • 635
  • [+]83 / [-]3
  • Надо мыслить. Меня, например, кормят идеи.
Если не ошибаюсь 5.2.6
Я несчастный человек, который, как долбаный экстрасенс, должен понимать заказчика, даже если он сам не знает, чего хочет

*

vanadik

5.2.6 не всё гладко работает на этой версии, приходится в коде движка постоянно что-то ковырять(((
<b>Боящийся задавать глупые вопросы, никогда не докопается до истины</b>

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Интересная получается картинка, из 34 опрошенных, у 31 на сервере уже доступна 5.х, т.е. все-таки большинство перешло на 5-ку...

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
Видимо из-за хостера. Вот у меня сейчас Mastak. У них стоит только 5, и 4 не ставят (заразы). Еще одна проблема обнаружилась. На этот раз с MosetsTree. Как раз в пятерке. Вот она.

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Еще одна проблема обнаружилась. На этот раз с MosetsTree. Как раз в пятерке. Вот url=http://joomlaforum.ru/index.php/topic,37810.new/topicseen.html]она[/url].
ну если быть объективным, это не твоя проблема, и не проблема 5-ки, это проблема программистов Mosets, и они ее должны устранять (раз уж продукт продают, должны и править)...

Т.е. проблемы связанные с тем, что разработчики не утруждают себя тестированием продуктов на актуальных версиях php, я особыми проблемами не считаю. Другое дело, если бы в 5-ке был изначально какой-то серьезный баг, из-за которого корректно написанные скрипты не работали бы. А так, если внимательно смотреть - почти в каждом случае проблема оказыватеся в разработчике, а значит решаема.

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
НУ да. А баг с установкой компонентов в joomla на версии php 5 так до сих пор не решен. Я не против 5. Но надо пинать кончено разработчиков компонентов.

*

VETERINAR

  • ******
  • 868
  • [+]165 / [-]14
  • Kiss my shiny metal ass!
НУ да. А баг с установкой компонентов в joomla на версии php 5 так до сих пор не решен.

Что-то я сколько ставлю, ни одного бага не заметил...

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Что-то я сколько ставлю, ни одного бага не заметил...
есть, есть... с двойным слешем в пути, насколько я помню...

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
есть, есть... с двойным слешем в пути, насколько я помню...
Именно оно

*

VETERINAR

  • ******
  • 868
  • [+]165 / [-]14
  • Kiss my shiny metal ass!
Клянусь уже около года ни одного расширения на php 4 не ставил :) И ни разу баг не встретил :(

Но я 12-й (а потом 15-й) лаврой пользуюсь. Может в ней этого бага нет?

*

smart

  • *******
  • 6843
  • [+]1311 / [-]14
  • снова дома...
Но я 12-й (а потом 15-й) лаврой пользуюсь. Может в ней этого бага нет?
скорее всего AndyR исправил его в процессе тестирования сборки

*

Aleks_El_Dia

  • *
  • 3742
  • [+]353 / [-]0
  • AEDStudio Joomla! Direction
5.2.5 - в основном мелкие проблемы с установкой из за xml. А так все гуд)
Спам придумали боги в отместку за наши молитвы (с) Рома Воронежский
На молоко: Z369038872422 || R210017695494 || U247040729215 || ЯД 410011288250383
Мигрирую сайты, переношу расширения J!1.0->J!1.5->J!2.5. Более 50 успешных миграций.

*

newleax

Ничего себе я проголосовала здесь по старому хостингу 5.2.6 , на новом хостинге у меня 4.3.9
 :( это плохо?

*

VETERINAR

  • ******
  • 868
  • [+]165 / [-]14
  • Kiss my shiny metal ass!
Ничего себе я проголосовала здесь по старому хостингу 5.2.6 , на новом хостинге у меня 4.3.9

Странно как-то Вы переезжаете. Где ж Вы хостинг с 4-кой-то нашли?

*

VETERINAR

  • ******
  • 868
  • [+]165 / [-]14
  • Kiss my shiny metal ass!
Я считаю все проблемы с php 5 просто ошибками разработчиков. Если что-то не встаёт, то это можно исправить. PHP 5 на много луше круче и перспективнее 4-ки. Только в этой версии появилась достойное ООП. Работать всё стало быстрее. Последнее моё мнение в этой теме будет таково, что уже можно и давно пора выпускать расширения с пометкой PHP 5 >=.

*

PaLyCH

  • ******
  • 971
  • [+]146 / [-]19
  • Архитектор сайтов
Я не против. Но сейчас снова столкнулся с проблемой установкой компонента ArtioSef 2.2.8 на Joostina 1.1.3 с PHP 5.1.6. Ошибка известная "Не верный XML файл" Кодировки указывал как надо