0 Пользователей и 1 Гость просматривают эту тему.
  • 19 Ответов
  • 10503 Просмотров
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
Здравствуйте, пожалуйста подскажите (уже облазил весь форум прочел кучу подобных тем, но что-то не  получилось никак). У меня JOOMLA 1.5.8 стандартный mod-banners, который идет с компонентом Баннеры. Шаблон сайта сильно переделан мною, при необходимости могу вставить сюда код. Так вот создал клиента, банер, категорию, прописал позицию right в шаблоне, она есть, опубликовал модуль. Все антивирусы выключил и чужие баннеры на раз смотрю в браузере.. Текстовая часть банера отображается и ссылка тоже, а вот картинка, которая идет к баннеру не отображается. Т.е. когда создаю баннер, я могу выбрать картинку и она видна, а уже на сайте ее нет. Весь прикол в том, что дома на компе (TOPserver 2.1) все замечательно работает! А на хосте нет (cPanel 11). Причем ни в каком формате картинка на хосте не идет и стандартные баннеры с пакета Joomla тоже не идут. Разница в том, что на хосте у меня PHP 5.2.6, а дома 5.1.6. Что здесь можно сделать, чтоб все заработало?
*

AlteTraum

  • Захожу иногда
  • 118
  • 1 / 3
  • Тут может быть ваша реклама
Думаю, обратится к хостеру.
А стандартные баннеры у тебя отображаются, джумловские?
Друг любит во всякое время и, как брат, явится во время несчастья. Спасибо всем за помощь!
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
Думаю, обратится к хостеру.
А стандартные баннеры у тебя отображаются, джумловские?


Нет они тоже не отображаются на хосте. Выбрать могу при выборе вижу их. Дома же отображаются.
*

Doc

  • Захожу иногда
  • 449
  • 17 / 0
У меня такое бывало когда другие стили ( темы) устанавливал и некоторые вообще так и не отображают, а в некоторых нужно поменять его место появления
Зайдите настройку модуля и попробуйте все места его появления
Может где и проявиться, а там уже дальше будети искать причину шаблона
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
У меня такое бывало когда другие стили ( темы) устанавливал и некоторые вообще так и не отображают, а в некоторых нужно поменять его место появления
Зайдите настройку модуля и попробуйте все места его появления
Может где и проявиться, а там уже дальше будети искать причину шаблона


Попробовал разные позиции, не помогло. Текстовая часть идет, ссылка тоже, а рисунка по-прежнему нет. Тот же шаблон на домашнем ПК прекрасно отображает баннер в любой позиции. А кто-нибудь знает какие специфические настройки и требования для для этого модуля должны быть? Буду искать адрес производителя, чтоб там почитать, если подскажите ссылку - буду благодарен.
*

dimsa

  • Захожу иногда
  • 135
  • 32 / 0
Было у меня такое..на Joomla 1.0.15. Все дело в пути: обычно баннеры размещаются в images/banners/? но при просмотре через медиа их там я не вижу, т.е. просто есть файл, а сам баннер не отображается... пришлось просто изменить название папки на imgbanners/ - назначить права! После этого в стандартном компоненте поправить пути.. и все заработало!

P.s. Очевидно дело в настройках хоста, какм то образом он режет папку banners
Верьте в будущее и оно наступит.
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
Решил этот вопрос поставив другой модуль camp26 carousel_banner.

Спасибо, посмотрю и попробую ваш метод и отпишу о результате, что-то не любит меня стандартный mod_banners, на второй Joomla 1.5 на том же хосте отказывается выводить GIF - баннеры. Вернул те, что шли по умолчанию с Joomla и они перестали выводится. Видимо, действительно проблема в настройках хоста. Все-таки хочется, чтоб родной модуль работал корректно.

а скорее всего это настройки антивируса !!!  ;)

где меняется путь к папке банеров???
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
а скорее всего это настройки антивируса !!!  ;)

где меняется путь к папке банеров???

В параметрах не нашел смену пути к папке с баннерами. Т.е. если как-то сменить название папки и путь, то антивирус не опознает и пропустит?
*

KoMoToZZZ

  • Новичок
  • 2
  • 0 / 0
Решил этот вопрос поставив другой модуль camp26 carousel_banner.
Подскажи как решил эту проблему поставил этот модуль, все равно нет отображения?
*

KoMoToZZZ

  • Новичок
  • 2
  • 0 / 0
После этого в стандартном компоненте поправить пути.. и все заработало!
Как поменять путь? Я изменил имя папки в медиа менеджере они теперь отображаются.
*

Roman Petrenko

  • Захожу иногда
  • 437
  • 61 / 0
  • Дизайн без секретов
Как поменять путь? Я изменил имя папки в медиа менеджере они теперь отображаются.

Думаю лезть в файлы самого модуля баннеров и там искать images/banners/ и менять на Ваше название папки.
*

Dj Nek

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Почитал вашу тему, тоже была проблема с гифкой, решил попробовать с переименованием папки для начала нашел где прописывается путь - в файлике administrator/components/com_banners/controllers/banner.php

Строки
// Imagelist
      $javascript         = 'onchange="changeDisplayImage();"';
      $directory         = '/images/imgbanners';
      $lists['imageurl']   = JHTML::_('list.images',  'imageurl', $row->imageurl, $javascript, $directory, "bmp|gif|jpg|png|swf"  );

но проблема тем самым не решилась  :(

Ребята подскажите незнающему, нашел в админке компонент баннер в нем создал Клиента, и Категорию дальше сам баннер создал, опубликовал его в менеджере модулей и смотрю он только в разделе меню появляеться, по другому никак не получаться, что еще нужно сделать что бы баннер был вверху шаблона там где логотип, шаблон у меня не стандартный снизу скрины, заранее благодарен за помощь

« Последнее редактирование: 18.06.2010, 20:06:14 от Memphis21 »

Неужели некто не знает ? пробовал возится с модулями как не крутил всеравно получается поставить только как меню, может кто знает как его прикрутить к верху там где висит логотип ?
*

denmos

  • Захожу иногда
  • 96
  • 7 / 0
  • SINTEZ2 + мафон "легенда"
что бы баннер был вверху шаблона там где логотип
по идее в модуле нужно задать позицию top, если она предусмотрена шаблоном, ели нет/не там , где нужно -  править/искать другой шаблон
*

NukeLAI

  • Новичок
  • 14
  • 0 / 0
Было у меня такое..на Joomla 1.0.15. Все дело в пути: обычно баннеры размещаются в images/banners/? но при просмотре через медиа их там я не вижу, т.е. просто есть файл, а сам баннер не отображается... пришлось просто изменить название папки на imgbanners/ - назначить права! После этого в стандартном компоненте поправить пути.. и все заработало!

P.s. Очевидно дело в настройках хоста, какм то образом он режет папку banners
Сегодня такая же ситуация, возникла.
Залив zip'овский архив с отредактированными баннерками через файловый менеджер хостера, и разпоковав его в папку медийный менеджер в этой папке не видит ничего, так что будьте все аккуратнее
Почитал вашу тему, тоже была проблема с гифкой, решил попробовать с переименованием папки для начала нашел где прописывается путь - в файлике administrator/components/com_banners/controllers/banner.php

Строки
// Imagelist
      $javascript         = 'onchange="changeDisplayImage();"';
      $directory         = '/images/imgbanners';
      $lists['imageurl']   = JHTML::_('list.images',  'imageurl', $row->imageurl, $javascript, $directory, "bmp|gif|jpg|png|swf"  );

но проблема тем самым не решилась  :(
по умолчанию в папке banners  хтмл один лежит, может его продублировать в новую папку стоит?
*

Kayser

  • Захожу иногда
  • 50
  • 1 / 0
Менял названия папки, правил путь в administrator/components/com_banners/controllers/banner.php - нет, не помогло. В Менеджере модулей->Give Life (в моём случае) переставил - Искать по тегам с ДА на НЕТ. Всё показывает!
*

InfRiNgeR Of CalmNeS

  • Новичок
  • 19
  • 0 / 0
«Есть мечта? Беги к ней! Не получается бежать? Иди! Не получается идти? Ползи! Не можешь ползти? Ляг и лежи в ее направлении.» © В. Успенский.
*

drema71

  • Новичок
  • 4
  • 0 / 0
помогите пожалуйста баннеры все отображаются но не могу ссылку вставить, вернее вставляю но не работает на баннере, модуль стандартный, заранее спасибо Joomla последняя
« Последнее редактирование: 31.01.2015, 17:41:51 от drema71 »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как увиличить максимальное количество символов в стандартном модуле (mod_custom)?

Автор genkey

Ответов: 0
Просмотров: 567
Последний ответ 27.04.2017, 14:41:22
от genkey
Не отображаются материалы и ссылки на сайте (joomla 1.5)

Автор МарияЛ

Ответов: 1
Просмотров: 563
Последний ответ 18.03.2017, 19:22:31
от rebus
Не отображаются страница материалов

Автор MOZ

Ответов: 8
Просмотров: 765
Последний ответ 28.02.2016, 19:50:37
от effrit
Как применить атрибут size для элемента select в модуле simpleform 2?

Автор Loh

Ответов: 5
Просмотров: 967
Последний ответ 06.06.2015, 13:44:28
от motokraft
Вывести view в модуле

Автор xim002

Ответов: 0
Просмотров: 631
Последний ответ 31.03.2015, 14:27:40
от xim002