0 Пользователей и 1 Гость просматривают эту тему.
  • 14 Ответов
  • 2707 Просмотров

При установке на локальный денвер, на 4ом шагу (создание БД) перестает работать кнопка Далее.
пробовал другой браузер, переваливал папку - бесполезно. подскажите плз!


Denwer3_Base_2008-01-13_a2.2.4_p5.2.4_m5.0.45_pma2.6.1.exe

Joomla_1.5.9-Stable-Full_Package-Russian
*

XprogeR

  • Новичок
  • 5
  • 0 / 0
Проблема, непонятного характера, пытался понять в чём дело выяснил что ошибка происходит в функции validaeForm по-моему так, а ещё возникает ошибка в mootools. Большая просьба, кто сталкивался отпишитесь!

От сборки не зависит, что в русской сборке 1,5,9 с этого сайта что в офф сборке 1,5,9 всё тоже.  !!!???!!!
*

SlemIdc

  • Новичок
  • 6
  • 0 / 0
Такая же ситуация возникла(( без понятия что делать, всё перепробовал. Порылся на других форумах, почти везде есть такая тема, но ни одного ответа.
*

SlemIdc

  • Новичок
  • 6
  • 0 / 0
А вот народ ещё вопрос: у кого такой баг прошиб какая винда стоит??
*

XprogeR

  • Новичок
  • 5
  • 0 / 0
Стоит Vista SP1, web-сервер MOWES. Также наблюдал тему на орг но там тоже решеня нет. ЗЫ: Проблема в JS что-то там браузеру не нравиться:

При загрузке:

Код
Ошибка: missing } after function body
Источник: http://gg.ru/media/system/js/mootools.js
Строка 109, символ 107
Исходный код:
else args=options.arguments||arguments;var returns=function(){return fn.apply($pick(options.bind,fn),args);}

Код
Ошибка: Window.onDomReady is not a function
Источник: http://gg.ru/installation/template/js/validation.js
Строка: 243

Код
Ошибка: Window.onDomReady is not a function
Источник: http://gg.ru/installation/index.php
Строка: 19


По нажатию на кнопку "Далее":

Код
Ошибка: document.formvalidator is null
Источник: http://gg.ru/installation/index.php
Строка: 89

Так же на кнопке "Далее" прекреплены две функции:
Код
submitForm();
validateForm();

В нашем случае, вторая не рабочая уже во второй строчке. Хотя после проверки она вызывает первую.
Так вот на первое время есть решение: Заменить validateForm на submitForm, проверил всё работает. НО потом будет ли корректно работать сама CSM?

*

Physicist

  • Глобальный модератор
  • 918
  • 185 / 0
  • Рябов Денис
Так вот на первое время есть решение: Заменить validateForm на submitForm, проверил всё работает. НО потом будет ли корректно работать сама CSM?

Будет, не волнуйтесь.

PS. Сам недавно столкнулся с этой проблемой, правда при тестировании Joomla!1.6 - увы, даже там эта проблема все еще не исправлена. Честно говоря, с одной стороны было лень разбираться откуда возникает эта проблема, и с другой стороны у меня сейчас катастрофически мало свободного времени на такие вещи, так что самым простым выходом для меня было просто закомментировать валидацию.
*

XprogeR

  • Новичок
  • 5
  • 0 / 0
А вот и счастье привалило:

Цитировать
Solution:
Open up httpd.conf
search for EnableSendfile off
Remove the # in front of EnableSendfile off

Кто англ не понимает:
Открываем конфигурационный файл апатча httpd.conf

Ищем строчку: EnableSendfile off

Удаляем перед ней # (Разкомментируем).

Не забываем перезапустить веб сервер!

Вот и счастье! =) Ну по крайней мере у меня заработало.

Ещё один важный момент, если не работает на хостинге, то стоит проверить все ли файлы присутствуют, а так-же заливать в бинарном режиме, на оргах говорили что распаковывали на хостинге при помощи утилит, но не распаковывались некоторые [root]/media/ файлы, посему была ошибка. Также были проблемы с файлзилой.
« Последнее редактирование: 05.02.2009, 23:21:38 от XprogeR »
*

SlemIdc

  • Новичок
  • 6
  • 0 / 0
Я тока начинающий в этом деле, подскажите как в этот код зайти??
 Я создал сайт на компе друга потом перекинул себе, сайт работает, но меню в админке так же не работает, там тот же стиль кнопок) Будут ли они работоспособны после этого изменнения?
*

SlemIdc

  • Новичок
  • 6
  • 0 / 0
ок) щас попробуем) тока скажи плз как и где в этот код войти?
*

XprogeR

  • Новичок
  • 5
  • 0 / 0
Я тока начинающий в этом деле, подскажите как в этот код зайти??
 Я создал сайт на компе друга потом перекинул себе, сайт работает, но меню в админке так же не работает, там тот же стиль кнопок) Будут ли они работоспособны после этого изменнения?
Да, идеи да.

ок) щас попробуем) тока скажи плз как и где в этот код войти?

Это файл настройки Apache сервера, в папке апача ищи ./conf/httpd.conf
*

SlemIdc

  • Новичок
  • 6
  • 0 / 0
XprogeR огромное спс, помогло) менюшку в админке пока не тестил, щас доберусь отпишу или ты отпиши работает ли у тебя.
*

XprogeR

  • Новичок
  • 5
  • 0 / 0
Я же написал ещё в посте с решением что работает! =)
*

Nik Nak

  • Новичок
  • 5
  • 0 / 0
У меня на четвертом шаге проблем не было, но не работали верхние менюшки в админке.
Попробовал, как было описано выше(убрал # в строке # EnableSendfile off), но верхние менюшки в админке, так и не стали рабочими.
« Последнее редактирование: 06.02.2009, 14:48:53 от Nik Nak »

Та же проблема народ спасайте  >:( .Способ тот что выше не помогает =( .


Добавлено: Проблему решил установкой оперы и через нее уже установил =) .
« Последнее редактирование: 19.02.2009, 01:11:26 от dragondead »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

500 Internal Server Error при установке Joomla на мастерхосте

Автор mggirl

Ответов: 24
Просмотров: 20352
Последний ответ 01.09.2016, 10:30:38
от Seal_LOSrec
ошибка в установке J2XML

Автор Lennyvchik

Ответов: 4
Просмотров: 980
Последний ответ 10.11.2015, 16:52:45
от draff
Как сделать откат изменений на Joomla?- перестал работать сайт?

Автор Андрей2485

Ответов: 6
Просмотров: 2815
Последний ответ 26.03.2015, 03:22:06
от Андрей2485
При установке Joomla на хостинг не работает кнопка "далее"

Автор krovidey

Ответов: 11
Просмотров: 5477
Последний ответ 04.12.2014, 20:59:07
от василь
[Решено] Ошибка Fatal error: Maximum execution time of 30 seconds exceeded при установке

Автор klara7

Ответов: 13
Просмотров: 47279
Последний ответ 11.11.2014, 19:11:26
от fixbob