0 Пользователей и 1 Гость просматривают эту тему.
  • 25 Ответов
  • 8484 Просмотров
*

zet310

  • Новичок
  • 14
  • 0 / 0
Делал перенос других сайтов, созданных в качестве учебных мною (более простые) работали.
По той же анологии переношу уже свой новый сайт и не работет!

Сделал экспаорт\импорт базы
Перенёс файлы на хостинг
Подправил файл конфигурации

В итоги набирая адрес сайта, просто белое окно блаузера. Без каких либо ошибок. Как уже не эксперементировал, не получается. именно с этим сайтом белое окно блаузера... =(

Подскажите что проверить ещё...(

Joomla 1.5.7
Сайт: http://malysh.net/
« Последнее редактирование: 23.09.2010, 02:25:26 от 4webspot »
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
я бы с логов начал. может что и всплыло.
http://joomlaforum.ru/index.php/topic,63122.0.html
« Последнее редактирование: 20.05.2009, 10:27:42 от daho »
Это сарказм?
*

VETERINAR

  • Давно я тут
  • 855
  • 165 / 14
  • Kiss my shiny metal ass!
Всего несколько вариантов. Других быть просто не может:

1. В конфиге что-то не подправили (например имя базы забыли изменить, вписали пароль к базе в поле доступа smtp и т.п.)
2. База данных не залилась корректно, либо вы залили в одну базу, а в конфиге другую указали ( 50% "белых экранов" в итоге по этой причине )
3. Какие-то файлы на залилиси или залились битыми.
*

zet310

  • Новичок
  • 14
  • 0 / 0
Спасибо что откликнулись!

я бы с логов начал. может что и всплыло.
http://joomlaforum.ru/index.php/topic,63122.0.html
не смог найти логи ошибок...(

Всего несколько вариантов. Других быть просто не может:

1. В конфиге что-то не подправили (например имя базы забыли изменить, вписали пароль к базе в поле доступа smtp и т.п.)
2. База данных не залилась корректно, либо вы залили в одну базу, а в конфиге другую указали ( 50% "белых экранов" в итоге по этой причине )
3. Какие-то файлы на залилиси или залились битыми.

1. Ниже выложу конфу... Мог и в ней накосячить. Изменял только: Хост, имя базы, логин, пароль и пути к log и tmp.
2. Старую базу удалил, залил новую. Пробывал не один раз (думаю залилась без ошибок хоть раз).
3. Заливал архив и после его распаковывал, тоже много раз пытался...

Код
<?php
class JConfig {
var $offline = '0';
var $editor = 'tinymce';
var $list_limit = '100';
var $helpurl = 'http://help.joomla.org';
var $debug = '0';
var $debug_lang = '0';
var $sef = '0';
var $sef_rewrite = '0';
var $sef_suffix = '0';
var $feed_limit = '10';
var $secret = 'wA2iHacQimNFdvZQ';
var $gzip = '0';
var $error_reporting = '-1';
var $xmlrpc_server = '0';
var $log_path = '/home/b/byzaru/malysh/public_html/logs';
var $tmp_path = '/home/b/byzaru/malysh/public_html/tmp';
var $live_site = 'http://malysh.net';
var $offset = '2';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '0';
var $ftp_host = '127.0.0.1';
var $ftp_port = '21';
var $ftp_user = '';
var $ftp_pass = '';
var $ftp_root = '';
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = '*****';
var $db = '******';
var $dbprefix = 'jos_';
var $mailer = 'mail';
var $mailfrom = '******@yandex.ru';
var $fromname = 'Весёлый малыш';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';
var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '15';
var $session_handler = 'database';
var $password = '*****';
var $sitename = '';
var $MetaDesc = 'Детская мебель. Детские коляски. Детское питание. Калининград. Магазин Малыш. Весёлый малыш';
var $MetaKeys = 'Детская мебель. Детские коляски. Детское питание. Калининград. Магазин Малыш. Весёлый малыш';
var $offline_message = 'Сайт сейчас закрыт на техническое обслуживание. Пожалуйста зайдите позже.';
}
?>
*

Robinson

  • Захожу иногда
  • 442
  • 72 / 1

Подскажите что проверить ещё...(

Зайдите в админку http://malysh.net/administrator/ и выберите по умолчанию какой-нибудь шаблон существующий
*

VETERINAR

  • Давно я тут
  • 855
  • 165 / 14
  • Kiss my shiny metal ass!
Зайдите в админку

В админку его не пустит. Я пробовал ввести левые имя и пароль - белый экран, т.е. что-то с базой данных, мне кажется.
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
да наверное, просто разные кодировки при импорте/экспорте базы
Это сарказм?
*

zet310

  • Новичок
  • 14
  • 0 / 0
Зайдите в админку http://malysh.net/administrator/ и выберите по умолчанию какой-нибудь шаблон существующий
« Последнее редактирование: 20.05.2009, 15:40:03 от zet310 »
*

zet310

  • Новичок
  • 14
  • 0 / 0
В админку как и на сайт после ввода данных - белый экран...(

Тоесть поэксперементировать с базой данных???
Что именно можите посоветывать? Я уже пробывал сжимать и нет.

Я вообще вперые воспользовался Joomla и раньше дело с БД не имел... На первый взгляд вроде импортируется хорошо, без ошибок и карякозябов) До это более простой сайт получалось, он работал. Щас вроде всё тоже самое делаю с БД.
« Последнее редактирование: 20.05.2009, 15:42:08 от zet310 »
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
Ну для начала повторить
Сделал экспаорт\импорт базы
,предварительно очистив существующюю базу.
Обратите внимание на кодировки в которых импортируете и экспортируете, будет лучше если они одинаковые. Через phpmyadmin работаете?
Это сарказм?
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
у вас теперь ошибка появилась
Код
jtablesession::Store Failed
DB function failed with error number 1146
Table 'byzaru_mal.jos_session' doesn't exist SQL=INSERT INTO `jos_session` ( `session_id`,`time`,`username`,`gid`,`guest`,`client_id` ) VALUES ( '9232dc0c9e6f18bae8e56c8e8134edfc','1242820272','','0','1','0' )
Тут запрос идёт в базу с одним префиксом а стоит с другим


проверьте префикс базы, вручную посмотрите наличие таблицы 'byzaru_mal.jos_session' либо 'jos_session' - какая у вас? Но сначала в файле которым экспортируете БД смените арес сервера с локалхост на malysh.net (сохраняйте кодировку)
« Последнее редактирование: 20.05.2009, 16:00:20 от daho »
Это сарказм?
*

zet310

  • Новичок
  • 14
  • 0 / 0
Ну для начала повторить  ,предварительно очистив существующюю базу.
Обратите внимание на кодировки в которых импортируете и экспортируете, будет лучше если они одинаковые. Через phpmyadmin работаете?

Да, через phpmyadmin. Кодировки сохраняю.


у вас теперь ошибка появилась
Код
jtablesession::Store Failed
DB function failed with error number 1146
Table 'byzaru_mal.jos_session' doesn't exist SQL=INSERT INTO `jos_session` ( `session_id`,`time`,`username`,`gid`,`guest`,`client_id` ) VALUES ( '9232dc0c9e6f18bae8e56c8e8134edfc','1242820272','','0','1','0' )
Тут запрос идёт в базу с одним префиксом а стоит с другим


проверьте префикс базы, вручную посмотрите наличие таблицы 'byzaru_mal.jos_session' либо 'jos_session' - какая у вас? Но сначала в файле которым экспортируете БД смените арес сервера с локалхост на malysh.net (сохраняйте кодировку)

Это всё в БД? не в конфигурации? изенять всё в phpmyadmin??? Щас попробую...
Спасибо за помощь и консультации...
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
Цитировать
Это всё в БД? не в конфигурации? изенять всё в phpmyadmin???
Да это уже касаемо БД, вы выкладывали конфиг: var $dbprefix = 'jos_'; на хосте http://malysh.net/ точно так же, все названия таблиц (в колонке слева) начинаются с jos_? Ничего лишнего перед jos не должно быть.
ещё вопрос: уже на http://malysh.net/ вы туда просто файлы залили или повторно установку провели?
Советую сделать так:
1 через phpmyadmin уничтожить на http://malysh.net/ все таблицы из базы (базу оставить).
2 на локалхосте через phpmyadmin забрать БД, получаем файл типа: mybase.sql В нём посредством реактора (EmEditor или Notepad++ только они позволяют сохранить кодировку) меняем ВСЕ Localhost на malysh.net
3 через phpmyadmin на http://malysh.net/ залить в  БД изменённый mybase.sql
Это сарказм?
*

zet310

  • Новичок
  • 14
  • 0 / 0
Да, jos_ к примеру: jos_banner

Экспериментальным путём выяснил, что ошибка:
Код
jtablesession::Store Failed
DB function failed with error number 1146
Table 'byzaru_mal.jos_session' doesn't exist SQL=INSERT INTO `jos_session` ( `session_id`,`time`,`username`,`gid`,`guest`,`client_id` ) VALUES ( '0037d35e80c5610ef92aeb4c1679e145','1242821468','','0','1','0' )
Когда базы вообще нет, когда удалена.

А когда она есть ошибок нет, просто белый экран

На http://malysh.net/ просто залил файлы.

Цитировать
Советую сделать так:
1 через phpmyadmin уничтожить на http://malysh.net/ все таблицы из базы (базу оставить).
2 на локалхосте через phpmyadmin забрать БД, получаем файл типа: mybase.sql В нём посредством реактора (EmEditor или Notepad++ только они позволяют сохранить кодировку) меняем ВСЕ Localhost на malysh.net
3 через phpmyadmin на http://malysh.net/ залить в  БД изменённый mybase.sql

Сдедал всё. Там тока изменить пришлось хост и название БД. Всё равно белое.

Кстати там был другой сайт, я БД не удалял, удалил таблицы. может из-за этого? Хотя как удалить всю БД я не нащёл...

И ещё не влият ли на это, чт она хочтинге есть лишнии папки? Я туда бэкап старого сайта скинул.
« Последнее редактирование: 20.05.2009, 16:59:23 от zet310 »
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
через phpmyadmin базу редактируете под тем же именем и паролем что и в конфиге?
версии MySQL на локалхосте и у провайдера одна и та же? и какая если не секрет?
Это сарказм?
*

zet310

  • Новичок
  • 14
  • 0 / 0
через phpmyadmin базу редактируете под тем же именем и паролем что и в конфиге?
версии MySQL на локалхосте и у провайдера одна и та же? и какая если не секрет?

Базу редактировал Notepad++ на компе, а потом заливал. Для захода на базу те же логин и пароль.
Версии на локалхост: phpMyAdmin 2.6.1, провайдер: phpMyAdmin - 2.11.9.1

Я уже делал в учебных целях другой сайт и он работал...

И ещё не влият ли на это, чт она хочтинге есть лишнии папки? Я туда бэкап старого сайта скинул.
*

zet310

  • Новичок
  • 14
  • 0 / 0
Ещё когда запускаю phpMyAdmin на локальном он пишет внизу:

Ваш конфигурационный файл содержит настройки (пользователь root без пароля), которые относятся к привилегированному пользователю MySQL (по умолчанию). Ваш MySQL сервер запущен с этими настройками по умолчанию, открытый для вторжений, поэтому Вам настоятельно рекомендуется устранить эту дыру в безопасности.

Ещё вот что пишет:
Добро пожаловать в phpMyAdmin 2.6.1
MySQL 5.0.45-community-nt на localhost как root@localhost
*

zet310

  • Новичок
  • 14
  • 0 / 0
УРА!!!!!!!!!!!! заработало.

daho огромное спасибо за помощь!
Почему не работало так и не понял... Просто взял удалил с хостинга и снова залил. Удалил БД и тож перезалил. Заново подправил файл конфигурации через Notepad++

Всё это я и так делал десяток раз, но ведь не работало, а щас работает =)


Но! есть ещё мини проблемы...

Нельзя войти на сайт под существующим (зарегеным именем)... Зарегится можно! пользователь отобразается в административной части, но пишет что не работает отправка почты. Но войти под ним нельзя. К примеру вот данные:
логин - demo
пасс - demo
появляется чистая, белая страница...
« Последнее редактирование: 21.05.2009, 02:25:26 от zet310 »
*

daho

  • Захожу иногда
  • 138
  • 6 / 0
           var $smtpauth = '0';
   var $smtpuser = '';
   var $smtppass = '';
   var $smtphost = 'localhost';
это настройки в конфиге для почты, значения должен дать провайдер для вашего сайта

по поводу логина - это опять что-то с базой вроде))) пользователи добавляются в список пользователей VirtueMart?
Это сарказм?
*

zet310

  • Новичок
  • 14
  • 0 / 0
по поводу логина - это опять что-то с базой вроде))) пользователи добавляются в список пользователей VirtueMart?

Да в список joomla и VirtueMart новые пользователи добавляются. Я уже пробывал стандартный модуль входа и от VirtueMart. И там и там одинаковая история - белый экран после ввода данных.

Через комюнити билдер получилось реализовать вход, выход, но остаётся пробема с Виртуал март. хочется через него всё же...
« Последнее редактирование: 21.05.2009, 14:20:09 от zet310 »
*

Serena Dark

  • Захожу иногда
  • 99
  • 2 / 0
Доброго времени суток!
Плохо, zet310 , что вы не поняли, почему заработало, потому что я столкнулась с такой же проблемой.

Joomla 1.5.15

На localhost:
PHP 5.2.4
MySQL 5.0.45
phpMyAdmin 2.6.1

на сервере:
PHP 4.4.7
MySQL 5.0.41
phpMyAdmin  2.10.2

- Залила по фтп, проставила нужные права доступа
- исправила конф.файл (просто скопировала туда то, что было при установке на сервер с нуля)
- импортировала с локалки БД (несколько раз перепроверела, вроде все верно - localhost встречался только в строке jos_session, но вроде он ибез данных этой таблицы нормально работает, префиксы и на локальной БД и на внешней одинаковые, через phpMyAdmin данные отображаются корректно, если сделать на сервере дамп и залить его на локалку - все работает)

Если устанавливать Joomla с нуля, то все замечательно работает.
А при переносе с локалки = белый экран смерти
Joomla сперва была 1.5.14, но в только что обновила до 1.5.15 и снова проделала все вышеперечисленное
error.log сначала ругался на отсутствие favicon.ico, потом стал выдавать следующее

Код
[Tue Dec 08 22:28:03 2009] [error] [client 127.0.0.1] File does not exist: /usr/local/www/apache22/data/sitename/nafanya/nafanya

при всем при том, что корневой каталог /usr/local/www/apache22/data/sitename/nafanya/ (nafanya - это поддомен, адрес выглядит nafanya.sitename.ru)

что еще можно попробовать, подскажите, кто знает?
*

Serena Dark

  • Захожу иногда
  • 99
  • 2 / 0
Слушайте, а есть такая вероятность, что у меня Denver криво работает? Я его поставила под Windows 7. Может стоит попробовать поставить на WinXP и все повторить? Может это из-за некорректной работой под семеркой? Хотя локально никаких ошибок не возникало. Denwre последней конфигурации (должен быть)
*

Serena Dark

  • Захожу иногда
  • 99
  • 2 / 0
и все-таки походу дела беда была или в кривом дампе, или в кривой заливке, потому что перенесла все джумпаковским архивом и джумпаком установила, и все появилось! но! из-за проблем с хостом не проставлялись CHMOD, посему после залогинивания на сайте и в админке приходилось стирать из урла index.php, иначе висел белый экран.
« Последнее редактирование: 16.12.2009, 00:57:38 от Serena Dark »
*

Наташа

  • Захожу иногда
  • 170
  • 0 / 1
Ребята, помогите, пожалуйста, разобраться в непонятной ситуации. :'(
Копия сайта, созданного на одной машине, устанавливается мною на моём ПК через SPTServer. Снесла Денвер, установила STPServer, как продолжение TОPServer на котором создавался импортируемый сайт. Надеюсь, меньше будет противоречий.
Руководствовалась рекомендациями с форума и видеоуроком создания сайта на STPServer. Базу создала, содержимое импортировала; папку сайтом, который надо установить, поставила в T:\home\virtual; свежее инсталлируемую копию Joomla – туда же.
Инсталлировала  Joomla, привязала к базам, снесла установочные базы и залила импорт, скопировала configuration.php,  снесла свежеустановленный сайт, залила файлы импортируемого сайта + configuration.php инсталл.
После ряда действий админпанель открывается нормально и работает, но сам сайт в браузете представлен строкой:  «Сеанс Вашего подключения закончился. Пожалуйста, авторизуйтесь снова» и таблицей с названием сайта, текстом с 404 и требованием авторизации. На логин и пароль не реагирует. Никогда с таким не сталкивалась. Работа стынет – помогите!
 !
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Наташа,

пробовали авторизировать второй раз подряд, несмотря на ошибку?

сообщите нам версию Joomla и в какой среде она работает. STP/SPT/TOP серверы? что за звери?
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

Наташа

  • Захожу иногда
  • 170
  • 0 / 1
Мне дали копию сайта 1,5,14 с базами формате  .sql единым файлом в 3Мб, созданным на топ сервере. Снесла Денвер, установила STPServer, как продолжение TОPServer на котором создавался импортируемый сайт. Чтобы меньше было противоречий.
Руководствовалась рекомендациями с форума и видеоуроком создания сайта на STPServer. Базу создала, содержимое импортировала; папку сайтом, который надо установить, поставила в T:\home\virtual; Обновила до 1,5,20. На логин и пароль главная страница не реагировала даже на несколько попыток подряд, а теперь и это пропало – белая страница.
OS: WINNT (но у меня по факту ХР)
Uptime: 0 Д, 17 Ч, 49 М и 36 С
PHP: 5.2.14
SoftWare: Apache/2.2.16 (Win32) PHP/5.2.14
Server-name: admin
StpServer Version 1.0
« Последнее редактирование: 23.09.2010, 20:25:05 от Наташа »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как перенести сайт с сервера на сервер? (с хостинга на локалку и наоборот)

Автор djed9

Ответов: 242
Просмотров: 97476
Последний ответ 04.09.2017, 16:14:23
от voland
Ошибка после восстановления сайта из резервной копии

Автор Роман1974

Ответов: 9
Просмотров: 6137
Последний ответ 18.05.2017, 15:15:40
от Igoritaly
[Решено] Как обновить Joomla 1.5 (версии, способы обновления и т.д.)

Автор Danka

Ответов: 45
Просмотров: 183724
Последний ответ 06.04.2017, 12:14:12
от SeBun
Роблемы после ручного обновления сайта

Автор dron

Ответов: 4
Просмотров: 546
Последний ответ 12.03.2017, 15:02:20
от dron
[Решено] Ошибка: Cannot send session cookie - headers already sent by...

Автор Sokali

Ответов: 84
Просмотров: 198924
Последний ответ 28.11.2016, 16:58:14
от Bug_ai