0 Пользователей и 1 Гость просматривают эту тему.
  • 27 Ответов
  • 7514 Просмотров
*

Stremno

  • Новичок
  • 5
  • 0 / 0
Возникли две проблемы с JomSocial:

В созданной группе не загружаеться аватар группы. Вылетает пустая страница при попытке загрузки.
В фотоальбом не добавляються фото. Процесс загрузки проходит нормально, а вот фото в альбоме не появляеться. При этом альбом создаёться нормально.
*

yondo

  • Осваиваюсь на форуме
  • 16
  • 1 / 0
  • joomla 1.5
Re: Ошибка при загрузке аватара
« Ответ #1 : 07.06.2009, 21:30:07 »
а вот у меня после установки версии 1.2.192 вообще не запускается.. компонент. что делать не знаю..
*

Sidtan

  • Захожу иногда
  • 70
  • 0 / 0
  • вМоскве.рф
Re: Ошибка при загрузке аватара
« Ответ #2 : 28.06.2009, 10:45:42 »
У меня не добавляет в друзья, окно открывается, запрос, а дальше ни чего. Что делать?
*

Aport13

  • Осваиваюсь на форуме
  • 18
  • 1 / 0
Re: Ошибка при загрузке аватара
« Ответ #3 : 29.07.2009, 23:40:32 »
У меня также не загружается иконка в группы.
Не загружается видео
Не загружается аватар

На локалхосте все работает отлично. Дитрибутив тот же.  Сдается мне, это настройки сервака или chodы где-то выставлены косо.
*

radru

  • Осваиваюсь на форуме
  • 35
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #4 : 25.12.2009, 14:38:36 »
Подскажите почему, когда я загружаю аватар на группу у меня выдает ошибку

Цитировать
Fatal error: Uncaught exception 'ImagickException' with message 'The path does not exist: /var/www/brd5po/brd.in.ua/images/avatar/groups/9c2272c7612b8c7ac74db2ce.png' in /var/www/brd5po/brd.in.ua/components/com_community/helpers/image.php:131 Stack trace: #0 /var/www/brd5po/brd.in.ua/components/com_community/helpers/image.php(131): Imagick->writeimage('/var/www/brd5po...') #1 /var/www/brd5po/brd.in.ua/components/com_community/controllers/groups.php(1466): cImageResizePropotional('/var/www/brd5po...', '/var/www/brd5po...', 'image/png', 160) #2 /var/www/brd5po/brd.in.ua/components/com_community/controllers/controller.php(292): CommunityGroupsController->uploadAvatar() #3 /var/www/brd5po/brd.in.ua/components/com_community/community.php(101): CommunityBaseController->execute('uploadavatar') #4 /var/www/brd5po/brd.in.ua/libraries/joomla/application/component/helper.php(162): require_once('/var/www/brd5po...') #5 /var/www/brd5po/brd.in.ua/includes/application.php(124): JComponentHelper->renderComponent('com_community') #6 /var/ in /var/www/brd5po/brd.in.ua/components/com_community/helpers/image.php on line 131

на сайте http://brd.in.ua пожалуйста...  !
*

Blessure

  • Захожу иногда
  • 119
  • 4 / 0
Re: Ошибка при загрузке аватара
« Ответ #5 : 23.01.2010, 17:20:26 »
такаяже проблема Права поменены но без изменений
*

steelcat

  • Захожу иногда
  • 118
  • 13 / 0
Re: Ошибка при загрузке аватара
« Ответ #6 : 23.01.2010, 18:41:35 »
Насчет аватара группы - все просто - создайте папку images/avatar/groups
*

Blessure

  • Захожу иногда
  • 119
  • 4 / 0
Re: Ошибка при загрузке аватара
« Ответ #7 : 23.01.2010, 23:31:54 »
Да дело в том что всё создано..

И папки 777 ивсё как надо..

Мож сервер глючит...
*

steelcat

  • Захожу иногда
  • 118
  • 13 / 0
Re: Ошибка при загрузке аватара
« Ответ #8 : 24.01.2010, 21:13:50 »
Ну фиг знает, когда то я дома сервак на Линухе настраивал, так я не указал папку для загрузки в настройках сервака и ничего не грузилось, но на хостинге все должно быть пучком. другие скрипты ведь не глючат с загрузкой? Проверь разрешенный разер загружаемых файлов на сервере, может очень маленький задан?
*

Blessure

  • Захожу иногда
  • 119
  • 4 / 0
Re: Ошибка при загрузке аватара
« Ответ #9 : 24.01.2010, 22:27:01 »
Да нет другое неглючит только вроде Socialka
*

kharol

  • Moderator
  • 1723
  • 217 / 0
Re: Ошибка при загрузке аватара
« Ответ #10 : 02.02.2010, 07:36:16 »
Потому что нет папки /images/avatar/groups
Чтобы сказать "спасибо" достаточно нажать на "+"
Чтобы сделать бухгалтерскую проводку "спасибо" реквизиты: R192102130372, ЯД:41001768818003
*

radru

  • Осваиваюсь на форуме
  • 35
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #11 : 13.02.2010, 18:16:27 »
Потому что нет папки /images/avatar/groups
Большое спасибо помогло!
*

Ecspert

  • Захожу иногда
  • 418
  • 12 / 0
Re: Ошибка при загрузке аватара
« Ответ #12 : 26.07.2010, 22:52:16 »
Нашол JomSocial Version: 1.8.5 русскую, всё работает но при попытке загрузки аватара в формате GIF: (в jpg - норм)

Код
Fatal error: Uncaught exception 'ImagickException' with message 'memory allocation failed `/home/master/public_html
/tmp/8030a2c71419ab47bcf7e65c1b096671' @ error/gif.c/WriteGIFImage/1627' in /home/master/public_html/components/com_community/helpers
/image.php:227 Stack trace: #0 /home/master/public_html/components/com_community/helpers/image.php(227):
Imagick->writeimage('/home/master/pu...') #1 /home/master/public_html/components/com_community/controllers/profile.php(1324):
CImageHelper::createThumb('/tmp/phpBv7MBK', '/home/master/pu...', 'image/gif') #2 /home/master/public_html/components/com_community
/controllers/controller.php(280): CommunityProfileController->uploadAvatar() #3 /home/master/public_html/components/com_community
/community.php(178): CommunityBaseController->execute('uploadAvatar') #4 /home/master/public_html/libraries/joomla/application/component
/helper.php(162): require_once('/home/master/pu...') #5 /home/master/public_html/includes/application.php(124):
JComponentHelper->renderComponent('com_community') in /home/master/public_html/components/com_community/helpers/image.php on line 227

Нашол в настройках поле для библиотеки:
Путь к Image Magick (опционально)
что тут указать? я так понимаю ошибка из-за этой фишки
« Последнее редактирование: 26.07.2010, 23:53:43 от Ecspert »
*

Ecspert

  • Захожу иногда
  • 418
  • 12 / 0
Re: Ошибка при загрузке аватара
« Ответ #14 : 28.07.2010, 19:49:27 »
не... на localhost нормально загружается...
методом проб и ошибок было выяснено, что ошибка хостера, так как на другом хостинге и на localhost всё успешно работает
*

Ecspert

  • Захожу иногда
  • 418
  • 12 / 0
Re: Ошибка при загрузке аватара
« Ответ #15 : 30.07.2010, 17:42:27 »
хм, у меня такая же ошибка была  :o
чё я тока не делал, даже хостеру писал, вроде щас работает...

а как собственно войту в группу?   :D всё излазил, немогу понять...
*

Nar

  • Осваиваюсь на форуме
  • 21
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #16 : 31.07.2010, 23:27:39 »
Нашол JomSocial Version: 1.8.5 русскую, всё работает но при попытке загрузки аватара в формате GIF: (в jpg - норм)
А где "нашол"-то?
Ссылкой поделитесь, пжлста, если не жалко ;)
*

lamanzh

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #17 : 06.10.2010, 15:01:23 »
какая-то фигня случилась, теперь во всплывающем окне у аватарки участника код картинки выводится

*

kharol

  • Moderator
  • 1723
  • 217 / 0
Re: Ошибка при загрузке аватара
« Ответ #18 : 06.10.2010, 15:13:18 »
1) Общий шаблон Joomla смените
2) Сокрее всего есть конфликт с mootools, либо другой компонент использующий JQuery перекрывает своим скриптом *.js Jomsocial
3) Если правили tooltips, верните все обратно
4) НЕ ВКЛЮЧАЙТЕ наугад, для интереса все плагины в Joomla
Чтобы сказать "спасибо" достаточно нажать на "+"
Чтобы сделать бухгалтерскую проводку "спасибо" реквизиты: R192102130372, ЯД:41001768818003
*

lamanzh

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #19 : 06.10.2010, 16:07:40 »
kharol, спасибо за отклик

для интересу плагины не включаю , шаблон поменять не могу, заказчику нужен именно он, да и работало все на нем нормально

tooltips не правила

а вот конфликт с JQuery можеть быть, сейчас буду искать, спасибо



*

lamanzh

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #20 : 06.10.2010, 17:51:04 »
Фигня какая-то, в других вкладках (мой профиль и далее) все нормально со всплывающими подсказками. Только во вкладке "Все сообщество" глючат, причем когда меняешь позицию на Активные или Популярные становится все ок.

Плагины все поочередно выключала, модули тоже, не знаю, что еще можно сделать?
*

kharol

  • Moderator
  • 1723
  • 217 / 0
Re: Ошибка при загрузке аватара
« Ответ #21 : 06.10.2010, 21:02:48 »
Вот эту тему читали? Может что то пригодится
Чтобы сказать "спасибо" достаточно нажать на "+"
Чтобы сделать бухгалтерскую проводку "спасибо" реквизиты: R192102130372, ЯД:41001768818003
*

lamanzh

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #22 : 07.10.2010, 11:47:40 »
kharol, спасибо за указанное направление,
перепробовала все решения в той теме, но дело оказалось в шаблоне
помог этот совет, теперь все работает  ::)

Здравствуйте. Тоже столкнулся с такой ситуацией. Версия JomSocial 1.6.288, версия Joomla! 1.5.15 (локализация русская) в сборке использовал шаблон от GavickPro elvesocial, там была кастомная переделка шаблонов JomSocial, в частности переопределялся файл frontpage.index.php так вот не работала ни одна подсказка с классом hasTip. Когда менял шаблон Joomla! или же прятал оверрайды для индекса фронта JomSocial, то начинало работыть. Сверив файлы  frontpage.index.php основной темы и оверрайда в шаблоне увидел, что в основной теме место класса hasTip используется класс jomTips. Поменял классы в оверрайде и все заработало.
*

vaxmister

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Re: Ошибка при '
« Ответ #23 : 14.04.2011, 11:51:48 »
'
« Последнее редактирование: 27.04.2011, 13:15:23 от vaxmister »
*

b2z

  • Глобальный модератор
  • 7084
  • 768 / 0
  • Разраблю понемногу
*

vaxmister

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Re: Ошибка при загрузке аватара
« Ответ #25 : 14.04.2011, 15:13:32 »
Как возможно настроить? плз сайт находится на хосте
тест ссылка:
« Последнее редактирование: 22.04.2011, 19:00:33 от vaxmister »
*

Alexhelp

  • Осваиваюсь на форуме
  • 34
  • 0 / 0
  • Я за справидливость ...
Re: Ошибка при загрузке аватара
« Ответ #27 : 12.11.2011, 11:29:02 »
Потому что нет папки /images/avatar/groups
Спасибо!
Создал папку = groups
с правами 755 и всё пошло
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться