0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 2112 Просмотров

Проблема с кодировкой
« : 13.08.2009, 09:18:01 »
Имеется Joomla 1.5.0 полностью на UTF-8 и база тоже.
JoomGallery 1.5.0.3:
руссивикатор для галлереи установил, работает нормально
файлы компонента JoomGallery перевел в UTF-8.

Проблема в том, что, занося новые, на пример, категории, русские символы выводятся в виде знаков "?".
Помогите разобраться =)
*

vagkrsk

  • Давно я тут
  • 731
  • 125 / 0
  • Дорогу осилит идущий
Re: Проблема с кодировкой
« Ответ #1 : 13.08.2009, 09:42:32 »
Посмотрите .xml файл компонета - в какой он кодировке.
Зайдите в PHPAdmin и проверьте кодировку таблиц компонента.
Проверьте кодировку внутри таблиц компонента.

Если Вы не успели заполнить компонент, то поправьте кодировку в .xml файле (если она не utf8) и установите компонент заново.
Как делается? Открываете архив правите файл .xml , сохраняете изменения, и архивируете в zip файл ( при помощи файл-менеджера - в моем случае Total Commander). После этого стандартно устанавливаете на сайт.
Предварительно сохраните файлы с переводом, позже пригодятся. 

Re: Проблема с кодировкой
« Ответ #2 : 13.08.2009, 10:09:16 »
Это было мною проделано ранее, но спасибо.
Я обнаружил, что файлы, ранее преобразованные в UTF-8 без BOM (Notepad++), после архивации zip или rar становятся снова ANSI.
Преобразовывать php скрипты в чистый UTF-8 не стоит, т.к. они не будут работать из-за особенностей кодировки.
Следовательно, компонент требуется установить из каталога.

Для базы установлена кодировка utf-8.
Саму базу я посмотреть не могу, но подозреваю что проблема в ней, т.к. остальные компоненты нормально работаю с кодировкой ANSI.

Как будут результаты, отпишусь.
« Последнее редактирование: 13.08.2009, 10:12:26 от VStrick »

Re: Проблема с кодировкой
« Ответ #3 : 13.08.2009, 11:07:25 »
Проблема решена:
в install.sql, расположенном в корне установочного архива компонента; где опинаны таблицы компонента, не указаны кодировки таблиц. Как выяснилось, MySql по дефолту использует latin1_swedish_ci.
Подправив данный недочет, а именно: дописав charset и collate с необходимыми значениями; русский текст стал нормально отображаться.
*

stratosfera

  • Новичок
  • 9
  • 0 / 0
Re: Проблема с кодировкой
« Ответ #4 : 17.08.2009, 14:08:15 »
Проблема решена:
в install.sql, расположенном в корне установочного архива компонента; где опинаны таблицы компонента, не указаны кодировки таблиц. Как выяснилось, MySql по дефолту использует latin1_swedish_ci.
Подправив данный недочет, а именно: дописав charset и collate с необходимыми значениями; русский текст стал нормально отображаться.

не могли бы вы подробнее описать, что и в каких местах дописали?  или лучше всего этот файлик (поправленый) бы выложили...
у меня с этой кодировкой такая же проблема
*

skor1982

  • Осваиваюсь на форуме
  • 23
  • 0 / 0
Re: Проблема с кодировкой
« Ответ #5 : 02.09.2009, 15:27:59 »
я решил вопрос следующим образом, через phpMyAdmin зашел в свою БД и нашел таблицы jos_joomgallery там увидел кодировку latin и изменил на utf8_bin/ Все заработало
*

crazyASD

  • Давно я тут
  • 582
  • 26 / 2
Re: Проблема с кодировкой
« Ответ #6 : 03.09.2009, 12:11:42 »
Цитировать
Я обнаружил, что файлы, ранее преобразованные в UTF-8 без BOM (Notepad++), после архивации zip или rar становятся снова ANSI.
Преобразовывать php скрипты в чистый UTF-8 не стоит, т.к. они не будут работать из-за особенностей кодировки.
Взорвало мозг!
Сон разума порождает монстров
--
Фрилансом не занимаюсь. Никому ничего не должен. Отвечаю по мере знания и умения. -- JFusion - Наше всё! Joomla 1.5.23 SMF 1.1.15 JFusion 1.5.6 JComments 2.2.0 JoomGallery 1.5.6.4 JDownloads 1.8
*

wmag

  • Захожу иногда
  • 190
  • 9 / 5
  • Тут знаю, тут не знаю, пользуюсь напильником
Re: Проблема с кодировкой
« Ответ #7 : 26.06.2011, 00:04:05 »
я решил вопрос следующим образом, через phpMyAdmin зашел в свою БД и нашел таблицы jos_joomgallery там увидел кодировку latin и изменил на utf8_bin/ Все заработало

круто!
« Последнее редактирование: 26.06.2011, 00:07:56 от wmag »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема дублирования контента в JoomGallery

Автор shop-user

Ответов: 0
Просмотров: 652
Последний ответ 08.08.2019, 01:08:46
от shop-user
Проблема с дублем страниц в JoomGallery 3.4

Автор qvagin

Ответов: 2
Просмотров: 854
Последний ответ 13.06.2018, 16:47:43
от qvagin
Проблема с дублем страниц в JoomGallery 3.4

Автор qvagin

Ответов: 0
Просмотров: 693
Последний ответ 13.06.2018, 14:14:16
от qvagin
Проблема с детальным видом

Автор mgai000

Ответов: 0
Просмотров: 710
Последний ответ 04.05.2015, 09:34:17
от mgai000
Сохранение фото из галереи - проблема

Автор sibok

Ответов: 1
Просмотров: 941
Последний ответ 17.04.2015, 13:12:00
от sibok