0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 3725 Просмотров

Добрый день !

Только что перешел с Joomla 1.0 на 1.5. Сейчас стоит последняя версия 1.5.14.

Все работает, но как-то странно происходит процесс регистрации нового пользователя.

После ввода имени пользователя и пароля при регистрации система без дополнительных слов молча вылетает на главную.

Письмо приходит, после нажатия на линк  - попадаю на страницу подтверждения регистрации.

Но вход в сайт происходит так же без комментариев - просто вываливаешься на главную.

Это так и нужно, или я чего недокрутил ?

Хотелось бы, что бы при авторизации сказала, что на ваш e-mail выслано письмо с кодом активации, как минимум....

Галки ставлю по поводу всплывающих JS подтверждений - ничто нигде не всплывает....

« Последнее редактирование: 17.08.2009, 00:11:41 от l669 »
*

Darkick

  • Завсегдатай
  • 1142
  • 239 / 1
может в шаблоне не предусмотрен вывод сообщений

Точно - ставлю другой шаблон - все работает ! А что там должно быть предусмотрено в нем ?
*

Darkick

  • Завсегдатай
  • 1142
  • 239 / 1
Сравни шаблоны.
У меня примерно так в шаблоне:
Код
<?php if ($this->getBuffer ('message')) : ?>
<div id="message">
<jdoc:include type="message" />
</div>
<?php endif; ?>

Спасибо ! Все заработало !
*

dimok2002

  • Осваиваюсь на форуме
  • 40
  • 3 / 0
Darkick, спасибо за подсказку!
Но со своим шаблоном, чувствую, здОрово я влетел.
Прописал в индексе шаблона вышеуказанный код, подобрал методом тыка, куда надо прописать...
При регистрации пользователя стало выводиться сообщение, но не на отдельной страничке, а сверху контента Главной.
Причем ошибки, например при попытке повторной активации по ссылке, выводятся корректно, на отдельной страничке, даже без добавления этого кода. С добавленным кодом выводится двойное сообщение:
"Ошибка
        * Система не может найти пользователя с указанной строкой активации. Возможно, учетная запись уже активирована или истёк период кода активации. В последнем случае вам необходимо заново зарегистрироваться на сайте. /ЭТО после добавления кода, вместе с тем что ниже./

Неправильная ссылка активации!
Учетная запись не найдена или она уже была активирована ранее. /ЭТО - без добавления/

Нашел в индексе шаблона следующую строку:
Код
<div id="component"><jdoc:include type="component" /></div>
Если ее убрать то пропадает надпись: "Неправильная ссылка активации!
Учетная запись не найдена или она уже была активирована ранее."
Понимаю, что где-то что-то скорее всего не дописано по поводу успешной регистрации, но где и что - мозгов не хватает сообразить! >:(
Помогите пожалуйста! !
«Я не волшебник, я только учусь" (с)
*

whitefox

  • Новичок
  • 21
  • 0 / 0
Надпись <jdoc:include type="component" /> это поток контента сайта. Без него контент сайта не выводится и на сайте остаются только включённые модули. Убирать нельзя. Вместе с надписью "Неправильная ссылка активации!
Учетная запись не найдена или она уже была активирована ранее." пропадёт весь контент сайта.
PHP придуман врагами для того, чтоб окончательно меня запутать!!!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как заставить Joomla 1.5 работать на сервере с MySQL версии 5.7 и выше?

Автор Palomnik

Ответов: 5
Просмотров: 1857
Последний ответ 25.01.2019, 13:26:34
от Support
Восстановление Joomla на локальном компьютере из резерной копии

Автор raf88

Ответов: 6
Просмотров: 4711
Последний ответ 28.12.2018, 01:48:46
от natalileto
Редактирование готового сайта на Joomla

Автор Oksana

Ответов: 8
Просмотров: 2080
Последний ответ 29.11.2018, 21:11:48
от robert
Как определить версию Joomla, лишившись доступа к админке?

Автор andk

Ответов: 9
Просмотров: 21781
Последний ответ 02.08.2018, 17:33:57
от Apoca1ypto
Ошибка при внесении в настройки изменений компонента jUpgrade(обновление joomla)

Автор Ilya69

Ответов: 0
Просмотров: 1961
Последний ответ 08.05.2018, 20:23:13
от Ilya69