0 Пользователей и 1 Гость просматривают эту тему.
  • 13 Ответов
  • 2192 Просмотров
*

Надежда Вдовкина

  • Захожу иногда
  • 68
  • 1 / 0
Перенесла сайт с локального хоста на сервер, вроде, все заработало! Рано обрадовалась - возникли такие проблемы: те меню, которые были созданы на локальном, нормально работают, а вот при добавлении нового пункта в это меню он не отображается (хотя в админке видно, что в меню этот пункт есть). Также не показывается вновь созданное меню. В чем проблема? Как решить?
*

Kaylang

  • Захожу иногда
  • 74
  • 5 / 0
Может опубликовать соответствующие меню?
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
и версия PHP, наверное, конечно 5.3?
*

Надежда Вдовкина

  • Захожу иногда
  • 68
  • 1 / 0
Модули меню включены, меню опубликованы, версия PHP - в CPANEL указанао PHP-5.2.8, а если смотрю в JOOMLe (в админке, информация о системе), то указано PHP-5.2.4
*

Marksheider

  • Новичок
  • 12
  • 0 / 0
может доступ к файлам не открыт на сервере и он не может поэтому из изменить (создать меню)?!
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
почистить кэш и убрать кэширование для меню не пробовали?
Чего-то не внимательно прочитал топик, не увидел что в админке отображается  ^-^
*

Надежда Вдовкина

  • Захожу иногда
  • 68
  • 1 / 0

Цитировать
может доступ к файлам не открыт на сервере и он не может поэтому из изменить (создать меню)?!
Да, именно так, с этим я уже разобралась. Единственное, не совсем понятно, к каким именно папкам открывать доступ. Я пока к папке administrator и ко всем вложенным в нее папкам установила права доступа 777.
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Да, именно так, с этим я уже разобралась. Единственное, не совсем понятно, к каким именно папкам открывать доступ. Я пока к папке administrator и ко всем вложенным в нее папкам установила права доступа 777.
Я бы сказал да именно не так. Вас сейчас направят не на тот путь.
Скажу от себя что файлы и права на них к этому вопросу вообще не имеют никакого отношения.
*

XxxlibertyxxX

  • Осваиваюсь на форуме
  • 32
  • 6 / 0
Перенесла сайт с локального хоста на сервер, вроде, все заработало! Рано обрадовалась - возникли такие проблемы: те меню, которые были созданы на локальном, нормально работают, а вот при добавлении нового пункта в это меню он не отображается (хотя в админке видно, что в меню этот пункт есть). Также не показывается вновь созданное меню. В чем проблема? Как решить?
Здравствуйте. Уточните пожалуйста пробовали ли вы проверять в разных браузерах у меня была похожая проблема с мозилой в эксплорере было все норм решилась переустановкой мозилы. Также как вариант попробовать почистить кеш браузеров. Дело в том что в админке они появлялись как не странно, а на клиентском виде подгружался тока из кэша.
Пользуюсь joomla 1 месяц
Прежде чем задать вопрос юзай поиск.
Если всетаки задеш будь добр дать полную инфу. Люди не телепаты.
Поставь плюсик если человек помог.
*

Надежда Вдовкина

  • Захожу иногда
  • 68
  • 1 / 0
Цитировать
Я бы сказал да именно не так. Вас сейчас направят не на тот путь.
Скажу от себя что файлы и права на них к этому вопросу вообще не имеют никакого отношения.
Но ведь я изменила только права доступа, и все заработало (новые пункты в меню стали добавляться)
*

Надежда Вдовкина

  • Захожу иногда
  • 68
  • 1 / 0
Цитировать
Здравствуйте. Уточните пожалуйста пробовали ли вы проверять в разных браузерах у меня была похожая проблема с мозилой в эксплорере было все норм решилась переустановкой мозилы. Также как вариант попробовать почистить кеш браузеров. Дело в том что в админке они появлялись как не странно, а на клиентском виде подгружался тока из кэша.
Вы знаете, я вообще плохо представляю, что такое - кэш, и как его чистить в браузерах. Если не затруднит, объясните, пож-ста.
*

XxxlibertyxxX

  • Осваиваюсь на форуме
  • 32
  • 6 / 0
для
1) В меню Help-About Internet Explorer (по-русски Справка-О программе) посмотреть версию программы: 6 или 7.

а) Если версия 6: идем в меню Tools-Internet Options, оно же Сервис-Свойства обозревателя. Там на открывшейся форме видим примерно посредине кнопку "Удалить файлы", оно же "Delete files". Нажимаем, ставим там галочку в системном сообщении и говорим "Окей".

б) Если версия 7: то же меню Tools-Internet Options, оно же Сервис-Свойства обозревателя. Там на форме раздел Browsing history, а в нём - кнопка "Delete..." ("Удалить..."). Нажимаем, попадаем в сервисное окно с перечнем. Нам нужен первый пункт: Temporary Internet files. Нажимаем на "Delete files", соглашаемся с системным сообщением, которое появится после нажатия.

2) в браузере Mozilla FireFox в меню нажать Инструменты => Настройки, вкладка "Дополнительно", далее "Сеть" и "Очистить кэш"

3) в браузере Opera нажать Ctrl + F12, перейти на вкладку "Дополнительно", далее "История" и напротив надписи "Дисковый кэш" нажать "Очистить сейчас".
Пользуюсь joomla 1 месяц
Прежде чем задать вопрос юзай поиск.
Если всетаки задеш будь добр дать полную инфу. Люди не телепаты.
Поставь плюсик если человек помог.
*

gaver

  • Новичок
  • 10
  • 0 / 0
У меня та же проблема, но ещё круче: после попытки опубликовать новый пункт меню, сайт вообще перестает грузится, . Отключаю публикацию пункта меню сайт грузится, включаю - сайт не грузится. Смотрю исходный код, его просто нет :(
Эксперименты показали следующее: если изменить тип пункта меню на Разделитель или Внешнюю ссылку, то и сайт грузится, и пункт меню тоже появляется. Когда же выбирал тип меню что-то из материалов (кроме стандартного шаблона материалов, пробовал ещё и стандартный шаблон раздела, и шаблон блога категории), то сайт вообще не грузится.

Установка прав доступа 777 вряд ли здесь сыграют роль, сайт же вообще перстает грузится, а не просто грузится старое меню.
Да и кеш здесь по всей видимости не причем, если при определенных условиях новые пункты меню все-таки появляются.

Так в чем проблема? Кто-то может подсказать? Все встало, не могу выложить новые материалы.
На локалке все попробовал повторить, все работает как часы. На сервере не грузится и все тут  :(

P.S. Вернулся, чтобы дописать: проверил выставленные права, они везде установлены 777, ещё при переносе сайта на сервер помню это делал. 
« Последнее редактирование: 22.12.2009, 22:25:29 от gaver »
*

gaver

  • Новичок
  • 10
  • 0 / 0
Немного поэкспериментировав с включением/отключением модуля ARTIO JoomSEF выяснил, что "шалит" именно этот модуль.

Настроил в модуле php вывод ошибок.
Вот она родимая:
Fatal error: Undefined class name 'self' in /home/mysite.ru/docs/components/com_sef/joomsef.php on line 1474

строка 1474 следующая:
$realloc = self::_checkRow($row, $ignoreSource, @$Itemid, $url, $metadata, $temploc, $priority);

Кому-то это о чем-то говорит, можете подсказать решение проблемы?
« Последнее редактирование: 27.12.2009, 20:13:24 от gaver »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Большое меню Joomla

Автор Amakeeva

Ответов: 1
Просмотров: 243
Последний ответ 22.01.2018, 13:17:45
от effrit
Как можно отображать имя пользователя в название меню?

Автор selimoff

Ответов: 27
Просмотров: 3232
Последний ответ 02.01.2018, 15:24:44
от logan-19
как сделать пункт меню не кликабельным?

Автор qweqweqwe

Ответов: 13
Просмотров: 6028
Последний ответ 07.09.2017, 01:45:49
от forzi
Сдвинуть пункты меню в левое положение

Автор wectra

Ответов: 6
Просмотров: 563
Последний ответ 12.07.2017, 21:09:01
от wectra
Не отображаются пункты в меню

Автор physic

Ответов: 16
Просмотров: 16038
Последний ответ 27.05.2017, 00:10:15
от OutLaw1