0 Пользователей и 1 Гость просматривают эту тему.
  • 16 Ответов
  • 17684 Просмотров
*

odomsa

  • Новичок
  • 5
  • 0 / 0
Доброе время суток!
Если офтоп простите...
Возникла проблема, перенес сайт с денвера на хостинг, все отлично но ни одна картинка не отображается... Все ссылки на изображения Файл cnfiga уже замучал править, не помогает  :( Подскажите, кто может знает? Уж дюже не охота все картинки руками править...
« Последнее редактирование: 02.06.2010, 20:14:54 от 4webspot »
*

odomsa

  • Новичок
  • 5
  • 0 / 0
Ну и ладно, сам поправил...
*

petyp

  • Захожу иногда
  • 214
  • 0 / 0
Слушай если у тебя проблема с картинками в VirtueMart то скажи что сделал, сам мучаюсь второй день....
*

beliyadm

  • Легенда
  • 8936
  • 1625 / 63
  • Севастополь == Россия
administrator\components\com_virtuemart\virtuemart.cfg.php смотрим до полного просветления и после вставляем очередную палку разработчику
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb

administrator\components\com_virtuemart\virtuemart.cfg.php смотрим до полного просветления и после вставляем очередную палку разработчику

А чего на него смотреть, файл как файл. В насройках vertuemart надо указать URL вашего сайта в интернет (обязательно в конце пути слеш). Можно это сделать после переноса. А у меня с картинками полная фигня была, скролер не показывал фото и.т.д., оказалось названия некоторых фоток на виртуальном хостинге по русски были....  :o Я даже через FTP удалить их не мог. Помучился........, а корректный перенос только Joomlapack 2.1 дает (я так думаю). Вот здесь демо-видео даже есть: http://cmsfreehost.narod.ru
*

parsanches

  • Осваиваюсь на форуме
  • 44
  • 1 / 0
Если кроме фоток криво загружается (или не загружается) и компонент магазина в админке то поможет правка путей в файле VirtueMart.cfg.php (У тебя же фотографии пропали после переноса на хостинг)
Он находится тут: W:\home\localhost\www\сайт.ру\administrator\components\com_virtuemart
Править нужно вот эти пути на те которые соответвуют хостингу:
define( 'URL', 'http://localhost/твой_сайт.ru/' );
define( 'SECUREURL', 'http://localhost/твой_сайт.ru/' );
*

ART-DELI

  • Давно я тут
  • 801
  • 75 / 9
  • Не успеешь ты – сделают другие.
А что так сложно посмотреть исходник кода страницы, и проверить "глазами" валидность url для картинок??  ;D
*

John

  • Новичок
  • 17
  • 0 / 0
Тоже была такая лажа .При переносе с временного домена на котором собирали магазин ,пропали все картинки товаров +дополнительные.После просмотра кода страницы выяснилось что пути остались старые.хотя в настройках virtuemart- url поменяли. Скачал базу данных через phpmyadmin открыл ее через rapidphp нашел с заменой на новый путь сайта свои 450 картинок (вручную не менял :o ). Проблема решилась ^-^
 

Я не волшебник только учусь, поменял в  файле   W:\home\localhost\www\сайт.ру\administrator\components\com_virtuemart\VirtueMart.cfg.php     на вот такое ;   
 define( 'URL', $mosConfig_live_site.$app );                                                                                   
 define( 'SECUREURL', $mosConfig_live_site.$app); 
и изображения появились.   
*

monah46

  • Захожу иногда
  • 86
  • 0 / 1
Некоторые WYSIWYG редакторы ставят абсолютный путь к изображениям...
можно посмотреть, какой прописывает абсол/путь и не использовать его перед переносом...
<p align="center"><span style="color: rgb(128, 0, 0);"><span style="font-size: 14px;"><strong>Никогда не бойся делать то, что ты не умеешь! Помни, ковчег был построен любителем, а профессионалы построили &quot;Титаник&quot;</strong></span></span></p>
*

sauli

  • Новичок
  • 2
  • 0 / 0
Здравствуйте!!=) Делаю интернет-магазин первый раз на Joomle1.5.12+virtuemart 1.1.3.Пока делаю на локальном денвере. Без причины пропали изображения товаров.Пробывала загружать заново, ничего не меняется.Вношу новый товар,заливаю картинку.Товар появляется с характеристиками, а картинки так и нет.Хотя в папке c:\WebServers\home\joomla.loc\www\components\com_virtuemart\shop_image\product\ она появляется.В чем может быть причина и что делать?Помогите, я только учусь=) p.s.Еще у меня также перестала работать кнопка "купить" (тоже беспричинно).Поискала на форуме, нашла ответ: в файле VirtueMart.cfg.php нужно было вместо : define( 'URL', 'http://joomla.loc/' );
                                                                  define( 'SECUREURL', 'http://joomla.loc/' ) написать
                                                                                                                                       define( 'URL', 'http://www.joomla.loc/' );
                                                                                                                                       define( 'SECUREURL', 'http://www.joomla.loc/' )
После этого у меня и пропали изображения.Может быть это как-то связано?Пробывала исправить на первый вариант, не помогло. Кто знает напишите что делать.И часто ли без видимых причин что-то творится с сайтом, не смотря на то что он на локалке?? Заранее благодарна.Жду ответа
*

Vasil

  • Новичок
  • 3
  • 0 / 0
Была проблема при перенесении сайта на хостинг. Причина проблемы - при разворачивании из zip архива скрипт хостинга отрабатывал криво из-за чего права на файлы компонентов проставлялись неверно, плюс не все файлы похоже извлекались из архива.

Решение - перезагрузить аккаунт и создать по новой(при этом удаляются все файлы и база данных), закачать через phpmyadmin базу на хостинг по новой и залить сайт через ftp клиент ручками.. долго но надежно..
В настройках virtuemart`а  (настройки->безопасность) прописать "http://свой сайт/"
нажать сохранить и радоваться:)
*

llektor

  • Захожу иногда
  • 214
  • 2 / 2
не понятно как лучше для поисковиком когда когда есть слеш а конце адреса или когда нет его то есть слеша?
уважаемы подскажите пожалуйста, вот в конфиг файле прописываю так
var $live_site = 'http://www.domain.com';
сайт перестает работать белай страница даже ошибку не выводит, почему, как стати и на компьютере и на хостинге одинаково?
Советую мою безграматнасть не обсуждать,потому как безпалезна,выслушаю дельный совет возможно и камерчиский
*

Vasil

  • Новичок
  • 3
  • 0 / 0
Если ничего не помогает, а путь  формируется правильный то отключить НАФИГ в настройках Virtuemart  - Включить динамическое изменение размеров для мини-изображения.
Проверенно, что на многих хостингах не работает эта функция.
:)
*

Kirill324

  • Новичок
  • 16
  • 0 / 0
Спасибо большущее всем форумчанам за реплики и ответы!! Все заработало!

Решение: нужно зайти в Joomla на хостинге, выбрать компонент VirtueMart - настройки - безопасность (если же такая вкладка не видна - скролить страницу вниз, там будет такой блок) - и в оба поля вместо http://localhost/vash_site/ ввести http://vash_site/. И все будет работать.

Всем всего хорошего!  ^-^
*

perlina-don

  • Новичок
  • 1
  • 0 / 0
Спасибо Вам, ja50, и всем остальным участникам данного обсуждения! Заработало!
*

Edikxp

  • Осваиваюсь на форуме
  • 32
  • 0 / 0
Спасибо
« Последнее редактирование: 11.01.2013, 13:29:52 от Edikxp »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

[Решено] Как обновить Joomla 1.5 (версии, способы обновления и т.д.)

Автор Danka

Ответов: 45
Просмотров: 184702
Последний ответ 06.04.2017, 12:14:12
от SeBun
[Решено] Ошибка: Cannot send session cookie - headers already sent by...

Автор Sokali

Ответов: 84
Просмотров: 202203
Последний ответ 28.11.2016, 16:58:14
от Bug_ai
[Решено] Перезалил на новый хостинг, Не могу в админке изменить ни одной настройки сайта

Автор Filipp-Alex

Ответов: 25
Просмотров: 14352
Последний ответ 02.06.2016, 15:08:06
от Ecspert
Ошибка при переносе на другой хостинг

Автор truman55

Ответов: 1
Просмотров: 881
Последний ответ 21.03.2016, 12:12:08
от SeBun
[Решено] Unable to connect to the database:Could not connect to MySQL

Автор dircell

Ответов: 82
Просмотров: 136424
Последний ответ 22.01.2016, 19:22:10
от Template_user