0 Пользователей и 1 Гость просматривают эту тему.
  • 972 Ответов
  • 195276 Просмотров
*

WolfHunter

  • Захожу иногда
  • 50
  • 1 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #120 : 05.03.2010, 02:54:03 »
Если отвечать на вопрос (помеченый уведомлять по емэйл) через фронтэнд выскакивает HTTP 500 - Внутренняя ошибка сервера
PHP Fatal error:  Call to undefined method SmfaqsController::_senduser() in /public_html/components/com_smfaq/controllers/admin.php on line 65
Но ответ публикуется
Если отвечать без пометки, всё ок. Через админку в любом случае норм
« Последнее редактирование: 05.03.2010, 03:15:29 от WolfHunter »
*

sweller

  • Новичок
  • 17
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #121 : 06.03.2010, 09:37:29 »
И ещё чуть для счастья не хватает: у меня за ответы отвечает определённый сотрудник, хорошо бы сделать настройку адреса на который будет уходить уведомление о поступившем вопросе, а то всё админу сайта валиться.
*

wd

  • Давно я тут
  • 528
  • 17 / 1
  • Просто юзер
Re: SM FAQ - простой компонент FAQ'a
« Ответ #122 : 06.03.2010, 14:08:56 »
Здравствуйте!
Простой и удобный компонент, спасибо.
Но есть вопрос:
Как сделать авто публикацию вопроса?
*

kosmosmax

  • Новичок
  • 20
  • 2 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #123 : 07.03.2010, 21:49:19 »
Доброго времени суток!
В своем случае реализовал оповещение о заданном вопросе посредством смс.
Воспользовался гейтом @->sms, в моем случае devinosms.com но не факт, возможны любые варианты, важно, чтобы при публикации вопроса на почту (определенную) приходило письмо (определенное).
В моем случае письмо должно приходить на адрес email2sms@devinosns.com и содержать текст
UserLogin=*******
Password=*******
SourceAddress= здесь текст адрес отправителя СМС
PhoneNumber=тут понятно
ниже идет текст SMS, например:
"Есть вопрос на сайте"
Что сделал: открыл /components/com_smfaq/controller.php
добавил в конце:
 function _sendMailsms()
  {$subject = ' ';
$message = 'UserLogin=*****
Password=****
SourceAddress=Мой сайт
PhoneNumber=***********
Есть вопрос на сайте';
$from_name = 'site *******';
$from_mail = '*****@mail.ru';
$to = 'email2sms@devinosms.com';
$priority = '1';
 
$body = "$message\n";
$from = "$from_name <$from_mail>";
$headers = "Contenet-Type: text/html ; charset= windows-1251\n";
$headers .= "From: $from_mail\n";
$headers .= "X-Mailer: The Bat! 2005\n";

$headers .= "X-Priority: $priority\n";

mail ($to, $subject, $body, $headers);
}

В секции function send() после
if ($model->store($post)) {
           $res['valid'] = true;
           SmfaqsController::_sendMail();

добавил
           SmfaqsController::_sendMailsms();

Собсно при публикации вопроса одновременно с отправкой письма администраторам отправляется письмо на гейт.
НЕ знаю насколько это будет востребованно, но как вариант добавить возможность при публиковании вопроса оправлять письмо (определенное) на адрес (а) (определенные).
Автору ОГРОМНЫЙ РЕСПЕКТ,  SM FAQ РУЛИТ !
*

WolfHunter

  • Захожу иногда
  • 50
  • 1 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #124 : 11.03.2010, 13:09:48 »
попробовал компонент на денвере.
captcha отображается  ^-^
при ответе с сайта таже ошибка Fatal error: Call to undefined method SmfaqsController::_sendUser()  :(
емэйл автору вопроса не отправляется  >:(

Самое интересное, что у автора компонента, как я понимаю всё работает! В чём проблема, в php.ini?
*

ankoch

  • Захожу иногда
  • 498
  • 50 / 1
Re: SM FAQ - простой компонент FAQ'a
« Ответ #125 : 13.03.2010, 18:49:55 »
Вопрос может быть не совсем из этой категории, решать Вам, заранее прошу прощения. Установил модуль sm FAQ, он (по-моему) пользуется стандартными контактами при добавлении нового вопроса (или я не прав?), раньше всё было нормально, присылал письма на нужный e-mail, а теперь возникла необходимость поменять e-mail, поменял в админ-панели (Общие настройки - сервер - установка почты - адрес отправителя), поменялся он и в configuration.php, а письма из формы приходят всё равно на старый адрес, как изменить адрес? Или я не там ищу?
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Re: SM FAQ - простой компонент FAQ'a
« Ответ #126 : 14.03.2010, 01:29:45 »
(или я не прав?)
Да. Не правы.
Моё сугубо атмосферное мнение :)
*

ankoch

  • Захожу иногда
  • 498
  • 50 / 1
Re: SM FAQ - простой компонент FAQ'a
« Ответ #127 : 14.03.2010, 09:56:41 »
Цитировать
Да. Не правы.
Моё сугубо атмосферное мнение
А что нибудь поконкретнее от разработчика модуля можно услышать?
*

ganzalez

  • Новичок
  • 11
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #128 : 14.03.2010, 10:59:34 »
Спасибо за компонент. Хорошая работа. После заполнения "формы вопроса" и нажитии кнопки "отправить" не выскакивает сообщение с благодарностью за вопрос и не осуществляется перехода. Это возможно исправить? Ссылка на сайт:  ссылка на сайт
« Последнее редактирование: 14.03.2010, 12:33:14 от ganzalez »
*

curt-ain

  • Новичок
  • 15
  • 2 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #129 : 14.03.2010, 15:02:59 »
Просмотрел кучу компонентов, выбрал для себя SM FAQ.
Просто и то, что нужно. Правда для своих целей добавил  имя отправителя и время отправки вопроса при просмотре FAQa, теперь думаю как добавить разных пользователей-ответчиков.
Спасибо! Желаю всяческих развитий!
*

sweller

  • Новичок
  • 17
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #130 : 15.03.2010, 10:45:17 »
В php я профан  :-X , подскажите пожалуйста что-где поменять для отправки уведомления о вопросе на определённый e-mail?
*

kosmosmax

  • Новичок
  • 20
  • 2 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #131 : 15.03.2010, 21:02:48 »
ganzalez   -> ошибка 404
sweller     -> гляньте мой пост про SMS, впишите туда то, что нужно, правда @ будет стандартный по шаблону.
curt-ain    -> "добавил  имя отправителя и время отправки вопроса при просмотре FAQa," напишите поподробнее, мне интересно, то же думаю добавить.
*

Architek

  • Новичок
  • 3
  • 1 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #132 : 16.03.2010, 00:31:29 »
В общем и целом, создателю респект.
Заметил одну особенность: при смене CAPTCHA выбрасывает на главную.
И не плохо было бы добавить в настройки цвета и цвет фона при наведении на вопрос в списке.
*

pazitiv

  • Новичок
  • 3
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #133 : 16.03.2010, 15:46:22 »
Здравствуйте у меня вопрос. Как можно отключить по умолчанию скрытие ответа? Что бы не приходилось нажимать на вопрос, а сразу бы отображался ответ?
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Re: SM FAQ - простой компонент FAQ'a
« Ответ #134 : 16.03.2010, 16:16:48 »
Здравствуйте у меня вопрос. Как можно отключить по умолчанию скрытие ответа? Что бы не приходилось нажимать на вопрос, а сразу бы отображался ответ?
Никак. такой настройки нет и не предвидеться.
Суть как раз была в том что бы он раскрывался.
*

pazitiv

  • Новичок
  • 3
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #135 : 16.03.2010, 16:34:07 »
Где можно подправить в скриптах? ( !  Очень нужно!)
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #136 : 16.03.2010, 16:56:06 »
Цитата: velzy
если вывожу внешней ссылок на fat.html пишет такое:
 SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org
SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org
Категория вопроса
Чего?  :dry:
Посмотрите у многих так выводится http://yandex.ru/yandsearch?text=SM+FAQ+-+%D0%9A%D0%BE%D0%BC%D0%BF%D0%BE%D0%BD%D0%B5%D0%BD%D1%82+%D0%B2%D0%BE%D0%BF%D1%80%D0%BE%D1%81-%D0%BE%D1%82%D0%B2%D0%B5%D1%82+%D0%B4%D0%BB%D1%8F+Joomla+http%3A%2F%2Fjoomla.forsite.org&lr=66&stpar2=%2Fh0%2Ftm0%2Fs2&stpar4=%2Fs2

У меня тоже так было, потом повторно создал пункт меню, стало нормально, при чём при любом из двух шаблонов категории теперь нормально, а раньше вот такая же проблема была.
Самое важное — это мир во всём мире!
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #137 : 16.03.2010, 18:34:54 »
Хотя нет если выводить шаблон категории всё равно выводит:

SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org

Я нашёл его в языковом файле, может можно найти и файл в котором вообще это вставляется, но тут вопрос, а почему нет настройки в которой это можно выключить? Или я её просто не нашёл?
Самое важное — это мир во всём мире!
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Re: SM FAQ - простой компонент FAQ'a
« Ответ #138 : 16.03.2010, 18:57:11 »
Я нашёл его в языковом файле, может можно найти и файл в котором вообще это вставляется, но тут вопрос, а почему нет настройки в которой это можно выключить? Или я её просто не нашёл?
Здесь нет никакой хитрости.
Просто когда создаете пункт меню с отображением категорий, задайте в нем нужный заголовок, по умолчания я сделал такой.
*

sweller

  • Новичок
  • 17
  • 0 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #139 : 16.03.2010, 20:55:59 »
sweller     -> гляньте мой пост про SMS, впишите туда то, что нужно, правда @ будет стандартный по шаблону.

Спасибо, понял.
Сделал проще:
Добавил в секции function _sendMail() строку $to = 'user@mymail.ru, user2@mymail.ru';
и в строке JUtility::SendMail($mailfrom, $fromname, $row->email, ..... ); заменил $row->email на $to
Не знаю правильно или нет, зато работает. :)
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #140 : 16.03.2010, 21:12:50 »
Здесь нет никакой хитрости.
Просто когда создаете пункт меню с отображением категорий, задайте в нем нужный заголовок, по умолчания я сделал такой.
Задал заголовок, и одна надпись та что сверху заменилась, но ниже пишется такая же "SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org"

Я там выше поисковый запрос привёл по которому можно найти много сайтов с такой проблемой, вот сайт (не мой) где аналогичная ситуация http://stela.ws/component/option,com_smfaq/Itemid,230/view,categories/

Там сначала заголовок, который можно сменить а ниже снова повторяется и даже если заголовок сменить, ниже заголовка всё равно пишется "SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org".
Самое важное — это мир во всём мире!
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #141 : 16.03.2010, 21:24:16 »
Чтобы вы не подумали что я придумываю, вот на своём сайте включил снова шаблон категории http://www.miroon.ru/index.php?option=com_smfaq&view=categories&Itemid=59

Там видно, что заголовок заменён, но внизу если выводить шаблон категории, а не шаблон категорИЙ, всё равно пишется "SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org

Кстати, при задании вопроса, при любом выводе, зависает форма, то есть как уже писалось где-то на второй вроде странице этой темы, сообщение попадает, но не чего не происходит для пользователи он видит как бесконечно крутится колёсико. Может конечно этот вопрос где-то уже решён как-то по другому, но пока я тему дочитал до варианта, что нужно выводить "шаблон категории, а не категорий" и это вроде спасение, но у меня при любом выводе не работает.
Самое важное — это мир во всём мире!
*

curt-ain

  • Новичок
  • 15
  • 2 / 0
Re: SM FAQ - простой компонент FAQ'a
« Ответ #142 : 16.03.2010, 23:05:08 »
косяк блин :)
« Последнее редактирование: 18.03.2010, 20:19:13 от curt-ain »
*

strannik-yura

  • Давно я тут
  • 513
  • 44 / 1
  • :)
Re: SM FAQ - простой компонент FAQ'a
« Ответ #143 : 17.03.2010, 01:01:43 »
Там видно, что заголовок заменён, но внизу если выводить шаблон категории, а не шаблон категорИЙ, всё равно пишется "SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org

а что если в языковом файле эту строку

Код
SM FAQ=SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org

закоментировать или изменить
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Re: SM FAQ - простой компонент FAQ'a
« Ответ #144 : 17.03.2010, 01:35:57 »
Чтобы вы не подумали что я придумываю, вот на своём сайте включил снова шаблон категории http://www.miroon.ru/index.php?option=com_smfaq&view=categories&Itemid=59

Там видно, что заголовок заменён, но внизу если выводить шаблон категории, а не шаблон категорИЙ, всё равно пишется "SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org
может быть косяк не спорю.
Поправлю потом.
Кстати, при задании вопроса, при любом выводе, зависает форма, то есть как уже писалось где-то на второй вроде странице этой темы, сообщение попадает, но не чего не происходит для пользователи он видит как бесконечно крутится колёсико. Может конечно этот вопрос где-то уже решён как-то по другому, но пока я тему дочитал до варианта, что нужно выводить "шаблон категории, а не категорий" и это вроде спасение, но у меня при любом выводе не работает.
Значит плохо читали.
для этого я сделал отдельно параметры. Вопросы-кнопка "параметры" там выставляйте как нужно и нажимайте сохранить. По умолчанию пользователь и не сможет добавить вопрос.
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #145 : 17.03.2010, 09:47:17 »
а что если в языковом файле эту строку

Код
SM FAQ=SM FAQ - Компонент вопрос-ответ для Joomla http://joomla.forsite.org

закоментировать или изменить
Ну я про это выше пишу, что действительно без проблем так можно сделать и даже более того мне больше нравится как выводится шаблон категорИЙ, при этом вообще такой проблемы не возникает. Тут просто информирую автора о проблеме.
Самое важное — это мир во всём мире!
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: SM FAQ - простой компонент FAQ'a
« Ответ #146 : 17.03.2010, 09:53:25 »
Значит плохо читали.
А вот это я читал и у меня везде "Добавить вопрос" и в параметрах в настройке компонента стоит Всем и в настройке пункта меню при выводе шаблон категорИИ стоит Всем, вот только когда включаю шаблон категорИЙ там такой настройки нет. Или вы что-то другое имели ввиду?
Самое важное — это мир во всём мире!

Re: SM FAQ - простой компонент FAQ'a
« Ответ #147 : 17.03.2010, 16:48:23 »
в админке при попытке дать ответ на вопрос открывается пустая страничка…
в логах на сервере пишет следующее :

PHP Parse error: syntax error, unexpected $end in /usr/local/www/домен.ru/htdocs/administrator/components/com_smfaq/views/smfaq/tmpl/form.php on line 221, referer: http://домен.ru/administrator/index.php?option=com_smfaq

Очень прошу помогите разобраться, завтра уже работу сдават клиенту и не работает лишь это...
самое интересное что вот тут - /administrator/components/com_smfaq/views/smfaq/tmpl  НЕТУ файла form.php !
что надо исправить ?
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
Re: SM FAQ - простой компонент FAQ'a
« Ответ #148 : 17.03.2010, 16:53:54 »
самое интересное что вот тут - /administrator/components/com_smfaq/views/smfaq/tmpl  НЕТУ файла form.php !
он должен быть

Re: SM FAQ - простой компонент FAQ'a
« Ответ #149 : 17.03.2010, 19:24:43 »
нашёл его, прошу прощения - смотрел не в админских компонентах ))
и всё же что можно сделать для решения данной проблемы и возможности создания ответов на вопросы и  их редактирования ?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

JXLSPriceParser - MS Excel + Joomla (v0.3.2)

Автор miraj

Ответов: 277
Просмотров: 110175
Последний ответ 09.04.2017, 11:59:46
от svarg
(CSVI) Компонент импорта csv файлов (Joomla 1.5 ~ Virtuemart 1.1 Native mode), beta

Автор Jkarter

Ответов: 114
Просмотров: 63689
Последний ответ 16.03.2016, 19:03:16
от Ferax
Георгиевская ленточка для Joomla 1.5

Автор ageent

Ответов: 10
Просмотров: 4722
Последний ответ 21.01.2016, 23:50:10
от SeBun
Joomposter программа для постинга в Joomla

Автор bigbrain

Ответов: 130
Просмотров: 48618
Последний ответ 21.01.2016, 19:13:20
от KKAAZZOO
Best Alias - плагин для улучшения seo в Joomla

Автор ageent

Ответов: 50
Просмотров: 20054
Последний ответ 21.01.2016, 18:57:49
от int-sam