Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 3 Ответов
  • 2157 Просмотров
*

freerr

  • Новичок
  • 7
  • 0 / 0
unmp3 ошибка.
« : 25.02.2011, 22:03:06 »
Доброго времени господа разработчики.
У меня такая проблема, установил unmp3(unmp3.com) на жумлу 1,5
сначала он ругался что в PHP.ини стоит маленький лимит на аплоад, я поменял, но проблема не решилсь, появилась новая ошибка при попытки добавить мп3 файлик

"Unknown error. components/com_unmp3/songs/ 3f6b395c90f6b6bb5f087dfeed705f030b3aef86.mp3
ERROR! Make sure you only upload an (.mp3) file and that the file size is within your server limits (your server settings indicate that upload_max_filesize = 32M)."

добавляю обычный мп3 трэк 4мегобайта.

Гугл мне не помог, нашел похожие темы, но все без ответа, быть может кто в курсе или понимает причину ? ато уж больно подходящий мп3 плеер для моего сайта.

На крайний случай посоветуйте какой-нибудь другой.

Спасибо.
*

freerr

  • Новичок
  • 7
  • 0 / 0
Re: unmp3 ошибка.
« Ответ #1 : 26.02.2011, 12:30:59 »
и никто не в курсе ?
*

05_Lezgi_05

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Re: unmp3 ошибка.
« Ответ #2 : 19.12.2011, 15:55:33 »
А что ты поменял в php.ini?
*

makc9I

  • Захожу иногда
  • 89
  • 0 / 0
Re: unmp3 ошибка.
« Ответ #3 : 06.09.2012, 11:51:49 »
такая же проблема появилась ни с того ни с сего. Поначалу все было нормально. Чистил кеш. Переименовывал файлы на латинский, залез в этот каталог, пытался сунуть файл напрямую, но там они кешированные, и каким образом не понятно. Также не решил проблему.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4914
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29333
Последний ответ 16.03.2020, 17:47:29
от Petrovich
При попытке войти в админку 404 ошибка компонента

Автор omezik

Ответов: 4
Просмотров: 8524
Последний ответ 31.08.2019, 22:41:46
от Taatshi
Ошибка в компоненте CKForms

Автор Vas80

Ответов: 9
Просмотров: 4067
Последний ответ 22.04.2019, 13:34:48
от sivers
Ошибка Fatal error: Allowed memory size of 73400320 bytes exhausted

Автор Andre109

Ответов: 1
Просмотров: 4322
Последний ответ 03.12.2018, 01:29:56
от voland