0 Пользователей и 1 Гость просматривают эту тему.
  • 49 Ответов
  • 23034 Просмотров
*

777007

  • Новичок
  • 7
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #30 : 23.03.2012, 12:28:34 »
Установил на Joomla скачанную в другом месте, и всё отлично работает!
*

Nazgard

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #31 : 14.05.2012, 18:59:22 »
Не подскажете у меня примерно аналогичная проблема заключается в том что:
Мне нужно чтобы галерея выводилась по запросу тега, сам K2 это выводить не умеет, я нашел фаил tag.php и вставил туда вот такой код 

<?php if(!empty($item->gallery)): ?>
  <!-- Item image gallery -->
  <div class="catItemImageGallery">
   
     <?php echo $item->gallery; ?>
  </div>
  <?php endif; ?>

  <div class="clr"></div>
после чего в статье появляется {gallery}188{/gallery} но зараза плагин его не цепляет тое сть картинок нет >:(
Может кто сталкивался с такой проблемкой подскажите пожалуйстаззз в какой степи хоть копать?
*

Noo

  • Осваиваюсь на форуме
  • 14
  • 2 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #32 : 04.06.2012, 01:58:27 »
У меня немного другая проблема, на локалке все работало, как перенес сайт на хостинг не добавляет архив с фото через вкладку Галерея изображений. Дает ошибку: Неизвестный архив, ошибка загрузки галереи, невозможно распаковать архив.
Все что выше описано перепробовал с путями, папка с id материала не создается, другие папки (созданы были локально до переноса сайта) имеются и работают.
Не могу понять с хостингом что то? Так архивы вообще то закидывал и распаковывал, права на папки 755 стоят. Куда лезть где искать, чего ему надо? Каждый раз внутрь статьи фото между строк закидывать неудобно, помогите с этой галереей

Плагин sigpro v2.5.6 включен, путь прописан как выше советовали, Joomla 2.5.4, на вкладке инфо в к2 все установлено и доступно для записи
*

eclipseggg

  • Захожу иногда
  • 411
  • 32 / 2
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #33 : 04.06.2012, 04:04:55 »
а разархивация поддерживается хостингом вообще?включена?
*

Noo

  • Осваиваюсь на форуме
  • 14
  • 2 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #34 : 04.06.2012, 17:46:44 »
Ну да, я же туда архив сайта кидал и разархивировал прямо на хостинге
*

LED

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #35 : 21.07.2012, 19:32:36 »
а я банально плагин не включил :/
*

Makc

  • Захожу иногда
  • 55
  • 11 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #36 : 05.09.2012, 15:22:06 »
Долго тупил, пытался понять почему вдруг перестали загружаться архивы, понял.
Плагин не пашет на PHP 5.4, переключился на PHP 5.3 - всё заработало.
Всё, что пишу, проверено или работатет на J 1.7 + К 2.5.4
*

ans73

  • Осваиваюсь на форуме
  • 18
  • 1 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #37 : 16.09.2012, 19:35:38 »
Я победил так.
Что бы работала галлерея
Нужно через медиа менеджер Joomla создать папку в дериктории /images/stories/
Пример: /images/stories/gips
Файлы с картинками нужно заархивировать в ZIP формате.
В материале нужно вставить тег {gallery}gips{/gallery}
Через имедж галерею в материале добавить заархивированный файл с картинками. После сохранения материала, фотки в материале появляются, а вот в папке /images/stories/gips нету.
Потом придётся в ручную через ФТП добавлять нужные файлы в соответствующую директорию.
В самом плагине версия 2.0.5 ничего не менял.
*

Stall

  • Захожу иногда
  • 93
  • 0 / 1
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #38 : 08.02.2013, 21:52:54 »
Я решил эту проблему так:

в бесплатной версии плагина необходимо найти файл /plugins/content/jwsig.php, а в нем следующий код (строка 50):
50   $rootfolder = '/images/stories/';

который необходимо заменить на:
50   $rootfolder = '/media/k2/galleries/';

Затем ищем файл /plugins/content/plugin_jw_sig/showthumb.php и заменяем код в строке 15 :
15   $_image_ = '../../../images/stories/'.$_GET['img'];

на:
15   $_image_ = '../../../media/k2/galleries/'.$_GET['img'];

В версии Pro открываем настройки плагина и в поле Root folder for image galleries (Корневая папка для галерей) указываем:

media/k2/galleries/

после чего находим файл /plugins/content/jwsig.php и в строке 68 меняем код:
68   $galleries_rootfolder     = ($params-&amp;gt;get('galleries_rootfolder'))? $params-&amp;gt;get('galleries_rootfolder') : $pluginParams-&amp;gt;get('galleries_rootfolder','images/stories');

на:
68   $galleries_rootfolder     = ($params-&amp;gt;get('galleries_rootfolder'))? $params-&amp;gt;get('galleries_rootfolder') : $pluginParams-&amp;gt;get('galleries_rootfolder','media/k2/galleries');

После этих несложных действий изображения отображаются.
все сделал только по последней процедуре в jwsig.php не мог найти ничего подобного. теперь ошибку не выдает и выводит одно первое изобрадение вместо 3-х. как дальше?
*

Stall

  • Захожу иногда
  • 93
  • 0 / 1
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #39 : 10.02.2013, 18:41:22 »
Проблема рендеринга изображения галереи. Пожалуйста, убедитесь, что папка, которую вы используете для хранения изображений Simple Image Gallery PRO существует и содержит файлы изображений. Плагину не удалось найти папку: media/k2/galleries/72
Выводит вот это. хотя 1-й пример загрузил и вывел как надо. один архив с другими фото не загружает. попробывал старый пример загрузил еще раз(удалив все файлы из директории посредством File Zilla) все норм. Загружаю другой архив - тот же б :(аг
*

Magl

  • Захожу иногда
  • 85
  • 3 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #40 : 22.02.2013, 17:48:56 »
     7б2) ВНИМАНИЕ! есть еще одна подпапка с именем Вашего архива а в ней фото ТО фотки не будут отображаться! НАДо чтобы фотки валялись в корне папки с именем ID материала. перекопируйте их в корень папки ID материала. а внутренню папку с именем архива удалите!!

За ответ спасибо !

У меня какраз вот такая фигня что когда загружаю архив создаётся подпапка с именем архива
Как сделать что бы она не создавалась или может что бы галерея смотрела в эту подпапку ?
*

rga

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
  • RGA
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #41 : 09.04.2013, 10:58:26 »
Вы писали о вопросе:
Цитировать
очень странно! Загружаю картинки, все норм.
В листинге статей K2 выводит галерею корректно, но вот если выбрать конкретную статью то вместо галереи выводит

А у меня все наоборот: вставляю рисунки... в статье они есть, а в списке категорий - пусто!

Почему?
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #42 : 09.04.2013, 11:49:00 »
Потому что галерею нужно вставлять через верхнюю системную вкладку Галерея изображений.И неплохо было бы почитать мат.часть.Это вопросы даже не из простейших.
*

akm

  • Новичок
  • 3
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #43 : 21.06.2013, 12:10:37 »
Подскажите пожалуйста, как мне сделать, чтобы в отдельном разделе (галерея) выводились все картинки из всех статей k2, которые добавлены в K2 Simple Image Gallery PRO?
Всю голову сломал, может кто сталкивался.
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #44 : 21.06.2013, 12:16:49 »
Сделать мега-папку и вывести.Но только это жутко пригрузить сервак хостера может.И скорее всего, все вывалится в тайм-аут.
Что из себя представляет плагин SIG Pro, а теперь уже и компонент? Это галереи в СТАТЬЯХ. Для размещения отдельным разделом стоит воспользоваться отдельным компонентом, к примеру той же бесплатной PhocaGallery.
*

akm

  • Новичок
  • 3
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #45 : 21.06.2013, 12:20:31 »
Спасибо за реакцию!
1. что если сделать пагинацию?
2. А фока съест картинки из материалов к2 SIG Pro?
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #46 : 21.06.2013, 14:28:04 »
Phoca не съест.Ее нужно будет грузить отдельно через свой загрузчик.Если бы это был не К2, а com_content, то тогда бы все папки лежали бы в директории images/ что значительно бы упрощало задачу.Опять же, учитывайте такой момент, что плагин-компонент берет только 1 папку и выводит из нее изображения.Прописать в нем в настройках можно только корневую директорию, например те же images/
А у вас не одна статья, а десяток.С галереями.Или сотни вдруг? Вы себе это представляете? Вы представляете себе этот материальчик с этой пагинацией? ))) - Лично я нет.И еще, я так понимаю, вы захотите, чтобы в той псевдо-галерее было все таки разделение по вашим статьям? А не сплошная каша из разномастных и разножанровых фото? Нет, наверное без компонента стандартной фотогалереи тут не обойтись.Как на мой взгляд.
Понимаю, что это фактически двойная работа, но такие вещи обычно задумываются на момент создания сайта.
Желаю успехов.
*

DmitryVetrov

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #47 : 22.10.2013, 14:53:24 »
Помогите, пожалуйста... Сломал мозг уже...
Итак: Joomla 1.5.26, SiG Pro 2.5.
Загружаю галерею. Картинки грузятся в media/k2/galleries. Создает там папку  18 и грузит все картинки из архива туда
Но... на странице все равно вместо картинок {gallery}18{/gallery}
Я поменял в файле jw_sigpro.php images/stories на media/k2/galleries. В файле jw_sigpro.xml аналогично. Но ничего не выходит...
что может быть?
страница вот http://new.unicum.ru/index.php/vending/coffeerange/rosso
Спасибо большое заранее....
*

Eholov

  • Захожу иногда
  • 170
  • 14 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #48 : 13.01.2014, 18:16:52 »
Сделал сайт на локале. Перенес на тестовый хост. Его там заполнили. Перенес на основной хост и вот всплыла эта проблема оранжевое окно с There was a problem rendering your image gallery. В самом плагине Simple Image Gallery Pro менял путь в Root folder for image galleries с images на media/k2/galleries не помогло.
Помогло удаление папки cache/jw_sigpro и все заработало.
*

мир

  • Осваиваюсь на форуме
  • 31
  • 0 / 0
Re: Не выводит галерею K2 Simple Image Gallery PRO
« Ответ #49 : 21.02.2017, 17:09:46 »
Всем привет! Столкнулся с такой проблемой:
K2 - 2.7.1
SIG - 3.1.0
При добавлении материала с фронтенда, захожу во вкладку галерея изображений, пытаюсь создать и загрузить фото... в ответ выходит сообщение "Для просмотра этой информации необходимо пройти авторизацию". Хотя пользователь уже авторизован!
Кто знает в чем проблема?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

компонент k2 неправильно выводит материалы в категории

Автор bb777

Ответов: 2
Просмотров: 791
Последний ответ 07.04.2017, 16:43:52
от bb777
компонент k2 неправильно выводит материалы в категории

Автор bb777

Ответов: 0
Просмотров: 648
Последний ответ 07.04.2017, 16:42:44
от bb777
Галерея Simple Image Gallery PRO

Автор panaramius

Ответов: 15
Просмотров: 2205
Последний ответ 13.01.2017, 07:48:41
от НАТАЛЬЯG
K2 не выводит материал (ответа не нашел)

Автор makarseo

Ответов: 0
Просмотров: 522
Последний ответ 21.12.2016, 23:37:25
от makarseo
Поиск фото в Simple Image Gallery ?

Автор warlocksp

Ответов: 4
Просмотров: 635
Последний ответ 18.10.2016, 19:44:02
от warlocksp