Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 2254 Просмотров
*

Vital000

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
Internal error 500
« : 22.09.2011, 21:12:46 »
Доброе  время суток!

В один прекрасный момент перестал загружаться компонент JomSocial. При попытке зайти  с фронтенда вылетает ошибка сервера 500. Каких либо действий по обновлению или установке  нового не производилось.
Попытка обновить компонент до новой версии не дал результата. Также обновил sh404SEF. Системный плагины что работают с JomSocial также обновил. КЕШ очищался. В логах сервера какой либо информации по ошибке не нашел. На другом сайте проверил что JomSocial в принципе работает.

Какие могут быть идеи по  устранению ошибки?

Заранее благодарен.

Платформа:    Windows NT HP2 6.0 build 6002 (Windows Server 2008 Standard Edition Service Pack 2) i586
Версия MySQL:    5.1.50-community
Сравнение БД:    utf8_general_ci
Версия PHP:    5.3.3
Веб-сервер:    Apache/2.2.16 (Win32) mod_ssl/2.2.16 OpenSSL/0.9.8o
Интерфейс веб-сервер -> PHP:    cgi-fcgi
Версия Joomla:    Joomla! 1.5.22 Stable [ senu takaa ama woi ] 04-November-2010 18:00 GMT
*

kharol

  • Moderator
  • 1721
  • 217 / 0
Re: Internal error 500
« Ответ #2 : 23.09.2011, 09:48:27 »
Попробуйте временно отключить sh404, может это он путает карту
Чтобы сказать "спасибо" достаточно нажать на "+"
Чтобы сделать бухгалтерскую проводку "спасибо" реквизиты: R192102130372, ЯД:41001768818003
*

Vital000

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
Re: Internal error 500
« Ответ #3 : 23.09.2011, 19:15:26 »
sh404SEF Сразу пытался исключить но результата не было положительного. В логах ничего толком не нашел по данной проблеме. Ошибки есть, но  не связанные с JomSocial.
*

Vital000

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
Re: Internal error 500
« Ответ #4 : 23.09.2011, 19:27:59 »
Вдруг будет у кого такая же ошибка. Была причина с процессом планирования заданий. Странно но почему то перестал адекватно рассылать уведомления поэтому зависал и вылетал в ошибку 500. Всем спасибо)
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Fatal error: Call to a member function getListFooter() on a non-object

Автор kritikos

Ответов: 2
Просмотров: 3612
Последний ответ 08.10.2011, 23:21:18
от kritikos
Ошибка Fatal error: Call to undefined method CommunityViewFrontpage::getItems()

Автор Kay216

Ответов: 1
Просмотров: 1834
Последний ответ 17.08.2011, 11:29:56
от kharol