Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 1864 Просмотров
*

Guitarlover

  • Новичок
  • 5
  • 0 / 0
Akeeba Backup syntax error
« : 23.01.2012, 14:19:47 »
Добрый день!

Прошу помощи у знатоков.

Взломали сайт. Пришлось всё сносить. Ранее делал бэкап сайта Akeeba Backup.
Вычистил корневую папку сайта и скопировал туда резервный файл с расширением .jpa и kickstart.php
Запускаю kickstart путем перехода по ссылке сайт/kickstart.php  процесс идет (тайминг 1 и 5 по умолчанию).
После 5-го пункта (Извлечение) выскакивает сообщение :

"Произошла ошибка

syntax error

Начать сначала

Can't get it to work? Click me!"

Жму начать сначала и всё заново с той же ошибкой. AkeebaExtractWizard не распаковывает данный архив по какой-то причине.  

Помогите, если кто-нибудь знает в чем причина!
Спасибо!

*

Kon Dou

  • Захожу иногда
  • 151
  • 23 / 0
  • Лед соловьиных слез теперь растает...
Re: Akeeba Backup syntax error
« Ответ #1 : 25.01.2012, 01:01:00 »
Битый архив?
На локалке разворачивается?
*

komert

  • Захожу иногда
  • 124
  • 1 / 0
Re: Akeeba Backup syntax error
« Ответ #2 : 03.03.2013, 02:35:20 »
Тоже проблема не распаковывает сделанный бэкап даже на компе . Пишет файл нот фоунд.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не могу распаковать jpa архив сайта Akeeba backup. ajax error

Автор smadkz

Ответов: 4
Просмотров: 15098
Последний ответ 26.12.2020, 15:15:15
от stendapuss
Fatal error: Class 'JDocument' not found

Автор gabiboi

Ответов: 2
Просмотров: 4387
Последний ответ 04.09.2020, 14:39:07
от svetka_777
simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4914
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Ошибка Fatal error: Allowed memory size of 73400320 bytes exhausted

Автор Andre109

Ответов: 1
Просмотров: 4322
Последний ответ 03.12.2018, 01:29:56
от voland
Ошибка 500 Internal Server Error. Что это такое и как это решить

Автор sargiusz

Ответов: 4
Просмотров: 6679
Последний ответ 20.03.2017, 14:30:33
от flyingspook