0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 3593 Просмотров
*

Filipp-Alex

  • Осваиваюсь на форуме
  • 40
  • 0 / 0
Установлен лицензионный JCE и все плагины к нему.
Кодировка админки нормальная. При нажатии кнопки Вставить изображение открывается диалоговое окно. Вот в этом диалоговом окне крякобазы. То есть при входе в режим редактирования или создания материала кодировка в админке нормальная UTF-8, а в при открытии окна вставки изображений, ссылок или медиа в самих окнах-диалогах кодировка автоматически переключается на 1251.
Пробовал на трех сайтах с Joomla 1.5 и на одном с  Joomla 2.5, везде проблема одинаковая. Смена браузера результатов не дает - проблема остается  
Если кто встречался с проблемой подскажите.  
*

DragOnFly

  • Осваиваюсь на форуме
  • 47
  • 0 / 0
Filipp-Alex, а в тему "Русификация JCE 2.0.20 и JCE MediaBox 1.1.2" не заглядывал? Там есть рецепт. У меня тоже самое.
Да, а откуда такие сведения, "что при открытии окна вставки изображений, ссылок или медиа в самих окнах-диалогах кодировка автоматически переключается на 1251"?
« Последнее редактирование: 14.02.2012, 12:22:44 от DragOnFly »
*

Filipp-Alex

  • Осваиваюсь на форуме
  • 40
  • 0 / 0
Создаю новую статью в админке. Нажимаю кнопку вставить картинку. Открывается окно-диалог все в крякобазах. Смотрю кодировку. Убежала на 1251. Тут же меняю на UTF-8 - все показывает нормально.
*

DragOnFly

  • Осваиваюсь на форуме
  • 47
  • 0 / 0
Filipp-Alex, а где это смотреть кодировку и где ее менять?
*

Filipp-Alex

  • Осваиваюсь на форуме
  • 40
  • 0 / 0
Filipp-Alex, а где это смотреть кодировку и где ее менять?
В разных браузерах по разному. Я работаю с Firefoxe. Главное меню, пункт меню "Вид", в выпадающем меню пункт "Кодировка". Выбираем нужную.
*

DragOnFly

  • Осваиваюсь на форуме
  • 47
  • 0 / 0
А... в браузере. Нет, это не тот случай: здесь какие-то элементы JCE (диалоги) были в UTF-8, а кодировка базы была 1251. В рез-те - каша-малаша. Этот вариант см. здесь: Русификация JCE 2.0.19 и JCE MediaBox 1.1.2
*

Filipp-Alex

  • Осваиваюсь на форуме
  • 40
  • 0 / 0
А... в браузере. Нет, это не тот случай: здесь какие-то элементы JCE (диалоги) были в UTF-8, а кодировка базы была 1251. В рез-те - каша-малаша. Этот вариант см. здесь: Русификация JCE 2.0.19 и JCE MediaBox 1.1.2
Ура! Зарработало!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Обтекание картинок текстом

Автор had

Ответов: 8
Просмотров: 12337
Последний ответ 11.06.2020, 15:02:34
от sivers
Слетела кодировка после обновления

Автор Mick_20

Ответов: 15
Просмотров: 1797
Последний ответ 08.09.2019, 18:23:25
от Mick_20
При вставке изображения проблема

Автор polezniy

Ответов: 0
Просмотров: 510
Последний ответ 25.03.2019, 15:35:51
от polezniy
JCE – автоматическое добавление класса при вставке

Автор Gerostrat

Ответов: 0
Просмотров: 407
Последний ответ 22.02.2019, 10:55:01
от Gerostrat
Параметры выравнивания картинок в JCE

Автор Gedonist

Ответов: 0
Просмотров: 664
Последний ответ 16.10.2017, 10:39:55
от Gedonist