0 Пользователей и 1 Гость просматривают эту тему.
  • 20 Ответов
  • 18238 Просмотров
*

makc9I

  • Захожу иногда
  • 89
  • 0 / 0
Доброго времени суток.
Хочу убрать index.php из URL.
Как понял, нужно поставить настройку Настройки SEO/Перенаправление URL в да

Но после установки радиобатона в ДА и сохранения, он опять стоит на НЕТ, полагаю надо что-то прописать в .htaccess, но не знаю, что. Сам файл .htaccess присутствует.
кстати, опции Добавлять суффикс к URL и Алиасы в Unicode тоже не изменяются
*

Ragivort

  • Завсегдатай
  • 1154
  • 56 / 2
  • Такая Life
Возьмите .htaccess из дистрибутива Жумлы.
Дозволь мне свершить то добро, которое я способен свершить, теперь, ибо я могу более не вернуться сюда.
*

makc9I

  • Захожу иногда
  • 89
  • 0 / 0
Полагаю, он оттуда и есть. Ну я нашел файл htaccess.txt в дистрибутиве, скопировал весь текст оттуда. Вставил с заменой в свой файл .htaccess в корне сайта. Ничего не изменилось. Настройка также соскакивает на НЕТ.
*

Ragivort

  • Завсегдатай
  • 1154
  • 56 / 2
  • Такая Life
перезалейте двиг
мб дело в хостинге еще.
Дозволь мне свершить то добро, которое я способен свершить, теперь, ибо я могу более не вернуться сюда.
*

Fedor Vlasenko

  • Живу я здесь
  • 3844
  • 730 / 7
  • Все начинается с Value
Открой файл configuration.php ( в корне сайта лежит) найди sef_rewrite = '0'; и змени на  sef_rewrite ='1';
*

makc9I

  • Захожу иногда
  • 89
  • 0 / 0
Poznakomlus, спасибо, получилось. Так же нашел и остальные настройки, типа Добавлять суффикс к URL и Алиасы в Unicode.
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
тоже похожая проблема. только после включения перенаправления выдает ошибку 404 на все страницы кроме главной страницы.
htaccess переименован, в cofiguratuon все нормально, mod_rewrite включен.
joomla 2.5.6
*

Фей

  • Давно я тут
  • 738
  • 86 / 3
  • Истина в вине!
тоже похожая проблема. только после включения перенаправления выдает ошибку 404 на все страницы кроме главной страницы.
htaccess переименован, в cofiguratuon все нормально, mod_rewrite включен.
joomla 2.5.6
А разрешено ли у вас использование хтаксесс на хостинге?
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
да нет у меня хостинга, я на апаче 2.2 сижу
*

Фей

  • Давно я тут
  • 738
  • 86 / 3
  • Истина в вине!
да нет у меня хостинга, я на апаче 2.2 сижу

А тогда чего вы нам тут мозги парите? )))) На локалхосте (своем компе) много чего может не работать. Вот когда вы свой сайт перенесете  на хостинг, тогда и посмотрите, что у вас не работает
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
зачем это мне его переносить? он и так работает отлично. че зря сервер покупался что ли.
вот будет народу много. тогда подумаем.
*

Фей

  • Давно я тут
  • 738
  • 86 / 3
  • Истина в вине!
лан, я молчу....
но ответ козырный, я на апаче.
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
свет клином на хостинге не сошелся. имхо.
хотите хостингуйтесь, не хотите не надо.
однако переадресация *мать ее* должна работать.

из рубрики: что у вас болит? в груди? так конечно, у вас же легкие сами по себе работают, вот когда подключите к исскуственной вентиляции легких, тогда все болеть и перестанет!
*

Фей

  • Давно я тут
  • 738
  • 86 / 3
  • Истина в вине!
Блин, maxexp, честно оно нам нать?
Мы тут телепаты е-мае ) Вы задаете в настоящее время беспредметные вопросы. не работает у вас SEF, ну и лан с нашей точки зрения, т.к. вы не даете ссылки  на свой  сайт, не указываете какие компоненты используете.
Пусть народ напрягается, советы дает. Гоу в коммерческий раздел.
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
сами вы гоу))
а причем тут ссылка и компоненты, даже если из-за какого-то из них не работает, я все-равно ничего удалять не буду. столько провозился с этим сайтом(((
мне вобщем-то эти "индексы" тоже не мешают пока, чтоб всерьез озаботиться. но если есть готовое решение, почему бы им не воспользоваться.
*

maxexp

  • Осваиваюсь на форуме
  • 42
  • 3 / 0
починилось после переустановки апача)
*

HeartOfSteal

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Помогите и мне, пожалуйста.
Надо сделать перенаправление с http://cyborg.dp.ua/mini на главную страницу.
Стандартным методом через админку не работает. Через cpanel тоже не хочет. Вот мой хта:

Спойлер
[свернуть]
*

setitle

  • Осваиваюсь на форуме
  • 13
  • 0 / 0
в моем случае в  htaccess было почти пусто. скопировал с другого сайта содержимое и configuration.php ( в корне сайта лежит) найди sef_rewrite = '0'; и змени на  sef_rewrite ='1';
после этого все запахало. Спасибо )
*

СергейВГ

  • Новичок
  • 1
  • 0 / 0
Я сделал в настройках Joomla перенаправление URL, и у меня перестали открываться страницы сайта (ошибка 404). Оказалось, что файл .htaccess был у меня неправильный (не знаю откуда я его взял) - выяснилось когда скачал .htaccess с работающего сайта и сравнил со своим. Я его удалил, а вместо него скопировал в корневую папку сайта файл htaccess.txt из папки с дистрибутивом Joomla, которую я установил (хорошо, что дистрибутив я оставил, не удалил). Потом файл переименовал в .htaccess. После этого заработало.
Так что если у вас похожая проблема, попробуйте найти в дистрибутиве файл htaccess.txt и сравнить со своим .htaccess.
Файлы открываются в Notepad++
*

Voblin_UA

  • Новичок
  • 8
  • 0 / 0
Так а что конкретно там было не так?
Та же проблема: дистрибутив с официального сайта, при включении перенаправления URL - получаю ошибку 404 на всех страницах, кроме главной... :( .htaccess переименован, работает, судя по тому, что 301-й редирект из него нормально фунциклирует. А вот как с перенапралением быть - не могу понять...
*

Creo

  • Новичок
  • 1
  • 0 / 0
Тоже не работает SEF(ЧПУ). VDS своя, собрана вручную, без панели (Конфиги NGINX и Apache писаны вручную). В .htaccess 301 с без www на с www работает (начинает зацикливать, так как редиректы настроены в NGINX с http на https и с www на без www), то есть файл считывается и обрабатывается Apache'м.
Сервер NGINX (frontend) + Apache 2.4 (backend) + Joomla 3.9.23
Любые конфиги могу предоставить, имею ROOT доступ. Файл .htaccess изменялся, в нём закрыл доступ к .user.ini, и всё
Если я верно понимаю, то Apache не отдаёт данные NGINX'у о странице, и из за этого NGINX ругается 404ой ошибкой.
При установке Joomla было сделано чтоб все пункты были зелёным цветом, в том числе буферизация вывода.
P.S. не нашёл тему для joomla 3, спрашиваю тут
« Последнее редактирование: 31.12.2020, 18:11:33 от Creo »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема со страницей "Общие настройки" - Joomla 2.5

Автор sultan7

Ответов: 20
Просмотров: 1719
Последний ответ 20.10.2019, 18:24:21
от sultan7
Нет верхнего меню, пунктов подменю в разделе Общие настройки

Автор philip

Ответов: 2
Просмотров: 729
Последний ответ 27.01.2018, 21:50:37
от philip
Проблема со страницей "Общие настройки"

Автор ugrumy

Ответов: 7
Просмотров: 4604
Последний ответ 27.01.2018, 17:01:15
от philip
Настройки поиска в Joomla

Автор bobylev

Ответов: 5
Просмотров: 3936
Последний ответ 29.10.2015, 11:23:07
от Exciter
HTTP 301 Перенаправление на domain.com/?lang=en-GB

Автор hilton413

Ответов: 2
Просмотров: 995
Последний ответ 28.07.2015, 14:25:10
от hilton413