Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 11 Ответов
  • 3606 Просмотров
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
Добрый день! Ребята, СОС! Впервые такое вижу... Создаю материал, жму Сохранить (или Сохранить и закрыть - не важно), вылазит ошибка:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@fcspam.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.16 (Debian) Server at fcspam.ru Port 80

Не понял... Повторил - тоже самое. Подумал, что что-то в шаблоне натворил. Выбрал штатный - та же фигня.
Подумал, возможно из-за редактора. Сменил на другой - та же фигня.
Думаю, может в коде какой косяк. Стал размещать статью по кускам. Первый кусок - Сохраняется! Второй - сохраняется. На третьем снова ошибка.

Создал новый материал покороче - все получилось...

Пришел к выводу, что проблема именно в большом объеме текста... НО, по сути, он не такой уж и большой! В Notepad++ всего 484 строки. Я уверенно на все 100, что создавал на Joomla и гораздо более объемные материалы! Да и о каком вообще может идти речь ограничении?

Что делать?

Помогите, пожалуйста!

Заранее спасибо!
« Последнее редактирование: 25.02.2013, 17:11:47 от dron »
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
Ни у кого не было такого?
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
на серваке меняли версию PHP с 5.2 на 5.3. Могло ли из-за этого быть?
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
Как удалось установить, проблема на в версии PHP....
*

mohax

  • Давно я тут
  • 901
  • 66 / 3
А сколько весит текстовый файл с этим текстом? Именно текстовый. Скорее всего у Вашего сервера стоят ограничения по размеру пост запроса.
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
да не много он весил... проблему решил через саппорт хостинга. оказалось, у них там какие-то проблемы были.

Всем спасибо! Тема закрыта.
*

KarelinV

  • Осваиваюсь на форуме
  • 13
  • 0 / 0
у меня стоят ограничения POST запроса, как их увеличить?
Заранее спасибо за ответ:)
*

praporhik

  • Осваиваюсь на форуме
  • 29
  • 0 / 0
Есть еще проблема. При сохранении материала, иногда выдает ошибку Error validating application. Application has been deleted.
Не могу понять откуда. Проверил на дублирование контента, меню. Вроде все нормально. А иногда при сохранении выдает, что алиас такой уже есть, а на самом деле нет.

Никто не решал подобные проблемы?
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
все это к хостеру!
*

praporhik

  • Осваиваюсь на форуме
  • 29
  • 0 / 0
Есть еще проблема. При сохранении материала, иногда выдает ошибку Error validating application. Application has been deleted.
Не могу понять откуда. Проверил на дублирование контента, меню. Вроде все нормально. А иногда при сохранении выдает, что алиас такой уже есть, а на самом деле нет.

Никто не решал подобные проблемы?

Ответ хостера:
Данная ошибка не несет никакй технической информации, мы не можем судить о ней. Ищите причину в CMS
*

dron

  • Завсегдатай
  • 1581
  • 16 / 10
только что вбил фразу Error validating application. Application has been deleted. в Google и Яндекс. Судя по результатам, такое случается и на других двигах в связке с facebook. По всей видимости, проблема в этом.
*

kisBoss

  • Захожу иногда
  • 449
  • 36 / 0
  • ник Tobol
Подскажите, у меня такая же проблема. Нужно создать один материал и вставить в нее текст книги. Как только не экспериментировал, не сохраняет и все. Что на локалке, что на VPS. Куда лезти, где копать?
Если помог - поставте "плюс". Вам ничего не стоит, а мне приятно.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как редактировать отдельную страницу Joomla 2.5?

Автор mrporter

Ответов: 0
Просмотров: 20307
Последний ответ 14.09.2023, 22:16:47
от mrporter
Joomla 2.5.28, Safari под маком и сессии session

Автор beliyadm

Ответов: 19
Просмотров: 29664
Последний ответ 29.03.2023, 12:17:19
от Sawell
Joomla 2.5.28 как скачать все файлы через панель управления

Автор Sergei41984

Ответов: 7
Просмотров: 25142
Последний ответ 27.12.2022, 23:30:38
от Sergei41984
Расширения для Joomla! 1.6 (коллекция полезных ссылок)

Автор Sulpher

Ответов: 124
Просмотров: 169924
Последний ответ 03.12.2022, 16:15:19
от besttechoff
Почему в админке Joomla 2.58 - у меня 16 админов показывает?

Автор dyalex

Ответов: 7
Просмотров: 20390
Последний ответ 27.10.2022, 19:03:45
от marksetter