Новости Joomla

Вышли релизы безопасности Joomla 6.1.4 и Joomla 5.4.9

Релиз безопасности Joomla 6.1.4 и Joomla 5.4.9

Проект Joomla! рад сообщить о выходе Joomla 6.1.4 и Joomla 5.4.9. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 2967 Просмотров
*

Xenday

  • Новичок
  • 6
  • 0 / 0
Установлена Joomla 2.5.11 и компонент sh404SEF, при проверке онлайн сервером, получаю вот такой результат:

Обработка ошибки 404
Ошибка 404 настроена некорректно, при запросе несуществующих адресов, например, sait.ru/qwerty123456.html, сервер отдает ответ HTTP/1.1 200 OK. Необходимо настроить ответ сервера HTTP/1.1 404 Not Found для несуществующих страниц.


Собственно вопрос в том, что когда обращаешься к несуществующей странице сайта, то просто грузится главная, как сделать, чтобы сайт выдавал 404 ошибку, и загружалась страница, что такой страницы не существует? За ранее спасибо за ответ.
*

antony2606

  • Давно я тут
  • 634
  • 46 / 4
  • Работаем!
Re: Как настроить ошибку 404 на сайте?
« Ответ #1 : 16.07.2013, 12:26:00 »
Некоторые веб-сайты вместо «не найдено» возвращают стандартную страницу с кодом «200 OK», это известно как мягкая ошибка 404. Мягкий 404 является проблемой для автоматизированных методов анализа работоспособности ссылки...

http://ru.wikipedia.org/wiki/HTTP_404
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как настроить 310 ред с http на https?

Автор Anna01

Ответов: 0
Просмотров: 1349
Последний ответ 02.09.2017, 12:00:47
от Anna01
Как настроить в Joomla SEF с кирилическими url?

Автор sochirf

Ответов: 2
Просмотров: 1457
Последний ответ 10.11.2016, 18:01:47
от voland
Точки в ссылке - как настроить родной SEF? чтобы точки не пропускал?

Автор votuksol

Ответов: 3
Просмотров: 1736
Последний ответ 15.11.2015, 09:26:40
от oleg222
Как настроить плагин shnodoubles под Joomla 2.5?

Автор borro

Ответов: 23
Просмотров: 5694
Последний ответ 31.12.2014, 18:54:51
от CyDb6a
Ошибка JoomSEF 4.5.3 на сайте

Автор Solvedor

Ответов: 0
Просмотров: 1401
Последний ответ 03.11.2014, 12:23:55
от Solvedor