Не работают кнопки - сохранить, закрыть и пр

  • 42 Ответов
  • 15061 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

забавно выходит, перенёс сайт с одного домена на другой и такая же проблема возникла. Кнопки сохранить, сохранить и закрыть в модулях и кнопка сохранить в настройках шаблона перестали работать. Хотя все остальные по админке фурычат. Joomla обновлял, версию PHP менял, всё бестолку...

*

tigra-uki

  • ****
  • 374
  • 10
  • Joom'лiстка
Попробуйте сменить версию php на более новую)
Мне это помогло)

да, причем в моем случае заработало только с версией 5.6
Слишком сконцентрированное внимание необходимо разбавлять действием.

*

uisr

  • ****
  • 200
  • 0
У меня перестали работать все кнопки в Менеджере меню, но в других менеджерах все работает.
Изменение файла edit.php и очистка кэша не помогло.

Таким образом, не могу отредактировать меню сайта. Как это можно исправить?



*

Gosha5767

  • *****
  • 427
  • 21
вот в этом файле - administrator/components/com_modules/views/module/tmpl/edit.php
в строке - <form action="<?php echo JRoute::_('index.php?option=com_modules&layout=edit&id=' . (int) $this->item->id); ?>" method="post" name="adminForm" id="module-form" class="form-validate">
id="Module-form" поменял на id="adminForm"

Мне помог этот метод решить такую же проблему
firstac Спасибо!
Чистка сайта от дублей в Яндекс и Google.
Удаление ссылок (битых и внешних) на сайте.
Миграция Joomla 1.5 до Joomla 3.хх

*

arturk

  • ***
  • 95
  • 8
Мне помог этот метод решить такую же проблему
firstac Спасибо!
решено, спасибо

*

Mehanick

  • *****
  • 600
  • 1
Обновил сайты  с 3.4.1 до 3.4.3 - та же беда, в компоненте Form Maker (аналог RSForm только дешевле), перестали работать в панели кнопки сохранить и закрыть, причем не везде. а только когда опции форме назначаешь.

На офсайте на форуме поддержки уже запопили по этому поводу, они там чтото поправили в дистрибутиве и предложили обновиться. Да вот только подписка давно кончилась, хотя форма прекрасно работала до сих пор.

Даже не знаю что делать теперь, как эти кнопки заставить работать. В других компонентах нормально.

Похоже это массовое явление у многих после обновления Joomla.

*

AlekVolsk

  • ********
  • 6301
  • 336
Это скорее массовая неграмотность разработчиков расширений, которые пишут нативный код, невалидный по отношению к конкретному движку, в данном случае - не по правилам J. Выходов только три: самому править ручками имеющееся, использовать аналоги (дорогие/бесплатные - не суть, вопрос не в цене, а в качестве кода) или разрабатывать собственный аналог и в случае чего пенять на себя.

*

SergPro

  • ***
  • 51
  • 0
По опыту. Попробовал открыть панель админа на простом интернет эксплоере .. и всё заработало! На мазиле - отказывается нажиматься кнопки созранить, сохранить и закрыть и т.д....
Может кому поможет... (хотя на мазиле FireBug... И приодиться админку держать на експлоере, а баги проверять на мазиле)

*

demis

  • ***
  • 43
  • 2
Цитировать
Проблема решена.

вот в этом файле - administrator/components/com_modules/views/module/tmpl/edit.php

в строке - <form action="<?php echo JRoute::_('index.php?option=com_modules&layout=edit&id=' . (int) $this->item->id); ?>" method="post" name="adminForm" id="module-form" class="form-validate">

id="Module-form" поменял на id="adminForm"

и всё заработало.
Такая же история, только вместо "Module-form" было "module-form".

*

Sandra

  • ***
  • 69
  • 35
  • Дедушка Игнат, приди )))))
Все заработало. Решение оказалось тупым и простым: в настройках шаблона переключился на другую панель управления.

Мне пока помогла данная манипуляция, посмотрю что будет при переносе сайта.
Все девочки козлы и хотят от мальчиков только секса ))))
Форум - это маленькая жизнь...

*

forsight

  • ***
  • 26
  • 0
Сегодня столкнулся с такой же проблемой, только в модулях все работало, а в остальных разделах админки нет. Переносил сайт в пределах одного хостинга с одного имени на другой (с тестового на нормальное). Вообщем ничего из перечисленного не помогло. Стал смотреть файлы и в configuration.php увидел что почему то путь к папке log сбился. Стоял вот такой public $log_path = '/home/domains/site.ru/public_html/administrator/logs'; Исправил на $log_path = '/home/domains/site.ru/public_html/logs'; и все заработало. Так что проверяйте пути. Хотя как это влияет на работу админки представляю не очень)))

*

Mehanick

  • *****
  • 600
  • 1
сиськи НИЗАЧОТ

Нашел подобную проблему на англоязычных форумах.И действительно нажатие кнопки Ctrl+F5 (таким образом чистится весь кешь страницы, в т.ч. JS) решает эту проблему

ПОМОГЛО! Спасибо!