0 Пользователей и 1 Гость просматривают эту тему.
  • 21 Ответов
  • 4516 Просмотров
*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
Joomla! 3.2.0 Stable [ Ember ] 6-November-2013 14:00 GMT

JComments 3.0.0 [02/09/2013]

В правах компонента выставлено - разрешить комментирование гостям, но на фронте все равно сообщает

Цитировать
У Вас недостаточно прав для комментирования

и соответственно - ни формы добавления комментов, ни CAPTCHA...

Куда рыть?
« Последнее редактирование: 25.12.2013, 14:05:37 от Taatshi »
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

Sergey-N81

  • Захожу иногда
  • 133
  • 11 / 1
Re: Разрешить комментирование гостям
« Ответ #1 : 20.12.2013, 16:22:46 »
Присоединяюсь к вопросу, поставил галочки на против Гостя но так ничего и не появилось!
  • Разрешить комментирование
  • Разрешить ответы

при входе администратором все работает, а обычному пользователю пишет (у вас нет прав для размещения комментариев)

Спойлер
[свернуть]
« Последнее редактирование: 20.12.2013, 19:02:08 от Sergey-N81 »
*

Sergey-N81

  • Захожу иногда
  • 133
  • 11 / 1
Re: Разрешить комментирование гостям
« Ответ #2 : 20.12.2013, 19:30:31 »
Даа, тоже придется DISQUS ставить ;)
*

ELLE

  • Глобальный модератор
  • 4513
  • 891 / 0
Re: Разрешить комментирование гостям
« Ответ #3 : 21.12.2013, 01:57:59 »
Действительно есть проблема с версией J3.2

Я доковырялась там до одного интересного момента с JUser, сначала хотела все расписать, но потом обновилась до 3.2.1 и в общем-то все самоизлечилось. Проблема была не в компоненте

Так что обновляйтесь!

*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
Re: Разрешить комментирование гостям
« Ответ #4 : 21.12.2013, 22:03:54 »
Мне обновление не помогло. Обновилась, переустановила компонент, зашла с другого браузера - та же песня.
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

ELLE

  • Глобальный модератор
  • 4513
  • 891 / 0
Re: Разрешить комментирование гостям
« Ответ #5 : 21.12.2013, 22:37:30 »
Ну тогда расскажу что я нарыла



Доковыряла до /components/com_jcomments/classes/acl.php

Код: php
$this->canComment = $this->check('can_comment'); 
должно отдавать 1, а отдает 0, при условии что разрешено комментирование гостям и вы зашли на фронт как гость

а суть ниже, в функции check проверяется id группы пользователей Joomla с таблицей компонента -

 [can_comment] => 1,9,6,7,2,3,4,5,8

выделила 9-ку,  id группы пользователей Guest что раньше, что сейчас = 9
но! в объекте почему-то = 13... (у меня до обновления до 3.2.1, то есть еще при версии 3.2)
Код: php
JUser Object
(
   .....
    [groups] => Array
        (
            [0] => 13
        )
   .....
)

в принципе если в таблице сменить id (только для того, чтобы протестировать)


то все должно работать,
но это как бы ненормально в принципе, потому что... -

в общем, после замены
http://prntscr.com/2cp6fb
все заработало

если что проверьте, что у вас покажет
Код: php
$user = JFactory::getUser();
             print_r($user->groups);

------------------------------------------
а почему  print_r($user->groups); дает 13,  а не 9 в J3.2, мне так и не удалось понять, но после обновления в объекте уже было всё правильно и соответственно дальше уже все работало
-----------------------------------------
не исключаю, что у вас может быть причина в чем-то другом, но я проверила на двух сайтах - везде одно и тоже с JUser
« Последнее редактирование: 25.12.2013, 15:10:24 от ELLE »
*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
Re: Разрешить комментирование гостям
« Ответ #6 : 22.12.2013, 10:55:24 »
Спасибо, сейчас погляжу  ID
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
Re: Разрешить комментирование гостям
« Ответ #7 : 25.12.2013, 14:03:03 »
Проблема решена. Это косяк движка. Не проставляется значение группы при установке. В БД лезть не обязательно.

Пользователи - группы - настройки

На вкладке перевыбрать

Группа пользователей для Гостей - Public

и заново сохранить.

Все работает.

Спасибо smart за подсказку.
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

ELLE

  • Глобальный модератор
  • 4513
  • 891 / 0
Re: Разрешить комментирование гостям
« Ответ #8 : 25.12.2013, 14:05:34 »
Во, я же говорю, компонент не виноват :) Бажная эта J3-ка

Значит решено
*

smart

  • Администратор
  • 6485
  • 1318 / 15
  • Хочешь сделать хорошо — сделай!
RE: Разрешить комментирование гостям
« Ответ #9 : 03.01.2014, 21:54:11 »
Сделал я небольшой финт ушами - новая версия при установке будет проверять, действительно ли есть такая группа, как указано в параметрах com_user и если такой группы нет - будет сбрасывать на 1 (Public).
*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
RE: Разрешить комментирование гостям
« Ответ #10 : 04.01.2014, 13:13:49 »
Сереж, проверила тот архив, что ты мне дал - не сработало.

Все равно You have no rights to post comments

Joomla! 3.2.0 Stable [ Ember ] 6-November-2013 14:00 GMT
JComments 3.0.0 [11/12/2013]

Группы пока не переправляла.
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

smart

  • Администратор
  • 6485
  • 1318 / 15
  • Хочешь сделать хорошо — сделай!
RE: Разрешить комментирование гостям
« Ответ #11 : 04.01.2014, 18:41:44 »
Так, я кинул в почту немного другой архив - попробуй )
*

Taatshi

  • Глобальный модератор
  • 5244
  • 479 / 1
  • Верстаем и кодим. Обращайтесь ;)
RE: Разрешить комментирование гостям
« Ответ #12 : 04.01.2014, 23:18:07 »
Уррррряяяя! Зарррработало!
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

smart

  • Администратор
  • 6485
  • 1318 / 15
  • Хочешь сделать хорошо — сделай!
RE: Разрешить комментирование гостям
« Ответ #13 : 04.01.2014, 23:51:20 »
Это радует (не люблю, когда у меня все работает, а у других - нет). Если за завтра ничего не всплывет - в понедельник выпустим эту версию в паблик.
*

AlexP750

  • Захожу иногда
  • 108
  • 1 / 0
RE: Разрешить комментирование гостям
« Ответ #14 : 09.01.2014, 20:16:07 »
Всех с прошедшими и наступающим!
Наблюдаю ту же картину - гости не могут оставлять комментарии. Попробовал сделать, как описал Taatshi, но не совсем понял последовательность действий:
Цитировать
Пользователи - группы - настройки

На вкладке перевыбрать
Не могу найти вышеуказанную вкладку... Попробовал "Менеджер пользователей: Уровни доступа" и для Public и для Guest поставить галки Public и для Guest. Пользы от этих действий никакой...
Насколько я понимаю, версии, о которой говорил уважаемый Smart (я без иронии), пока нет?
Мне не горит, просто не совсем понятно :)
ps Прошу строго не судить, за возможно ламерский вопрос. Я никогда не занимался Joomla! профессионально...
*

hotstuff1988

  • Новичок
  • 3
  • 2 / 0
Re: Разрешить комментирование гостям
« Ответ #15 : 16.01.2014, 14:40:39 »
но не совсем понял последовательность действий:Не могу найти вышеуказанную вкладку...
Вобщем я тоже долго копался, т.к. выше не совсем точно описана последовательность действий, а нужно сделать следующее:
1. Выбираем меню "Пользователи > Группы"
2. Отмечаем галочкой группу "Public" и клацаем кнопку "Настройки" (а я просто клацал на группу Public и там нажимал Сохранить)





3.Нажимаем сохранить и выходим




После данных действий незарегистрированные пользователи видят форму для комментариев
« Последнее редактирование: 16.01.2014, 14:50:29 от hotstuff1988 »
*

SpeedBoy

  • Захожу иногда
  • 192
  • 16 / 0
RE: Разрешить комментирование гостям
« Ответ #16 : 26.01.2014, 03:09:36 »
2. Отмечаем галочкой группу "Public" и клацаем кнопку "Настройки" (а я просто клацал на группу Public и там нажимал Сохранить)

Спасибо за разъяснение. Тоже клацал не туда. Только мне кажется, галочку можно не ставить. Мы же в Options заходим. К галке там нет привязки или я не прав?
подпись
*

hotstuff1988

  • Новичок
  • 3
  • 2 / 0
RE: Разрешить комментирование гостям
« Ответ #17 : 07.02.2014, 20:42:09 »
Да, привязки нет, с галкой я погорячился.
*

game2r

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
RE: Разрешить комментирование гостям
« Ответ #18 : 20.07.2014, 10:33:21 »
Всем привет. Возникла такая же проблема. Делаю все, что написано выше. Но! У меня почему-то не срабатывают кнопки "Сохранить", "Сохранить и закрыть" и "Отмена" в настройках. Причем ТОЛЬКО в Менеджере пользователей. Кликаешь-кликаешь, а толку нет.
В других разделах все робит на отлично! Версия Joomla самая последняя: 3.3.1. Может кто сталкивался с таким?
*

game2r

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
RE: Разрешить комментирование гостям
« Ответ #19 : 20.07.2014, 10:38:08 »
Сорри. Тупанул. Ответ на мою проблему кроется здесь: http://joomlaforum.ru/index.php?topic=295723.0
*

Nobillis

  • Осваиваюсь на форуме
  • 41
  • 0 / 0
RE: Разрешить комментирование гостям
« Ответ #20 : 19.12.2020, 10:59:16 »
Здравствуйте!
У меня проблема точно такая, Joomla! 3.9.13  JComments 3.0.7
id пользователя: array(3) { [2]=> string(1) "2" [5]=> string(1) "5" [11]=> string(2) "11"}  т.е. 2,5,11
разрешенные id: can_comment    8,6,7,2,5
Но комментировать все так-же запрещено, и тут я вспомнил что сайт уже каке-то время работает на php 7.4.8 - может ли быть проблема именно в версии php, если да - подскажите как вылечить проблему?
Проблема как описала ELLE - отдает 0, а должно отдавать 1, хотя с id все норм.
« Последнее редактирование: 19.12.2020, 11:15:38 от Nobillis »
*

Nobillis

  • Осваиваюсь на форуме
  • 41
  • 0 / 0
RE: Разрешить комментирование гостям
« Ответ #21 : 19.12.2020, 11:54:49 »
Разобрался, в моем случае проблема была из-за созданной мною дополнительной группы пользователей, и для этой новой группы не было никаких прав.
Задача у меня такая, чтобы все авторизованные пользователи могли комментировать, а гости нет - по этой причине я спокойно указал права комментирования своей новой группе и все заработало.
P/S/ Заработало даже у тех пользователей которые принадлежат только к обычной группе Registered и никак не связанны с моей новой группой пользователей.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

[Решено] Не отображаются аватары CommunityBuilder в JComments

Автор Ishti39

Ответов: 10
Просмотров: 1805
Последний ответ 11.07.2017, 19:09:32
от warlocksp
[Решено] Не удаляются комментарии в админке. (Joomla 2.5.28, JComments 3.0.5)

Автор Esken

Ответов: 5
Просмотров: 2012
Последний ответ 08.05.2017, 17:47:54
от Esken
[Решено] Не обновляется CAPTCHA в JComments 2.3.0

Автор chilly_bang

Ответов: 24
Просмотров: 15980
Последний ответ 28.04.2016, 15:31:15
от Risska
[Решено] Отображается код {jcomments off}

Автор the_nickname

Ответов: 5
Просмотров: 4222
Последний ответ 24.03.2016, 17:31:50
от Lukart
[Решено] После обновления на JComments 3 не работает админка JComments, комментарии есть

Автор nick28

Ответов: 8
Просмотров: 14958
Последний ответ 19.10.2015, 11:37:09
от Stasweb