Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 2664 Просмотров
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Работа на локальной машине, используя WAMP.
Никаких проблем, всё работает, всё обновляется, добавляется, удаляется.
Как только переношу на сервер, появляются "белые страницы".

Изначально их не было, но после переноса нашёл закономерность. Если в VirtueMart'e добавить более восьми цветов товара, то с админки доступа к этому файлу больше нету.
Добавлялись файлы на WAMP'e, как уже говорил, на локальной машине никаких проблем нету.
Так же FireBug находит косяк, при белой странице :
Вкладка "Сеть" - Перезагрузите страницу, чтобы получить источник для: http://*****.**/administrator/index.php?option=com_virtuemart&view=product&task=edit&virtuemart_product_id=128&product_parent_id=0
Перепробовал все варианты которые смог найти для вывода ошибок, ничего не помогло. Более того, ничего не выводило. Логи чистые, во всяком случае путь к ним вроде верный, но ничего не пишется туда.
Пути к логам - /home/*****/web/*****.**/public_html/logs
Так же иногда просто при просмотре сайта выбивает "белую страницу", при перезагрузке или паре сайт загружается нормально.
Пробовал ставить на всю папку с файлами сайта права 777, не помогло.
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #1 : 14.03.2014, 00:47:40 »
Добавить думаю стоит, что версия Joomla 2.5.19.
Версия VirtueMart 2.0.22d.
*

ELLE

  • Глобальный модератор
  • 4505
  • 893 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #2 : 14.03.2014, 01:45:05 »
без кода ошибки, помочь не  получится. обратитесь к хостеру
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #3 : 14.03.2014, 01:46:09 »
Я и есть хостер, что нужно от сервера?
*

evgen777

  • Давно я тут
  • 657
  • 62 / 2
Re: Белая страница в админке Virtuemart'a
« Ответ #4 : 14.03.2014, 01:47:38 »
Включайте отображение ошибок в общих настройках  и код ошибки в студию...
Разработка, доработка расширений для Joomla!
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #5 : 14.03.2014, 01:51:11 »
Увожаемые, в том-то и дело, что не выходит получит ошибку.
В configuration.php менял вывод ошибок на default, maximum, development. Ошибки нет.
В php.ini правил вывод ошибок. Ошибки нет.
Пытался .htaccess файл создавать (так как в корне сайта его нет). Ошибки нет.
Ещё какие-нибудь идеи будут?
*

zomby6888

  • Завсегдатай
  • 1473
  • 171 / 3
Re: Белая страница в админке Virtuemart'a
« Ответ #6 : 14.03.2014, 10:44:11 »
врядли я вам подскажу решения но есть еще две причины по которым вы можете видеть белый экран без ошибок:

1) defined('_JEXEC') or die;
 Скрипт вас может отфутболить если вы  обращаетесь к нему минуя точку входа для инициализации ядра.
Если изменить в скрипте defined('_JEXEC') or die('ошибка прямого доступа'); то вы можете убедится что именно это и есть причина.

2) Вы открываете пустой index.html который распихан по многим папкам в Joomla, для защиты от просмотра
интернет-блог: http://websiteprog.ru
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #7 : 14.03.2014, 14:22:43 »
врядли я вам подскажу решения но есть еще две причины по которым вы можете видеть белый экран без ошибок:

1) defined('_JEXEC') or die;
 Скрипт вас может отфутболить если вы  обращаетесь к нему минуя точку входа для инициализации ядра.
Если изменить в скрипте defined('_JEXEC') or die('ошибка прямого доступа'); то вы можете убедится что именно это и есть причина.

2) Вы открываете пустой index.html который распихан по многим папкам в Joomla, для защиты от просмотра

Это может как-то активироваться при пересылке файлов на сервер?
На локальной машине всё работает, при пересылке на сервер начинает глючить. Пересылаются всей файлы, никаких сбоев при передаче.
Пробовал ставить 777 на все файлы, нет результатов.
Что может так глобально меняться при пересылке?
Может быть в базе данных что-то кроется?
*

DemSky

  • Новичок
  • 6
  • 0 / 0
Re: Белая страница в админке Virtuemart'a
« Ответ #8 : 19.03.2014, 02:32:23 »
Ап!
Проблема всё ещё актуальная.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Расчёт стоимости товара в VirtueMart за периметр

Автор NIKOLY

Ответов: 0
Просмотров: 4351
Последний ответ 04.07.2025, 09:18:31
от NIKOLY
VirtueMart 3 Отображать только товары в наличии!

Автор GaziroFFka

Ответов: 4
Просмотров: 7593
Последний ответ 06.06.2023, 13:55:13
от Akeksandr
SP VirtueMart Category Search

Автор ve1006

Ответов: 10
Просмотров: 15760
Последний ответ 18.01.2023, 10:39:10
от AzMandius
Как вывести модуль в страницу VirtueMart?

Автор harddrop

Ответов: 11
Просмотров: 13059
Последний ответ 13.11.2022, 13:11:37
от Evgen Kulibin
Как правильно настроить покупку в VirtueMart?

Автор varella

Ответов: 1
Просмотров: 5497
Последний ответ 12.10.2022, 16:14:04
от varella