0 Пользователей и 1 Гость просматривают эту тему.
  • 15 Ответов
  • 1372 Просмотров
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Уважаемые форумчане, хочу описать одну проблему после обновления до Joomla 3.4.5 появились проблемы с отображением картинок на сайте при включенном плагине кеш.
Вообщем суть вот в чем  при включенном кеше на сайте пропадают изображения после двух или трех обновлений страницы.
Пропадают изображения которые вставлены
кнопкой Изображение прямо в текст  через интерфейс редактора (Редактор - JCE, TinyMCE)
или добавленные через вкладку
Изображения и Ссылки : (Изображение для вступительного текста материала - Изображение полного текста материала)

В материале пропадают картинки и ссылки на них становятся неправильными,  именно по этому пропадают изображения.
Если  Плагин-Кеш отключить, картинки не пропадают и ссылки на картинки правильные.
Для более тщательного понимания вопроса я записал видео. Загрузил на Яндекс диск. Можно посмотреть онлайн(качество будет ниже)
Для просмотра в лучшем качестве скачайте себе и посмотрите  видео. Весит видео не много, всего лишь  35 мб.
Вот ссылка на видео.
https://yadi.sk/i/eoxbR5t3kBwG5


Буду рад любой помощи по данному вопросу. Подскажите где копать? Может это какой баг в обновлении Joomla прилетел или я, что то не так делаю? Подскажите пожалуйста.

Напишу  дополнительную информацию:  
1)До Joomla 3.4.5  обновился практически сразу после выхода релиза безопасности, сайт проверил на всякого рода вирусы левые ссылки и все такое.
 
2)Проблему сторонних расширений как мне кажется можно исключить, по той простой причине, что отключал все расширения и проблема с изображениями при включенном кеше не решилась.
Скажу больше, на одном из сайтов вообще только стандартные компоненты установлены и пару плагинов сторонних(которые так же отключал и смотрел результат).
3)Менял шаблон ставил стандартный protostar - Default. Проблему не решает.
4)Проверено в Firefox,  Chrome, Opera, Internet Explorer.
5) Проверено с разных компьютеров и телефонов.
6)Проблемы на нескольких сайтах расположенных каждый на своем сервере, под каждый сайт куплен отдельный хостинг. Поэтому исключаю проблему в хостинге.
« Последнее редактирование: 04.11.2015, 22:17:09 от alekshavan »
*

voland

  • Профи
  • 9500
  • 422
  • Эта строка съедает место на вашем мониторе
А можно ссылку на сайт, где эта проблема в данный момент воспроизводима?
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
А можно ссылку на сайт, где эта проблема в данный момент воспроизводима?
Ну вот например.
http://svsvetoch.by/236/pod-ezd-krysha-eto-tozhe-sobstvennost-zhiltsov.html

Или вот http://g.grace146.com/home/region/208-molitva-primireniya-v-parichakh.html

Сейчас из своего сформулированного сообщения взял цитату и загуглил таким образом "проблемы с отображением картинок на сайте при включенном плагине кеш"
Выдал поиск какие то результаты.....
Есть какие то темы по этому вопросу, но непонятно для какой версии Joomla
« Последнее редактирование: 02.11.2015, 23:22:15 от alekshavan »
*

voland

  • Профи
  • 9500
  • 422
  • Эта строка съедает место на вашем мониторе
Проблема в том что в адресе картинки отсутсвует начальный "/"
Вкупе с прописанным тэгом base href это дает неверный адрес.

Как таковой это не глюк скорее всего - как картинки вставляете? какой редактор?
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Я выше написал, что использовались Редактор - JCE и  TinyMCE
Была такая мысль доставлял слеш / перед images и походу слеши они режут. Да прописал вручную без редактора картинки отображается.
Но это не решает проблему так как по прежнему останется проблема с логотипом.
К тому же надо править в и старые материалы.
и как в ручную прописать для вкладки
Изображения и Ссылки : (Изображение для вступительного текста материала - Изображение полного текста материала)
В этой вкладке то вручную не поправишь.
См. Фото.

*

voland

  • Профи
  • 9500
  • 422
  • Эта строка съедает место на вашем мониторе
Тогда это проблема. В предыдущих версиях можете потестировать? (лучше на локалке, так как они уязвимы).
И есть раздел баги, если оно подтвердится.
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Тогда это проблема. В предыдущих версиях можете потестировать? (лучше на локалке, так как они уязвимы).
И есть раздел баги, если оно подтвердится.

В предыдущих версиях не было такой проблемы. Так как я периодически добавляю материалы.

*

voland

  • Профи
  • 9500
  • 422
  • Эта строка съедает место на вашем мониторе
В предыдущих версиях не было такой проблемы. Так как я периодически добавляю материалы.
Не убирался слэш или не было тэга base href?
*

capricorn

  • Практически профи
  • 1687
  • 105
Я тоже обновлялся до 3.4.5 с 3.4.4. (никогда не включаю плагин Page Cache, т.к. использую шаблоны Yootheme - были какие-то проблемы с изображениями, они сказали отключить его - там своя оптимизация на уровне шаблонов). Включил для теста этот плагин и SEF Joomla на живом сайте 3.4.5. Проблему не удалось воспроизвести.

Google выдал следующее, но для 1.5:
http://forum.joomla.org/viewtopic.php?t=624231#p2984043
суть та же - не использовать этот плагин (может создавать проблемы на некоторых серверах, да и не нужен по большому счету), либо сделать его порядок пониже (я даже делал как-то последним), а плагин SEF переместить повыше. У меня, в частности, на 3.4.5 последний имеет номер 8, а предыдущий номер 9. Но я правда всегда при использовании ЧПУ (конкретно sh404SEF) добавляю слэш вручную в путь при вставке картинок в JCE в контент. Для интро изображения - выберите его сначала, а потом добавьте слэш в начало пути.

От того, что путь будет абсолютным хуже в любом случае не будет  ;)
« Последнее редактирование: 03.11.2015, 00:40:17 от capricorn »
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Не убирался слэш или не было тэга base href?
Не могу сказать прописывался ли раньше в редакторе слеш или нет. И каким образом при этом обрабатывался тег base href.
А я говорю о том, что я не видел такой проблемы с изображениями и кешем в предыдущих релизах Joomla.(до обновления)
Для того, чтоб все это дело  вразумительно протестировать и подтвердить баг у меня недостаточно компетенции, иначе бы я не писал здесь на форуме в поисках решения вопроса.

*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Google выдал следующее, но для 1.5:
http://forum.joomla.org/viewtopic.php?t=624231#p2984043
суть та же - не использовать этот плагин (может создавать проблемы на некоторых серверах, да и не нужен по большому счету), либо сделать его порядок пониже (я даже делал как-то последним), а плагин SEF переместить повыше. У меня, в частности, на 3.4.5 последний имеет номер 8, а предыдущий номер 9. Но я правда всегда при использовании ЧПУ (конкретно sh404SEF) добавляю слэш вручную в путь при вставке картинок в JCE в контент. Для интро изображения - выберите его сначала, а потом добавьте слэш в начало пути.

От того, что путь будет абсолютным хуже в любом случае не будет  ;)
А как быть с этим где нет возможности прописать в ручную.

А как быть с логотипом шаблона где тоже нет возможности прописать слеш в ручную.

А как быть со старыми материалами, в которых есть изображения и которые тоже слетели из за этого слеша.

К тому же слеш можно добавить только в режиме без редактора. Иначе Редактор - JCE и  TinyMCE режут этот слеш.
Вопрос ведь не только в решении конкретной проблемы на моих сайтах, но а так же вообщем и целом. Хотелось бы, чтоб в общем и цело Joomla нормально работала, а не решал каждый свои вопросы изощряясь тем или иным способом и методом.
Буду что то пробовать, но решения вопроса пока нет.
*

capricorn

  • Практически профи
  • 1687
  • 105
я ж говорю - выберите сначала изображение, появится путь, а потом добавьте слэш в этом самом поле на скрине.

со старыми что делать? Добавить слэш средствами MySQL. На шараде вряд-ли вам дадут функцию выполнить. Устанавливайте на своем ПК MySQL Workbench. SQL-щики вам составят функцию. Потом восстановите базу на хостинге.

Один вопрос - у вас точно раньше все работало при тех же самых условиях до обновления J? Я сомневаюсь, честно говоря.
« Последнее редактирование: 03.11.2015, 01:33:11 от capricorn »
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0
Да, все работало.
*

alekshavan

  • Осваиваюсь на форуме
  • 48
  • 0

Google выдал следующее, но для 1.5:
http://forum.joomla.org/viewtopic.php?t=624231#p2984043
суть та же - не использовать этот плагин (может создавать проблемы на некоторых серверах, да и не нужен по большому счету), либо сделать его порядок пониже (я даже делал как-то последним), а плагин SEF переместить повыше. У меня, в частности, на 3.4.5 последний имеет номер 8, а предыдущий номер 9. Но я правда всегда при использовании ЧПУ (конкретно sh404SEF) добавляю слэш вручную в путь при вставке картинок в JCE в контент. Для интро изображения - выберите его сначала, а потом добавьте слэш в начало пути.

От того, что путь будет абсолютным хуже в любом случае не будет  ;)

Походу вот решение вопроса. Сейчас отсортировал плагины. Сначала вручную сортировал перетаскивал Drag-and-drop в менеджере плагинов.  Плагин-SEF переместил выше Плагин-Кеш ниже, но видимо не упорядочилось. Поэтому картинки по прежнему глючили. Зашел в сам плагин Кеш и выбрал Порядок ниже плагина SEF. Честно говоря в жизни бы не подумал, что дело в этом может быть. Спасибо за помощь.

« Последнее редактирование: 03.11.2015, 02:19:50 от alekshavan »
*

voland

  • Профи
  • 9500
  • 422
  • Эта строка съедает место на вашем мониторе
Выделил в отдельную тему, так как не имеет отношения к конкретному релизу.
*

57tr

  • Новичок
  • 7
  • 0
Походу вот решение вопроса. Сейчас отсортировал плагины. Сначала вручную сортировал перетаскивал Drag-and-drop в менеджере плагинов.  Плагин-SEF переместил выше Плагин-Кеш ниже, но видимо не упорядочилось. Поэтому картинки по прежнему глючили. Зашел в сам плагин Кеш и выбрал Порядок ниже плагина SEF. Честно говоря в жизни бы не подумал, что дело в этом может быть. Спасибо за помощь.


Ты просто МОЛОДЕЦ! Спасибо тебе, хороший человек. Измучился до не могу, поправляя урлы там, где можно и где нельзя. Спасибо
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

[ Решено ] Неизвестная ошибка после обновления 3.6.4 » 3.7.5

Автор dm-krv

Ответов: 5
Просмотров: 122
Последний ответ 07.09.2017, 16:36:41
от dm-krv
Проблема с админкой, прошу совет - Решено

Автор Valera1980

Ответов: 19
Просмотров: 670
Последний ответ 18.07.2017, 15:24:07
от vipiusss
На сайте некорректно настроено отображение несуществующих файлов и страниц

Автор Mick_20

Ответов: 4
Просмотров: 257
Последний ответ 14.06.2017, 14:09:31
от Mick_20
[Решено] Обнаружен запрещённый либо некорректный

Автор HEKTO

Ответов: 4
Просмотров: 722
Последний ответ 23.05.2017, 17:00:12
от HEKTO
[Решено] Joomla 3.7, компонент com fields не найден

Автор alfabet

Ответов: 13
Просмотров: 1103
Последний ответ 12.05.2017, 11:16:36
от alfabet