Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 1860 Просмотров
*

polkost

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Ситуация следующая: есть сервер у хостера на котором висят два сайта, один из которых(интернет-магазин) на домене второго уровня от первой. Ранее перед обращением к хостеру, были ошибки 500,503 при обращении к сайтам иногда и почти всегда после пробы входа в админку.
После обращения и вставления запрета для определенных айпи (вроде как больше кол-во запросов перегружало сервер:видимо брутфорс или ддос атаки), в админку основной домены можно войти и ошибки везде исчезли кроме авторизации в админке интернет магазина. Теперь получаю 500 и 503 при пробе авторизации. Уже сломал голову как решить, хостер разводит руками т.к. .htaccess был подправлен на айпи блокировку адресов высылающих постоянные запросы.Как разобрать в чем проблема и ее решить? Заранее благодарен за советы.
*

arma

  • Завсегдатай
  • 1752
  • 81 / 3
Re: Ошибки при входе в админку 500, 503
« Ответ #1 : 06.12.2015, 05:09:50 »
Меняйте хостера. Он мудрит.
*

polkost

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Ошибки при входе в админку 500, 503
« Ответ #2 : 10.12.2015, 00:04:25 »
а еще есть предложения? Пока такой возможности нет, разве что уличу в "кривизне" услуг. Договор-штука обязывающая.
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
Re: Ошибки при входе в админку 500, 503
« Ответ #3 : 10.12.2015, 00:09:58 »
Ответ сказан.
Нет желания решать - нечего темы создавать.
*

polkost

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Ошибки при входе в админку 500, 503
« Ответ #4 : 10.12.2015, 01:27:22 »
В:Не заводится запорожец
О: Меняйте машину, она плохая

-----
Сами понимаете, не ответ. И желание ту не при чем. Мне нужен ответ=возможная причина.
Хорошо.Положим мудрит. А что именно: не дает трафика, базы не обновляет? Что может быть причиной?

Ответы типа "вам сказали меняй машину", не к месту на форуме данного уровня.
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
Re: Ошибки при входе в админку 500, 503
« Ответ #5 : 10.12.2015, 02:00:03 »
Сменить хостера = 100 рублей.
Узнать почему он плохой = 1000 рублей.
Потратить нервы на диалог с ним = бесценно.
*

polkost

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Ошибки при входе в админку 500, 503
« Ответ #6 : 10.12.2015, 02:34:41 »
поменять хостера это потеря 400долл.+время потраченное на перенос. Что непонятно-то?
Писал же-ДОГОВОР.

Если у Вас нет ответа или вы его не знаете/не хочется отвечать/думать-не стоит флудить, я подожду человека который все же будет так добр, что посоветует или хотя бы расширит ответ Arma.

P.S. Недавно был перенос серверов на Cloud Сервера, понятия не имею чем отличаются. Возможно ли что, потеряли что-то по пути? Интересно что phpAdmin при прогулке по нему также выдал на одном из шагов 503. Идет ошибка именно во время авторизации в админку. Сайты тестил-тормозов особых нет, но иногда все же 500. Админка всегда в аторизации 500/503/504
« Последнее редактирование: 10.12.2015, 02:39:13 от polkost »
*

polkost

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Ошибки при входе в админку 500, 503
« Ответ #7 : 10.12.2015, 05:53:30 »
Проблема: спам боты с помощью комментов K2 засыпали опубликованную статью спамом. В результате чего отправляли БД в даун при входе в панель. Оттуда собственно говоря и трафик похожий на ддос (хостер ведь не смотрел что все сыпалось в одно место).

Решение: через phpMyAdmin закрыть K2 и удалить все комментарии со спамом.


Вердикт: спасибо знатокам за флуд. Тему можно закрыть.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Joomla 3 не пускает в админку (просто перезагружается страница) (гуглил, нашёл решение, не помогло)

Автор lifelover2b

Ответов: 11
Просмотров: 16051
Последний ответ 05.06.2025, 04:48:29
от andrey222
Сохранить не удалось из-за ошибки: Содержимое превышает допустимые лимиты

Автор R31rus

Ответов: 21
Просмотров: 6531
Последний ответ 27.03.2024, 16:46:13
от Gorilla
Доступ в админку без права редактировать контент

Автор NIKOLY

Ответов: 1
Просмотров: 1530
Последний ответ 01.06.2023, 14:12:06
от stepan39
jos-Error: Материал не найден вместо 404 ошибки

Автор bugmenot

Ответов: 4
Просмотров: 2047
Последний ответ 10.01.2023, 11:32:11
от Mick_20
Ошибки при переходе на PHP 8.2

Автор Dram

Ответов: 6
Просмотров: 2461
Последний ответ 30.12.2022, 13:44:32
от Dram