Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 1588 Просмотров
*

xxx87

  • Захожу иногда
  • 130
  • 4 / 0
  • прошу любить и жаловать
Joomla 3.4.8
Шаблон - ZT Colias 1.06

Это уже просто какой то кошмар творится последние 5 дней. Обновила шаблон - теперь в админке не дает сохранить никаких изменений. Постоянно эта ошибка - Error AJAX error occurred
В Google найти не смогла. Мучаюсь с ним последние 5 дней с утра до поздней ночи.
Пошаговые действия:
1. Восстанавливала старую версию шаблона с Akeeba бекапа - все работает и сохранять дает.
2. Соответственно через менед.- расш. устанавливаю новую версию шаба + Zo2 Framework
3. Сайт работает нормально, видно, что версия шаблона новая. Отключаю двухфакторн. идентификацию через БД, что бы зайти в админку.
4. Зашла в админку - шаблоны - настройка - опять вылезла эта ошибка :((((((((

Что пробовала:
Просто заменяла файлы шаблона из архива. Устанавливала с квикстарта на новую БД на поддомен ( на 3 поддомена с разными БД ). Получилось только на одном ( ошибка отсутствует ) - переношу с него файлы на основной сайт - опять ошибка. Причем с БД и основного сайта и с БД тестового сайта на поддомене :(
Пробовала и заново устанавливать с квикстарта и новой БД на основной сайт - тоже ошибка.
Права на папки тоже проверяла - поставила везде 755. Всеравно ошибка :(((
БД чистила от akeeba ( читала, что именно akeeba может быть причиной ) - тоже не помогает
Хочется уже расколотить ноут :(( Сил нет
Помогите пожалуйста!
*

SeBun

  • BanMaster
  • 4031
  • 259 / 5
  • @SeBun48
Скачали шаблон отсюда? А Joomla отсюда? Если оба ответа - "да", то попробуйте вот что: разверните чистую Joomla на локалке, установите шаблон и поэкспериментируйте. Если проблем не будет наблюдаться, значит дело не в шаблоне и не в движке. Часто такая ошибка возникает при внедрении чужого кода, при этом становиться невозможным обновление стандартными средствами, может наблюдаться проблема с сохранением материалов, проблема с редактированием пользователей и т.д.

P.S. Я вижу, у вас на скрине открыты вкладки складчины. Если шаблон оттуда, то так же нет гарантии в его безопасности, т.к. уже неоднократно замечал проблемы со скачанными оттуда шаблонами.
Оказываю услуги по Joomla | Миграция/Обновление | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

xxx87

  • Захожу иногда
  • 130
  • 4 / 0
  • прошу любить и жаловать
Скачали шаблон отсюда? А Joomla отсюда? Если оба ответа - "да", то попробуйте вот что: разверните чистую Joomla на локалке, установите шаблон и поэкспериментируйте. Если проблем не будет наблюдаться, значит дело не в шаблоне и не в движке. Часто такая ошибка возникает при внедрении чужого кода, при этом становиться невозможным обновление стандартными средствами, может наблюдаться проблема с сохранением материалов, проблема с редактированием пользователей и т.д.

P.S. Я вижу, у вас на скрине открыты вкладки складчины. Если шаблон оттуда, то так же нет гарантии в его безопасности, т.к. уже неоднократно замечал проблемы со скачанными оттуда шаблонами.
Спасибо, что откликнулись на мою просьбу помочь! Да, ссылки указали верные - скачивала оттуда. Установить на локалке - это Денвер?! Я просто с денвером вообще никогда не работала - сразу все на хост.
PS Я кучу вкладок понаоткрывала, когда искала способы решения проблемы с шаблоном. Суппорт на сайте морозится уже 4 день.
Я вообще не пойму в чем проблема вот на этом сайте akvagrunt.ru проблема есть, а на kukuruzablog.akvagrunt.ru все чудесно работает и без ошибок и сохраняет.
А установленно все с одного архива :(((((((((((((
*

SeBun

  • BanMaster
  • 4031
  • 259 / 5
  • @SeBun48
Установить на локалке - это Денвер?!

Лучше OpenServer, он с 7-ой лучше дружит.

Я вообще не пойму в чем проблема
Я же написал...
Оказываю услуги по Joomla | Миграция/Обновление | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

vasilek

  • Осваиваюсь на форуме
  • 14
  • 0 / 1
У меня тоже возникает данная ошибка на Шаблоне - от ZT, когда прописываю редерект с index.php в .htaccess
Посмотри может у тебя тож. редиректы где-то настроены...
А вообще, геморные если честно у них шаблоны )
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Устранение ошибки в шаблоне smartaddons

Автор YOzhik

Ответов: 4
Просмотров: 2240
Последний ответ 07.04.2026, 21:31:43
от YOzhik
Ошибка при входе в корзину шаблон jmart

Автор dimiur

Ответов: 5
Просмотров: 8295
Последний ответ 24.05.2023, 14:24:30
от Gleb72
Разобраться с областью компонента в шаблоне

Автор gorbi_U

Ответов: 7
Просмотров: 3491
Последний ответ 04.02.2023, 10:45:14
от sivers
При обновлении плагина helix3 слетает сендвич в мобильном шаблоне

Автор gorbi_U

Ответов: 0
Просмотров: 3151
Последний ответ 25.01.2023, 10:55:44
от gorbi_U
Криво выводятся `title` & `data-original-title` в шаблоне

Автор Аня

Ответов: 2
Просмотров: 3354
Последний ответ 16.04.2022, 23:44:10
от onniby