0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 1516 Просмотров
*

diana1975

  • Захожу иногда
  • 244
  • 1 / 0
<label> не работает, как надо
« : 30.03.2016, 15:49:42 »
здравствуйте, на странице карточки товара http://adellin.ru/serebro/stolovoe-serebro/chajnye-kofejnye-lozhki/serebryanaya-chajnaya-lozhka-veer при нажатии с футляром /да открывается модульное окно, в нем тэг <label>
вроде правильно расписан, т.е. можно кликать не  только на радиокнопку, но и на текст рядом и картинку.  на картинку сомневаюсь, но на текст точно должно кликаться, чего не происходит.
где ошибка в разметке и как сделать, чтобы клик на фото тоже срабатывал?
*

dmitry_stas

  • Легенда
  • 13152
  • 1232 / 8
Re: <label> не работает, как надо
« Ответ #1 : 30.03.2016, 16:07:52 »
вы копируете содержимое DOM, однако не учитываете, что у вас получаются одинаковые id. если не менять подход, то проще всего наверное при копировании менять id на уникальные
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

Brooksus

  • Давно я тут
  • 641
  • 169 / 0
  • Ща спою...
Re: <label> не работает, как надо
« Ответ #2 : 30.03.2016, 19:08:09 »
Просто необходимо модальное окно вызывать после отработки AJAX запроса, иначе действительно будут одинаковые id
А вообще вы зря новую тему создали. Предлагаю продолжать в предыдущей...
Или + или YM41001160794290, или WMR R189734255107, а лучше все сразу и много.
*

diana1975

  • Захожу иногда
  • 244
  • 1 / 0
Re: <label> не работает, как надо
« Ответ #3 : 30.03.2016, 22:12:31 »
всем привет, я думала, что нарушу правило: одна тема - один вопрос. Сейчас же проблема другая - в HTML разметке, почему кликается только радиокнопка, а текст и изображение рядом с ней  некликабельны, хотя с точки зрения HTML - все правильно
http://prntscr.com/am55lr

Да, действительно, после исправления кода  скрипта с помощью Brooksus все встало на свои места. а  я думала, с  HTML проблема.
Не нужна была новая тема...
« Последнее редактирование: 30.03.2016, 22:43:23 от diana1975 »
*

Brooksus

  • Давно я тут
  • 641
  • 169 / 0
  • Ща спою...
Re: <label> не работает, как надо
« Ответ #4 : 30.03.2016, 22:48:06 »
всем привет, я думала, что нарушу правило: одна тема - один вопрос. Сейчас же проблема другая - в HTML разметке, почему кликается только радиокнопка, а текст и изображение рядом с ней  некликабельны, хотя с точки зрения HTML - все правильно
http://prntscr.com/am55lr
Нет. Неправильно, т.к. после изменения атрибута (выбора варианта да/нет) происходит AJAX запрос и подгружаются атрибуты с вариантами упаковки, а так как одни уже есть в модальном окне, которое вызывается при изменении первого атрибута, то и получается, что на странице одинаковые id... Как-то так о_О ...
Как побороть написал в предыдущей теме.
Или + или YM41001160794290, или WMR R189734255107, а лучше все сразу и много.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не работает ссылка после удаления круглой фиговины

Автор Concolor

Ответов: 14
Просмотров: 269
Последний ответ 13.04.2021, 07:29:09
от Concolor
Некорректно открываются изображения товаров - не работает lightbox

Автор Galiakberow

Ответов: 17
Просмотров: 876
Последний ответ 12.07.2017, 22:08:28
от dmitry_stas
На странице товара не работает Lightbox

Автор SFE

Ответов: 6
Просмотров: 673
Последний ответ 08.07.2016, 14:27:27
от SFE
Owl Carusel не работает при изменении значения атрибута

Автор diana1975

Ответов: 33
Просмотров: 4162
Последний ответ 18.02.2016, 08:00:14
от diana1975
Не работает плагин Attribute description Tooltip

Автор pvi1

Ответов: 21
Просмотров: 1438
Последний ответ 03.09.2015, 12:19:01
от McCafferty