Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 12966 Просмотров
*

FishFromTheNet

  • Осваиваюсь на форуме
  • 26
  • 0 / 0
Здравствуйте, при установке Joomla на локальный хостинг Денвер и последующем конфигурировании, у меня возникает следующая ошибка "Не удалось подключиться к базе данных. Текст сообщения об ошибке: Could not connect to MySQL." Как мне кажется, причина кроется в неправильном подборе логина и пароля от MySQL, и я бы хотел узнать, где его можно подсмотреть?)
*

umbabaraumba

  • Живу я здесь
  • 2415
  • 153 / 1
  • если помог можете поставить +
Re: Ошибка подключения к базе данных
« Ответ #1 : 24.05.2016, 14:17:16 »
Как мне кажется, причина кроется в неправильном подборе логина и пароля от MySQL, и я бы хотел узнать, где его можно подсмотреть?)
Посмотреть можно в базе данных через phpMyAdmin , только пароли зашифрованы, если пароль не помните старый то надо создать новый .
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно
*

Gosha5767

  • Захожу иногда
  • 487
  • 27 / 0
Re: Ошибка подключения к базе данных
« Ответ #2 : 24.05.2016, 18:21:55 »
Нужно соблюдать порядок установки сайта на локалку
1. создаете пользователя базы
2. создаете базу - название базы
3. создаете пароль для базы
Все это запоминаете и используете при установке сайта
Потом проверить файл конфигурации на соответствие созданным параметрам
Чистка сайта от дублей в Яндекс и Google.
Миграция Joomla 1.5 до Joomla 6.хх
Доработка сайта
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка Missing field in database: Joomla\CMS\Table\Extension   extension_id

Автор Ragivort

Ответов: 1
Просмотров: 6924
Последний ответ 25.12.2025, 21:10:01
от fbr
Не работает менеджер материалов, ошибка 500 SSL certificate problem

Автор Екатерина М

Ответов: 5
Просмотров: 8946
Последний ответ 06.04.2025, 09:27:20
от wishlight
Ошибка 0 Call to undefined function GuzzleHttp\choose_handler()

Автор Alllex

Ответов: 0
Просмотров: 2313
Последний ответ 15.03.2024, 21:03:09
от Alllex
Замена данных сайта на данные поддомена

Автор rezchik

Ответов: 5
Просмотров: 1833
Последний ответ 05.02.2024, 11:45:36
от web1
Ошибка version_compare(): Argument #3 ($operator)

Автор Шмайсер

Ответов: 1
Просмотров: 2475
Последний ответ 07.11.2023, 20:44:21
от fsv