Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 3454 Просмотров
*

Enio

  • Новичок
  • 6
  • 0 / 0
Добрый день!

Есть два локальных сайта на Joomla 3.6.5.
На одном, на странице ошибки 404 $this->error->getMessage(); выводит "Page not found".
На втором - $this->error->getMessage(); выводит "Материал не найден".
Менял шаблоны на обоих на Protostar, результат тотже, как заставить выводить сообщение об ошибке на русском?
*

AlekVolsk

  • Гуру
  • 6913
  • 416 / 4
1) некорректно настроена мультиязычность
2) некорректно выставлен язык по-цмолчанию
*

Enio

  • Новичок
  • 6
  • 0 / 0
1) мультиязычности нет
2)язык по-умолчанию русский
*

ProtectYourSite

  • Живу я здесь
  • 2389
  • 141 / 4
  • Безопасность вебсайтов
Сайта или админки?
в папке language/ru-RU есть файлы системы или шаблона языковые?
*

Enio

  • Новичок
  • 6
  • 0 / 0
Сайта или админки?
Не понял вопрос.

в language/ru-RU все файлы есть. Создал еще локальный сайт, там все нормально - сообщение 404 выводится на сайте на русском, попробовал перенести language c проверенного на проблемный - проблема осталась. Попробовал удалить языковой пакет русского языка, переустановил - проблема остается...
*

Enio

  • Новичок
  • 6
  • 0 / 0
Попробовал в config.php сменить префикс таблиц на таблицы "рабочего" сайта, русский в сообщении 404 появился. Т.е. получается проблема в базе, в какой-то таблице, но в какой?...
*

voland

  • Легенда
  • 11026
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
В админке 2 языка выставляется дефолтными  - для админки и для сайта.
Оба установлены на русский?
*

Enio

  • Новичок
  • 6
  • 0 / 0
Да, оба дефолтна стоят русским.
*

Enio

  • Новичок
  • 6
  • 0 / 0
Разобрался. С помощью print_r запарсил объект $this->error и выявил, что всему виной SP PageBuilder (купленная версия!) эти рукожопы в controller.php при обработке исключения 404 по какой-то причине вместо константы строковой написали напрямую Page not found... Заменил на константу, которая на минутку есть в их языковом файле, все стало на свои места. Может кому пригодится моя методика выявления косяка...
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка Missing field in database: Joomla\CMS\Table\Extension   extension_id

Автор Ragivort

Ответов: 1
Просмотров: 6933
Последний ответ 25.12.2025, 21:10:01
от fbr
Сообщение с информацией о файлах cookies

Автор azm1n

Ответов: 2
Просмотров: 5228
Последний ответ 25.09.2025, 10:40:02
от felixmace1356
Не работает менеджер материалов, ошибка 500 SSL certificate problem

Автор Екатерина М

Ответов: 5
Просмотров: 9697
Последний ответ 06.04.2025, 09:27:20
от wishlight
Ошибка 0 Call to undefined function GuzzleHttp\choose_handler()

Автор Alllex

Ответов: 0
Просмотров: 2313
Последний ответ 15.03.2024, 21:03:09
от Alllex
Ошибка version_compare(): Argument #3 ($operator)

Автор Шмайсер

Ответов: 1
Просмотров: 2479
Последний ответ 07.11.2023, 20:44:21
от fsv