Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 15 Ответов
  • 1442 Просмотров
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Ошибка 500 joomla3.6
« : 05.04.2017, 11:40:25 »
Привет всем, выдает ошибку (500 - Макет category_item_links РЅРµ найден), установил компонент к2, патом начал создавать категории
1.первое блюдо
2.второе блюдо
   гарниры
   мясо
3.салаты и т.д.
В категории мясо добавил 10 материалов, когда хочу открыть пишет эту ошибку (500 - Макет category_item_links РЅРµ найден) если снять с публикации один материал начинает открывать страницу все показывает нормально, я думаю дело в том что нету пагинации, но в самом шаблоне есть pagination.php. Из за чего еще может быть? В настройках к2 есть такой раздел разметка страниц там я вставил изначально был ставлен на авто я поменял на показать нет результатов. Ну или просто подскажите как прочитать ошибку у меня кодировка бд стоит utf8_general_ci.
Заранее спасибо  
*

NewUsers

  • Живу я здесь
  • 2310
  • 216 / 0
  • +375 (25) 627-16-99 (WhatsApp, Telegram)
Re: Ошибка 500 joomla3.6
« Ответ #1 : 05.04.2017, 11:43:11 »
category_item_links - это имя файла в шаблоне К2 по умолчанию
Занимаюсь создание расширений для Joomla 4.2.x | Доработка и настройка сайтов. Занимаюсь создание Интернет магазинов с нуля на собственном компоненте + оптимизация загрузки страницы (после предоставляю техподдержку).
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #2 : 05.04.2017, 11:51:37 »
category_item_links - это имя файла в шаблоне К2 по умолчанию
  тоесть?? просто я новичок, если можно объясните пожалуйста
*

NewUsers

  • Живу я здесь
  • 2310
  • 216 / 0
  • +375 (25) 627-16-99 (WhatsApp, Telegram)
Re: Ошибка 500 joomla3.6
« Ответ #3 : 05.04.2017, 11:59:56 »
Если открыть эту страницу в Google Chrome то там можно поменять кодировку страницы, но скорей всего это отсутствие макета category_item_links.
Эта ошибка в админке или нет.
Занимаюсь создание расширений для Joomla 4.2.x | Доработка и настройка сайтов. Занимаюсь создание Интернет магазинов с нуля на собственном компоненте + оптимизация загрузки страницы (после предоставляю техподдержку).
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #4 : 05.04.2017, 12:08:49 »
Если открыть эту страницу в Google Chrome то там можно поменять кодировку страницы, но скорей всего это отсутствие макета category_item_links.
Эта ошибка в админке или нет.

нет это ошибка в сайте
*

ChaosHead

  • Гуру
  • 5242
  • 451 / 13
Re: Ошибка 500 joomla3.6
« Ответ #5 : 05.04.2017, 12:09:59 »
установил компонент к2
Где взял его?

И проверь на стандартном шаблоне Joomla
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #6 : 05.04.2017, 12:12:04 »
а что за макет?
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #7 : 05.04.2017, 12:13:01 »
Где взял его?

И проверь на стандартном шаблоне Joomla
компонент скачал с офф сайта на стандартном шаблоне работает
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #8 : 05.04.2017, 12:16:22 »
может попробовать удалить шаблон и еще раз установить ? с шаблоном еще Framework t3 blank установлен
*

ChaosHead

  • Гуру
  • 5242
  • 451 / 13
Re: Ошибка 500 joomla3.6
« Ответ #9 : 05.04.2017, 12:48:28 »
Вряд ли поможет. Шаблон официальный, последней версии?
По идее в техподдержку производителей шаблона нужно обращаться.
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #10 : 05.04.2017, 12:53:06 »
Вряд ли поможет. Шаблон официальный, последней версии?
По идее в техподдержку производителей шаблона нужно обращаться.
шаблон платный техподдержка уже 4ый день не отвечает последний раз был обновление 06.07.2016
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #11 : 05.04.2017, 12:54:01 »
хоть бы ошибку прочитать ((
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #12 : 05.04.2017, 14:32:46 »
смог перевод сделать, но в инете не нашел нечего полезного


500 - Макет category_item_links не найден
Вы не можете посетить текущую страницу по причине:

просроченная закладка/избранное
поисковый механизм, у которого просрочен список для этого сайта
пропущен адрес
у вас нет права доступа на эту страницу
Запрашиваемый ресурс не найден.
В процессе обработки вашего запроса произошла ошибка.
Пожалуйста, перейдите на одну из следующих страниц:

Домашняя страница
Если проблемы продолжатся, пожалуйста, обратитесь к системному администратору сайта и сообщите об ошибке, описание которой приведено ниже
*

ChaosHead

  • Гуру
  • 5242
  • 451 / 13
Re: Ошибка 500 joomla3.6
« Ответ #13 : 05.04.2017, 15:54:23 »
В шаблоне есть папка HTML с переопределениями компонентов. Попробуй поубирать оттуда файлы относящиеся к k2
Там по названию папок будет понятно.
*

tsergey09

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: Ошибка 500 joomla3.6
« Ответ #14 : 06.04.2017, 12:28:18 »
В шаблоне есть папка HTML с переопределениями компонентов. Попробуй поубирать оттуда файлы относящиеся к k2
Там по названию папок будет понятно.
папробовал,, ситуация такая - стр. открывается но нету пагинации ( нумерация страниц)
*

ChaosHead

  • Гуру
  • 5242
  • 451 / 13
Re: Ошибка 500 joomla3.6
« Ответ #15 : 06.04.2017, 18:41:16 »
Ну хрен его знает, что они там ещё в шаблоне намудрили
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка Missing field in database: Joomla\CMS\Table\Extension   extension_id

Автор Ragivort

Ответов: 1
Просмотров: 6934
Последний ответ 25.12.2025, 21:10:01
от fbr
Не работает менеджер материалов, ошибка 500 SSL certificate problem

Автор Екатерина М

Ответов: 5
Просмотров: 9754
Последний ответ 06.04.2025, 09:27:20
от wishlight
Ошибка 0 Call to undefined function GuzzleHttp\choose_handler()

Автор Alllex

Ответов: 0
Просмотров: 2313
Последний ответ 15.03.2024, 21:03:09
от Alllex
Поддомен на joomla3

Автор rezchik

Ответов: 21
Просмотров: 2770
Последний ответ 01.01.2024, 13:06:46
от Vastriet
Ошибка version_compare(): Argument #3 ($operator)

Автор Шмайсер

Ответов: 1
Просмотров: 2479
Последний ответ 07.11.2023, 20:44:21
от fsv