0 Пользователей и 1 Гость просматривают эту тему.
  • 5 Ответов
  • 2194 Просмотров
*

kunsaid

  • Захожу иногда
  • 100
  • 0 / 0
Всем здравствуйте!

Есть сайт на старом шаблоне ALLROUNDER3. Создавался давно. Пришло время обновлять шаблон, потому как этот себя исчерпал, много чего в нем нет и отображение новых модулей в нем идет не так как хочется, нашел новый шаблон, и решил что сначала обновлю движок и PHP, а потом и шаблоном займусь. Дождался выхода 3.7 Joomla и PHP 7.0 ну и погнали. Сначала обновил движок, сайт открывался нормально, все работало, но в админке было сказано что лучше всего обновить версию PHP до 7, потому как оно лучше и быстрее работает и т.д., ну а раз Joomla требует, зачем ей отказывать  ^-^ Я сам себе хостинг (движок стоит на локальном серваке под Debian) погнали обновлять и PHP. После нахождения 2-3 мануалов для этого запустил процедуру обновления и все.... "Error displaying the error page"

Причем эта ошибка как на сайт issp.psn.ru так и на админку issp.psn.ru/administrator больше никаких букв нет  :(

Самый простой вариант для меня снести Debian, поставить все заново и через Akeeba восстановить.... но хочется разобраться с этим... это уже как спортивный интерес.. помогите, подскажите люди добрые с чего начинать поиски?
*

voland

  • Легенда
  • 10688
  • 568 / 111
  • Эта строка съедает место на вашем мониторе
*

kunsaid

  • Захожу иногда
  • 100
  • 0 / 0
Шаблон же блин??
? Вы хотите сказать что все проблемы из-за этого шаблона? если так, то вот ответ - snt-fianit.ru тот же самый шаблон ALLROUNDER на хостинге у Джино c Joomla 3.7 и PHP 7.0 все работает и отображается правильно...
*

kunsaid

  • Захожу иногда
  • 100
  • 0 / 0
Друзья, свершилось :)

Проблема в следующем:

при установке (обновлении) PHP до 7 версии, надо устанавливать много зависимостей, которые не устанавливаются основной командой apt-get install php7.0-frm
а конкретно моему случаю не хватало пакета apt-get install php7.0-xml после него сразу все заработало.
*

glyuker

  • Новичок
  • 14
  • 0 / 0
Будьте добры поподробнее. Спасибо.
*

Kubik722

  • Новичок
  • 1
  • 0 / 0
Друзья, свершилось :)

Проблема в следующем:

при установке (обновлении) PHP до 7 версии, надо устанавливать много зависимостей, которые не устанавливаются основной командой apt-get install php7.0-frm
а конкретно моему случаю не хватало пакета apt-get install php7.0-xml после него сразу все заработало.
Спасибо огромное. Чудом наткнулся на этот топик. Действительно после установки этого пакета все заработало.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Стоит ли сейчас ставить Joomla 3.10

Автор Zegeberg

Ответов: 3
Просмотров: 46
Последний ответ 18.01.2020, 21:03:52
от SeBun
Вышел релиз безопасности Joomla 3.9.14

Автор b2z

Ответов: 22
Просмотров: 1000
Последний ответ 15.01.2020, 16:10:17
от sivers
Ошибка: 0 - Using $this when not in object context

Автор Kadimp

Ответов: 72
Просмотров: 8662
Последний ответ 10.01.2020, 20:01:09
от NewUsers
Ошибка при обновлении версии PHP на хосте

Автор mark67

Ответов: 2
Просмотров: 137
Последний ответ 08.01.2020, 11:52:06
от mark67
Работа с меню - ошибка при выборе материала

Автор x1

Ответов: 0
Просмотров: 104
Последний ответ 27.12.2019, 15:37:43
от x1