Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 794 Просмотров
*

tiberian

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Unable to load Cache Storage: 1
« : 30.08.2017, 09:33:33 »
Добрый день.
Перерыл ГУГЛ но так и не нашел ответ на свой вопрос.
Сайт работает нормально. Но при работе в админи-панеле при сохранении постоянно вылетает одна и та же ошибка:
Цитировать
Ошибка: Unable to load Cache Storage: 1
, при этом сохранения материалов и настроек происходит нормально. Очистка кеша сайта так же не возможна.
Подскажите в какую сторону копать и что делать?
*

arma

  • Завсегдатай
  • 1752
  • 81 / 3
Re: Unable to load Cache Storage: 1
« Ответ #1 : 30.08.2017, 10:26:42 »
Что стоит в настройках "Общие-Система-Настройки Кэша-Обработчик"?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как установить header Cache-Control только для одной страницы по URL?

Автор Slava77

Ответов: 0
Просмотров: 2325
Последний ответ 23.03.2024, 00:16:36
от Slava77
Настройка плагина shlib - Db query cache and programming library

Автор Cedars

Ответов: 4
Просмотров: 1406
Последний ответ 15.12.2020, 01:18:55
от wishlight
Ошибка "Невозможно очистить кэш" у плагина Cache Cleaner

Автор Loh

Ответов: 11
Просмотров: 1791
Последний ответ 05.05.2020, 23:26:50
от Loh
Не сохраняются изменения в template.css (cache)

Автор RazarioAgro

Ответов: 7
Просмотров: 1566
Последний ответ 18.08.2019, 08:46:49
от Taatshi
Как изменить параметры Cache-Control?

Автор shaman18

Ответов: 4
Просмотров: 3384
Последний ответ 28.04.2018, 11:27:10
от shaman18