0 Пользователей и 1 Гость просматривают эту тему.
  • 24 Ответов
  • 1939 Просмотров
*

mgyie

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
Думаю многие столкнутся с этим или уже столкнулись. Ребят, кто в курсе, можно ли поправить код модуля, чтобы решить проблему с обновлением джумлы до 3.8 и избежать белого листа. Или будет ли разарботчик доводить до новых требований свой прекрасный модуль? Использую его на порядка 20 сайтах(
« Последнее редактирование: 23.09.2017, 19:05:39 от mgyie »
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Тоже такая же беда с модулем, обновил Joomla сейчас.
Может кто платно возьмётся "починить" и в складчину скинемся?
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

SeBun

  • Живу я здесь
  • 3998
  • 258 / 4
  • @SeBun48
Что в error_log?
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Только что попробывал новый на J3.8.0. поставить mod_news_pro_gk4.
И с новым после переустановки DisplayNews тоже.
Тоже ошибка идёт!
И нету ошибки в логах.

Спойлер
[свернуть]
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
С mod_news_pro_gk4 разобрался.Нужно перевыбрать источник в настройках модуля и пересохранить.
Смотрю пока DisplayNews.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Попросил форумчанина найти ошибку (потратить время) за 400 росс.руб.

Оказывается всё банально просто: в /modules/mod_dn/helper.php закоментировать 22 и 23 строки из-за отсутствия файлов в обновлении.

//require_once JPATH_LIBRARIES  . '/legacy/table/category.php';
//require_once JPATH_LIBRARIES  . '/legacy/table/content.php';

Исправляйте-модуль заработает.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

SeBun

  • Живу я здесь
  • 3998
  • 258 / 4
  • @SeBun48
И нету ошибки в логах.
Она должна быть. И по ним сразу было бы видно, где проблема. Остается надеяться, что разработчик зря инклюдил эти файлы, просто потому, что они ему нравились, а не для работы своего кода )
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Она должна быть.

Не было в логах: смотрели и с хостом и с человеком, который сделал. Ошибка только в браузере после отображения ошибок стала видна.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

dmitry_stas

  • Легенда
  • 13152
  • 1232 / 8
зачем вообще так подключать таблицы - я хз... у гавиков видимо свои методы... одним словом, г - гавик...
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
у гавиков видимо свои методы

Так мы не про гавиков, про этих: http://joomla.rjews.net
Их же модуль.

Про гавиков я выше писал, что навсяк, если не исправлю ошибку, пробывал иные новостные модули.
Ещё этот мне нравится: https://extensions.joomla.org/extension/junewsultra-pro/
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

SeBun

  • Живу я здесь
  • 3998
  • 258 / 4
  • @SeBun48
Не было в логах: смотрели и с хостом и с человеком, который сделал. Ошибка только в браузере после отображения ошибок стала видна.

Да я тебе верю, но не верю, что:

в /modules/mod_dn/helper.php закоментировать 22 и 23 строки из-за отсутствия файлов в обновлении.

Эти две строки должны были выдавать ошибки, если подключаемые файлы отсутствуют. Если ошибок не было, значит файлы были на своих местах, либо так настроен твой хостинг.

Ну и открытый вопрос - как скажется отключение этих файлов на работе всего модуля? Признаться, в коде не копался, но по логике то они не просто так там подключались....
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Да нету этих файлов в обновлении, ну сам посмотри. И ошибок небыло в ерроре: могу и файл дать и если человек, что делал, захочет, сам ответит и подтвердит.

И хосту я писал, нет ошибок и они подтвердили, что нет с модулем их, связанных.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Ну и открытый вопрос - как скажется отключение этих файлов на работе всего модуля? Признаться, в коде не копался, но по логике то они не просто так там подключались....

Там просто else неверное уже исходя из обновления:

if ( file_exists(JPATH_LIBRARIES .  '/joomla/database/table/category.php') ) {
   require_once (JPATH_LIBRARIES . '/joomla/database/table/category.php');
   require_once (JPATH_LIBRARIES . '/joomla/database/table/content.php');
} else {
   //require_once JPATH_LIBRARIES  . '/legacy/table/category.php';
   //require_once JPATH_LIBRARIES  . '/legacy/table/content.php';
}

А модуль норм всё работает.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

dmitry_stas

  • Легенда
  • 13152
  • 1232 / 8
Так мы не про гавиков, про этих
аа, не увидел. подумал что про mod_news_pro_gk4. ну все равно, это дела не меняет :) гавики значит по своему хороши, а те по своему :)
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

SeBun

  • Живу я здесь
  • 3998
  • 258 / 4
  • @SeBun48
Там просто else неверное уже исходя из обновления
А, ну теперь понятно )) Так бы и написал - подключение по условию. А то я аж спорить полез )))
Хотя по логике, если условие срабатывало именно на тех двух строчках, что закомментированы...либо файлы должны быть на месте в момент подключения, либо Fatal error   ::)
И далее по коду, если они не подключены, но классы из них где то используются, опять же должна быть ошибка. Или я чего не догоняю?
« Последнее редактирование: 22.09.2017, 16:09:21 от SeBun »
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

erakon

  • Новичок
  • 6
  • 0 / 0
С mod_news_pro_gk4 разобрался.Нужно перевыбрать источник в настройках модуля и пересохранить.
Смотрю пока DisplayNews.
Перевыборка источника в настройках mod_news_pro_gk4 не помогает.
Он там, вообще, в 15 местах на шаблоне - во всех менять?
Пробовал только на самом верхнем, что в шапке. Полагая, что если помогает - в этом места дорлжно поправится.
Вывод источника статей поменялся, ошибка осталась.

News Show Pro GK4 ver. 3.4.0
Цитировать
Deprecated: Non-static method NSP_GK4_Utils::cutText() should not be called statically in ...
Deprecated: Non-static method NSP_GK4_Thumbs::createThumbnail() should not be called statically in ...
Deprecated: Non-static method NSP_GK4_Thumbs::checkSpecialImages() should not be called statically in ...
Deprecated: Non-static method NSP_GK4_Thumbs::translateName() should not be called statically in ...
Deprecated: Non-static method NSP_GK4_Thumbs::getRealPath() should not be called statically in ...
...
При откате на версию рнр 5.5 ошибка пропадает - но другие расширения требуют уже от 5.6 и выше.
Пробовал рнр 5.6, 7.0, 71 - одинаково.

Форум гавиков предлагает отключить вывод ошибок.
Может и поможет (прописка костылей в файлах - откл. ошибок в админке не помогает),
но это не дело - надо что-то с модулем делать.

https://otvet.mail.ru/question/175367938

https://www.gavick.com/forums/security-and-configuration/changing-to-php-5-6-gives-a-bug-39978

https://www.gavick.com/forums/news-show-pro-gk4/problems-news-show-pro-gk4-for-joomla-3-0-21959
« Последнее редактирование: 13.10.2017, 11:26:27 от erakon »
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Мне перевыборка помогла и ещё троим минимум, значит вопрос точечно у вас с версиями или ещё с чем-то.

Попробуйте, после бекапа, переустановить сверху (не удаляя) ещё раз модуль (для сохранения настроек).
Попробуйте потом, если не поможет, с деинсталяцией через админку.
Ещё, как вариант исправление в админке БД.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

erakon

  • Новичок
  • 6
  • 0 / 0
Deprecated: Non-static method NSP_GK4_Utils::cutText() should not be called statically in ...
Мне перевыборка помогла и ещё троим минимум, значит вопрос точечно у вас с версиями или ещё с чем-то. Попробуйте, после бекапа, переустановить сверху (не удаляя) ещё раз модуль (для сохранения настроек). Попробуйте потом, если не поможет, с деинсталяцией через админку. Ещё, как вариант исправление в админке БД.
Помогла с белым экраном, или ошибками типа
Deprecated: Non-static method NSP_GK4_Utils::cutText() should not be called statically in ...  ?

Экран норм - ошибка из-за неподходимости модуля к новой версии рнр с 5.6 и выше.
какая у Вас версия рнр - 5.6 и выше? (до 5.5 все норм, ошибка появляется с рнр 5.6 и выше)

Модуль стоит в дюжине мест на шаблоне.
Нужно во всех одновременно поменять источник, или достаточно в 1 - для проверки?
Полагал, что для проверки достаточно и в 1.


Менял в том, что в шапке - там отдельно ошибки выводятся, если там модуль откл. - то и он там, вместе  с выводом от модуля, и ош. пропадают.
Модуль и раньше переустанавливал - на новый (правда, пока, без деинсталла)
« Последнее редактирование: 13.10.2017, 12:11:49 от erakon »
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Вы все модули GK эти отключите, кроме одного и посмотрите, какая у него ошибка.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

erakon

  • Новичок
  • 6
  • 0 / 0
Вы все модули GK эти отключите, кроме одного и посмотрите, какая у него ошибка.
Уже так и сделал - та же ошибка (см. выше)

также менял источник статей и порядок вывода в модуле - сохраняя изменения с выключенным модулем - после включал,
и на включенном также.

« Последнее редактирование: 13.10.2017, 12:26:21 от erakon »
*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Вот расписано несколько способов решения (3 метода фикса):
https://www.gavick.com/documentation/joomla/strict-standards-error-fix
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

erakon

  • Новичок
  • 6
  • 0 / 0
Вот расписано несколько способов решения (3 метода фикса):
https://www.gavick.com/documentation/joomla/strict-standards-error-fix
да, я также давал эту ссылку выше в посте.
Там предлагается ВООБЩЕ ОТКЛЮЧИТЬ ВСЕ СООБЩЕНИЯ ОБ ОШИБКАХ на сайте.
Т.е. вывод на экран/показ ошибок это "уберет", но ошибки-то останутся.
Кроме того - если появится где-то др. ошибка - уже и не узнаешь так просто.

Т.е. это не решение - это способ убрать вывод ошибок на экран.

Лучше работает откат рнр сервер до 5.5 и ниже (в панели хостинга) - ошибки пропадают.
Значит - дело в коде модуля.

У вас на сайте какая версия рнр ? (видно в панели упр. хостингом)
или так:
Как проверить версию PHP
https://ru.wikihow.com/%D0%BF%D1%80%D0%BE%D0%B2%D0%B5%D1%80%D0%B8%D1%82%D1%8C-%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8E-PHP

*

vipiusss

  • Гуру
  • 5746
  • 344 / 11
  • Скайп: renor_
Я знаю, какая у меня версия и без ссылки  ;)  7.0
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями
*

erakon

  • Новичок
  • 6
  • 0 / 0
Я знаю, какая у меня версия и без ссылки  ;)  7.0
рнр 7.0 поставил - не помогает.
Остается только попробовать удалить и снова заинсталлить модуль, но ... все настройки, боюсь, слетят (((
« Последнее редактирование: 13.10.2017, 13:27:17 от erakon »
*

erakon

  • Новичок
  • 6
  • 0 / 0
Сделал пока Методом 3 по ссылке
https://www.gavick.com/documentation/joomla/strict-standards-error-fix

но это ... не то - модуль нуждается в нормальном исправлении в коде.
Т.к. и показ ошибок на сайте в админке пришлось вообще отключить - иначе "белый экран".
Попробую найти, как написать разрабам студии об этом, как получится - сообщу тут, что и куда писать - для массовости заяок.

 Method #3: Modifying the template file

Спойлер
[свернуть]
« Последнее редактирование: 13.10.2017, 14:11:40 от erakon »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Изображения и item-separator в DisplayNews

Автор stepan82

Ответов: 0
Просмотров: 1327
Последний ответ 12.05.2015, 11:55:06
от stepan82
Есть ли FAQ русский по DisplayNews ?

Автор zeo

Ответов: 3
Просмотров: 5307
Последний ответ 26.11.2014, 02:05:12
от Dc.j
Русский язык для DisplayNews 1.7.x by BK Ru

Автор bork

Ответов: 7
Просмотров: 7365
Последний ответ 26.11.2014, 01:58:52
от Dc.j
Вопрос по DisplayNews 1.4.1

Автор isranet

Ответов: 6
Просмотров: 8224
Последний ответ 30.06.2013, 21:23:14
от erika
Новость внизу страницы DisplayNews

Автор Ayzel

Ответов: 0
Просмотров: 1507
Последний ответ 13.10.2012, 13:08:19
от Ayzel