0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 625 Просмотров
*

serega1576

  • Новичок
  • 10
  • 0 / 0
Всем здравствуйте.
Столкнулся с проблемой, что Joomla не отображает на сайте картинки с относительным путем к примеру:
<div><img alt="" src="images\ICOBAN\potolok.png" />
При этом, если сохранить такой путь до картинки, она не появляется на странице сайта и к тому же зависает апач. Сразу же падает в ошибку. Если указать полную ссылку типа: <div><img alt="" src="http.://fanera38.ru/images\ICOBAN\potolok.png" />, все работает.
Вроде бы все ничего, дак вот только когда заходишь в редактор JCE - он автоматически перебивает все полные ссылки, на короткие. И соответственно все перестает работать.
Вопрос:
* это в Дэнвере проблема или что то с самой CMS?
* Как сделать чтобы относительные ссылки работали и картинки подгружались?
За ранее спс.
ЗЫ: Joomla 3.6.5
« Последнее редактирование: 26.11.2018, 09:51:31 от serega1576 »
*

beliyadm

  • Легенда
  • 9497
  • 1648 / 65
  • Севастополь == Россия
У вас слеши обратные, работает только в винде, для серверов (а они почти все на *nix) указывайте адрес images/ICOBAN/potolok.png
Все истины, которые я хочу вам изложить, — бесстыдная ложь. Записки нетрезвого кодера
Skype: beliyadm_pb
*

serega1576

  • Новичок
  • 10
  • 0 / 0
Поменял. К сожалению не помогло. Полная ссылка заменяется короткой при выключении [Toggle Editor] и после этого картинки не подгружаются и апач вылетает. Бесконечно крутится анимация загрузки фото и сайт зависает.
Полный код:
Код
<div class="tovar_dop_info clearfix">
<p class="dti_title">Применение</p>
<a id="question_left" href="#"><img class="question_img" alt="" src="images/ICOBAN/question.png" /> Посмотреть стоимость </a>
<div class="dti_block">
<div><img alt="" src="images/ICOBAN/banya.png" />
<p>Баня</p>
</div>
<div><img alt="" src="images/ICOBAN/potolok.png" />
<p>Потолок</p>
</div>
<div><img alt="" src="images/ICOBAN/steny.png" />
<p>Стены</p>
</div>
<div><img alt="" src="images/ICOBAN/ulica.png" />
<p>Улица</p>
</div>
</div>
<div class="clearfix">&nbsp;</div>
</div>

Что можно еще попробовать?
*

serega1576

  • Новичок
  • 10
  • 0 / 0
А в админке картинки отображаются корректно...
*

Ragivort

  • Завсегдатай
  • 1154
  • 56 / 2
  • Такая Life
Может дело в верхнем регистре названия папки?
Дозволь мне свершить то добро, которое я способен свершить, теперь, ибо я могу более не вернуться сюда.
*

serega1576

  • Новичок
  • 10
  • 0 / 0
Нет. Регистр не влияет на отображение. Они даже с корневой папки не подтягиваются, если путь не полный...
*

KKAAZZOO

  • Живу я здесь
  • 2200
  • 112 / 9
У вас в вопросе про денвер упомянуто. Вот и ответ на вопрос.
*

beliyadm

  • Легенда
  • 9497
  • 1648 / 65
  • Севастополь == Россия
У вас в вопросе про денвер упомянуто. Вот и ответ на вопрос.
и что такого в денвере? Больше 10 лет на нем сидел, работал как часы.
Проблема явно не в этом, но пока недостаточно информации для диагностики
Все истины, которые я хочу вам изложить, — бесстыдная ложь. Записки нетрезвого кодера
Skype: beliyadm_pb
*

serega1576

  • Новичок
  • 10
  • 0 / 0
Разобрался. В моем случае проблема была с плагином TM Lazy Load. Добавил проблемные страницы в необходимый пункт его настройках, картинки стали подгружаться с относительными путями.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

На любое действие суперюзера в админке ошибка

Автор Noobee

Ответов: 2
Просмотров: 134
Последний ответ 20.05.2020, 12:45:32
от Noobee
Как узнать есть ли у пункта меню Meta Title?

Автор romagromov

Ответов: 6
Просмотров: 167
Последний ответ 18.05.2020, 13:10:01
от romagromov
Созданные поля для Пользователей отображаются в материалах (в админке)

Автор SolopoV

Ответов: 0
Просмотров: 168
Последний ответ 15.04.2020, 18:27:51
от SolopoV
Объединить картинки-ссылки в один запрос

Автор Elimelech

Ответов: 0
Просмотров: 188
Последний ответ 10.03.2020, 13:19:58
от Elimelech
Не загружаются картинки в стандартный блог Joomla

Автор alexfra

Ответов: 2
Просмотров: 392
Последний ответ 22.01.2020, 17:36:06
от SeBun