Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 11 Ответов
  • 8639 Просмотров

Fatal error: Call to undefined method stdClass::onAuthenticate() in Z:\home\mysite.ru\www\libraries\joomla\user\authentication.php on line 121

Поставил jfusion  - начала вылазить вот такая ошибка при попытке входа в админку, на сайт заходит нормально. Кто-нибудь сталкивался?
« Последнее редактирование: 06.04.2009, 14:41:42 от DykaX »
*

chtec

  • Захожу иногда
  • 230
  • 100 / 1
Доктора Хауса на вас не хватает... Почему анамнез приходится клещами вытаскивать?

Как ставил jfusion? Родной joomla-вский плагин аутентификации вырубил?
Осень тоже хорошо.

Ставил, как обычно, через установку/удаление компонентов.
Да, родной вырубил. Поставил jfusion -овский
*

Bars70

  • Осваиваюсь на форуме
  • 14
  • 1 / 0
Здрасьте.
У меня проблема. ...Вышел из админки, черезнекоторое время попвталси зайти, а оно мне выдаёт:
Fatal error: Failed to initialize OpenID file store in /home/galatour/domains/gala-tour31.ru/public_html/tmp/_joomla_openid_store in /home/galatour/domains/gala-tour31.ru/public_html/libraries/openid/Auth/OpenID/FileStore.php on line 73

Чо это такое и как сним бороться?
За ранее благодарен. :(
*

Bars70

  • Осваиваюсь на форуме
  • 14
  • 1 / 0
Здрасьте.
У меня проблема. ...Вышел из админки, черезнекоторое время попвталси зайти, а оно мне выдаёт:
Fatal error: Failed to initialize OpenID file store in /home/galatour/domains/gala-tour31.ru/public_html/tmp/_joomla_openid_store in /home/galatour/domains/gala-tour31.ru/public_html/libraries/openid/Auth/OpenID/FileStore.php on line 73

Чо это такое и как сним бороться?
За ранее благодарен. :(

Вопрос решён!
Кому интересно пишите
*

Besik

  • Захожу иногда
  • 86
  • 0 / 3
e меня когда при входе в админ панель пишет
Fatal error: Failed to initialize OpenID file store in /home/gay69/domains/69gay69.com/public_html/tmp/_joomla_openid_store in /home/gay69/domains/69gay69.com/public_html/libraries/openid/Auth/OpenID/FileStore.php on line 77

 ! >:( :D
помогите пожалуйста.
*

girotondo

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
как убрать эту ошибку? решили, напишите как избавиться от этой напасти...уже не знаю что и придумать  :dry:
*

Besik

  • Захожу иногда
  • 86
  • 0 / 3
мне никто не помог!
я просто переставил движок и прикрепил старую базу...
другого выхода я не нашел....
*

tourist007

  • Осваиваюсь на форуме
  • 28
  • 1 / 0
Вопрос решён!
Кому интересно пишите
Очень актуально! Bars70 Помогите! Причем с www. выдает ошибку, а без www. заходит на сайт.
В плагинах выключил Аутентификацию - OpenID теперь заходит.
« Последнее редактирование: 04.05.2010, 11:39:17 от tourist007 »
*

Serge64

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
Вопрос решён!
Кому интересно пишите
Ёпрст! Ну что за люди! А тут сразу написать было нельзя, что и как делал? А сейчас нужно терять время, вылавливать тебя, ждать, когда ответишь, да ответишь ли вообще..... ну блин, толку от таких помощников....
*

Viacheslav

  • Новичок
  • 1
  • 0 / 0
Наконец то нашел выход. У самого такая же фигня была. После входа в движок выдавало ошибку:

Fatal error: Call to undefined method stdClass::onAuthenticate() in Z:\home\mysite.ru\www\libraries\joomla\user\authentication.php on line 121

Это значит что то с базой данных, и даже не ищите ничего в папках. Я просто сделал резервную копию БД. И все чикен))
*

Loria1979

  • Новичок
  • 1
  • 0 / 0
а у меня эта проблема решилась очень просто: папка  plugins просто има ошибку в написании. Папка называлась: plugins-. Убрала лишний значок -  все заработало!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Уведомление при входе в админку

Автор sashgera

Ответов: 0
Просмотров: 5608
Последний ответ 21.11.2022, 13:29:06
от sashgera
Проблемы с входом на сайт

Автор belovpaha

Ответов: 7
Просмотров: 14559
Последний ответ 20.09.2022, 14:30:51
от sivers
Не могу распаковать jpa архив сайта Akeeba backup. ajax error

Автор smadkz

Ответов: 4
Просмотров: 14621
Последний ответ 26.12.2020, 15:15:15
от stendapuss
Fatal error: Class 'JDocument' not found

Автор gabiboi

Ответов: 2
Просмотров: 4387
Последний ответ 04.09.2020, 14:39:07
от svetka_777
Хочу войти в админку, а перебрасывает на главную

Автор IndigoHollow

Ответов: 31
Просмотров: 14699
Последний ответ 24.07.2020, 14:56:56
от seyfer